Multiple GRE Tunnels with same source and destination address

Answered Question
Apr 15th, 2009
User Badges:

Hi,


We have the following problem :


We have two sites, site A and site B which are interconnected as following :


(Site A)--Router A---Firewall A---------WAN--------Firewall B---Router B-----(Site B)


The two routers are 3825 Cisco Routers.

On each of theses routers, there are multiple VRF created in order to separate user traffic.


Each Cisco router is interconnected with its firewall by an ip adress in the global routing table.


We wanted to create as much GRE tunnel as VRF.However, all the GRE tunnel must have the same source and destination address which is the address of the interface linked to the firewall (address in the global routing table).


Here is an exemple of our configuration :


interface Tunnel 1

ip vrf forwarding vrf_1

ip address 10.0.0.1 255.255.255.0

keepalive 10 3

tunnel destination GigabitEthernet 0/1

tunnel destination 93.2.3.2


interface Tunnel 2

ip vrf forwarding vrf_2

ip address 11.0.0.1 255.255.255.0

keepalive 10 3

tunnel destination GigabitEthernet 0/1

tunnel destination 93.2.3.2


interface Tunnel 3

ip vrf forwarding vrf_3

ip address 11.0.0.1 255.255.255.0

keepalive 10 3

tunnel destination GigabitEthernet 0/1

tunnel destination 93.2.3.2


When we set up a unique Tunnel, it works very well (Interfave Tunnel up).

But as soon as we create another tunnel with the same source and destination address, these tunnels fall down.

So, is it impossible to create Tunnels with the same source and destination address? So is there any other solution to fix our problem?


Thanks you very much for your responses


Best Regards

Correct Answer by Paolo Bevilacqua about 7 years 11 months ago

Use "tunnel key".

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Paolo Bevilacqua Wed, 04/15/2009 - 02:58
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Use "tunnel key".

Djule2804 Wed, 04/15/2009 - 04:14
User Badges:

Thank you very much! This command solved our problem.

Actions

This Discussion