Ether channel Error

Answered Question
Apr 15th, 2009
User Badges:


Hi


please find my ether channel config below


interface Port-channel1

switchport trunk allowed vlan 11-14

switchport mode trunk

no ip address


----------------------------------------

interface FastEthernet0/2

switchport mode trunk

no ip address

channel-group 1 mode on

----------------------------------

interface FastEthernet0/9

switchport mode trunk

no ip address

channel-group 1 mode on


I am not able to see port channel up


out put is pasted below

---------------------

sh etherchannel s

Flags: D - down P - in port-channel

I - stand-alone s - suspended

H - Hot-standby (LACP only)

R - Layer3 S - Layer2

u - unsuitable for bundling

U - in use f - failed to allocate aggregator

d - default port


Number of channel-groups in use: 1

Number of aggregators: 1


Group Port-channel Protocol Ports

------+-------------+-----------+-----------------------------------------------

1 Po1(SD) - Fa0/2(s) Fa0/9(s)

sh etherchannel brie

Channel-group listing:

-----------------------


Group: 1

----------

Group state = L2

Ports: 2 Maxports = 8

Port-channels: 1 Max Port-channels = 1

Protocol: -


A01-KG-DMZ-1#sh eht

A01-KG-DMZ-1#sh eht the

A01-KG-DMZ-1#sh etherchannel d

Channel-group listing:

-----------------------


Group: 1

----------

Group state = L2

Ports: 2 Maxports = 8

Port-channels: 1 Max Port-channels = 1

Protocol: -

Ports in the group:

-------------------

Port: Fa0/2

------------


Port state = Up Cnt-bndl Suspend Not-in-Bndl

Channel group = 1 Mode = On/FEC Gcchange = -

Port-channel = null GC = - Pseudo port-channel = Po1

Port index = 0 Load = 0x00 Protocol = -


Age of the port in the current state: 00d:05h:56m:10s


Probable reason: vlan mask is different

Port: Fa0/9



Port state = Up Cnt-bndl Suspend Not-in-Bndl

Channel group = 1 Mode = On/FEC Gcchange = -

Port-channel = null GC = - Pseudo port-channel = Po1

Port index = 0 Load = 0x00 Protocol = -


Age of the port in the current state: 00d:05h:56m:14s


Probable reason: vlan mask is different

Port-channels in the group:

----------------------


Port-channel: Po1

------------


Age of the Port-channel = 00d:03h:15m:04s

Logical slot/port = 1/0 Number of ports = 0

GC = 0x00000000 HotStandBy port = null

Port state = Port-channel Ag-Not-Inuse

Protocol = -



Could some one help to fix this isssue


regd

Adhitya

Correct Answer by lamav about 8 years 3 months ago

Toshi is right.


The physical interfaces as well as the logical port channel interface must be configured to pass the same vlans.


I made this point earlier.


When you dont specifically allow vlans on a trunk, you are allowing all of them by default. Remember, the logical channel must be an exact representation of the physical channels.


HTH


Victor

Correct Answer by thotsaphon about 8 years 3 months ago

Adhitya,

That's what I'm talking about.


The VLANs trunked on the port-channel interface and the member interfaces should match. If there is a mismatch, the status of the interfaces will be down


Toshi

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
lamav Wed, 04/15/2009 - 08:18
User Badges:
  • Blue, 1500 points or more

Hi, Adhitya:


For a port channel to come up successfully with all the associated links in the bundle, the configurations on each end have to be identical and hardware has to have the same capabailities.


That having been said, please make sure that:


1.) All ports are set to "switchport"


2.) All have the correct trunk encapsulation (dot1q, ISL).


3.) All are using the same trunking mode (dynamic desirable, on, etc) and that all ports are allowing the same vlans.


4.) Make sure all ports have the same speed and duplex settings (hardcode them preferably).


5.) Make sure all the ethernet cables are good and plugged into the correct ports.


You can always remove the etherchannel configuration and bring up each trunk one at aa time. When you verify all of the above, plus the fact that the ports can trunk successfully, then try adding them to the channel group.


PS When I say check all ports, I mean on both sides of the link -- all the ports involved.


HTH


Victor

adhityakarthik Wed, 04/15/2009 - 08:23
User Badges:

Hi Victor,


thanks for the updates


Here are the my answers below



1.) All ports are set to "switchport" ( its L2 Switch 2950 )


2.) All have the correct trunk encapsulation (dot1q, ISL). ( encapsulatio is dot1q at bothe ends)


3.) All are using the same trunking mode (dynamic desirable, on, etc) and that all ports are allowing the same vlans. ( All are using same mode)


4.) Make sure all ports have the same speed and duplex settings (hardcode them preferably). ( All ports has same settings)


5.) Make sure all the ethernet cables are good and plugged into the correct ports.(Cables are good)


Please help


adhitya

thotsaphon Wed, 04/15/2009 - 08:26
User Badges:
  • Gold, 750 points or more

adhitya,

Would you please post a "show interface x/x switchport" command on 4 links?



Toshi

lamav Wed, 04/15/2009 - 08:30
User Badges:
  • Blue, 1500 points or more

Also, are you sure that the trunks come up without the port channel being configured?



adhityakarthik Wed, 04/15/2009 - 08:33
User Badges:

Dear ALl




A01-KG-DMZ-1#show interfaces fa0/2 switchport

Name: Fa0/2

Switchport: Enabled

Administrative Mode: trunk

Operational Mode: down (suspended member of bundle Po1)

Administrative Trunking Encapsulation: dot1q

Negotiation of Trunking: On

Access Mode VLAN: 1 (default)

Trunking Native Mode VLAN: 1 (default)

Voice VLAN: none

Administrative private-vlan host-association: none

Administrative private-vlan mapping: none

Operational private-vlan: none

Trunking VLANs Enabled: ALL

Pruning VLANs Enabled: 2-1001

Capture Mode Disabled

Capture VLANs Allowed: ALL


Protected: false


Voice VLAN: none (Inactive)

Appliance trust: none

A01-KG-DMZ-1#show interfaces fa0/9 switchport

Name: Fa0/9

Switchport: Enabled

Administrative Mode: trunk

Operational Mode: down (suspended member of bundle Po1)

Administrative Trunking Encapsulation: dot1q

Negotiation of Trunking: On

Access Mode VLAN: 1 (default)

Trunking Native Mode VLAN: 1 (default)

Voice VLAN: none

Administrative private-vlan host-association: none

Administrative private-vlan mapping: none

Operational private-vlan: none

Trunking VLANs Enabled: ALL

Pruning VLANs Enabled: 2-1001

Capture Mode Disabled

Capture VLANs Allowed: ALL


Protected: false


Voice VLAN: none (Inactive)

Appliance trust: none

A01-KG-DMZ-1#




---------------


A01-KG-DMZ-2#show int

A01-KG-DMZ-2#show interfaces fa0/2 sw

A01-KG-DMZ-2#show interfaces fa0/2 switchport

Name: Fa0/2

Switchport: Enabled

Administrative Mode: trunk

Operational Mode: down (suspended member of bundle Po1)

Administrative Trunking Encapsulation: dot1q

Negotiation of Trunking: On

Access Mode VLAN: 1 (default)

Trunking Native Mode VLAN: 1 (default)

Voice VLAN: none

Administrative private-vlan host-association: none

Administrative private-vlan mapping: none

Operational private-vlan: none

Trunking VLANs Enabled: ALL

Pruning VLANs Enabled: 2-1001

Capture Mode Disabled

Capture VLANs Allowed: ALL


Protected: false


Voice VLAN: none (Inactive)

Appliance trust: none

A01-KG-DMZ-2#show interfaces fa0/9 switchport

Name: Fa0/9

Switchport: Enabled

Administrative Mode: trunk

Operational Mode: down (suspended member of bundle Po1)

Administrative Trunking Encapsulation: dot1q

Negotiation of Trunking: On

Access Mode VLAN: 1 (default)

Trunking Native Mode VLAN: 1 (default)

Voice VLAN: none

Administrative private-vlan host-association: none

Administrative private-vlan mapping: none

Operational private-vlan: none

Trunking VLANs Enabled: ALL

Pruning VLANs Enabled: 2-1001

Capture Mode Disabled

Capture VLANs Allowed: ALL


Protected: false


Voice VLAN: none (Inactive)

Appliance trust: none

A01-KG-DMZ-2#


lamav Wed, 04/15/2009 - 08:36
User Badges:
  • Blue, 1500 points or more

Also, are you sure that the trunks come up without the port channel being configured?


thotsaphon Wed, 04/15/2009 - 08:45
User Badges:
  • Gold, 750 points or more

Adhitya,

switchport trunk allowed vlan 11-14 Do you want to do this on both sides?



SW1:

interface Port-channel1

switchport trunk allowed vlan 11-14

switchport mode trunk

no ip address


----------------------------------------

interface FastEthernet0/2

switchport trunk allowed vlan 11-14

switchport mode trunk

no ip address

channel-group 1 mode on

----------------------------------

interface FastEthernet0/9

switchport trunk allowed vlan 11-14

switchport mode trunk

no ip address

channel-group 1 mode on



SW2:

interface Port-channel1

switchport trunk allowed vlan 11-14

switchport mode trunk

no ip address


----------------------------------------

interface FastEthernet0/2

switchport trunk allowed vlan 11-14

switchport mode trunk

no ip address

channel-group 1 mode on

----------------------------------

interface FastEthernet0/9

switchport trunk allowed vlan 11-14

switchport mode trunk

no ip address

channel-group 1 mode on



Please let us know how things work out. I always do "shut and no shut".



Toshi





adhityakarthik Wed, 04/15/2009 - 08:48
User Badges:

Dear,


U mean to say that i need to add the below commads at interfae level


switchport trunk allowed vlan 11-14


Correct Answer
thotsaphon Wed, 04/15/2009 - 09:06
User Badges:
  • Gold, 750 points or more

Adhitya,

That's what I'm talking about.


The VLANs trunked on the port-channel interface and the member interfaces should match. If there is a mismatch, the status of the interfaces will be down


Toshi

Correct Answer
lamav Wed, 04/15/2009 - 10:45
User Badges:
  • Blue, 1500 points or more

Toshi is right.


The physical interfaces as well as the logical port channel interface must be configured to pass the same vlans.


I made this point earlier.


When you dont specifically allow vlans on a trunk, you are allowing all of them by default. Remember, the logical channel must be an exact representation of the physical channels.


HTH


Victor

cisco.net Fri, 04/17/2009 - 10:59
User Badges:

@ Aditya,


As suggested by Toshi & Other...U need to configure command "switchport trunk allowed vlan 11-14" in each fastethernet / gigabit ethernet port bundled for a port channel.

Regards

Actions

This Discussion