Multi E1/T1 cards - clock issue

Unanswered Question

On a 2811 acting as gateways for CCM 4.1 I have 2 Wic cards for 2 E1, with following conf :

network-clock-participate wic 0

network-clock-participate wic 1


controller E1 0/0/0

framing NO-CRC4

pri-group timeslots 1-31 service mgcp

!

controller E1 0/1/0

framing NO-CRC4

clock source internal

pri-group timeslots 1-31 service mgcp


interface Serial0/0/0:15

no ip address

isdn switch-type primary-net5

isdn incoming-voice voice

isdn bind-l3 ccm-manager

no cdp enable

!

interface Serial0/1/0:15

no ip address

isdn switch-type primary-net5

isdn incoming-voice voice

isdn bind-l3 ccm-manager

isdn bchan-number-order ascending

no cdp enable


First E1 is connected to Provider A

Second E1 is connected to provider B


First E1 has never a problem


Second E1 loses its sync with lots of erros whether loss of frame, line code violations and eventually goes down.

I contacted the ISP the link is ok.


I think I have a clock configuration issue. I tried internal or line for second E1 but it is ok during a few minutes and goes down after 2 minutes.


any help ?




  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
mchin345 Tue, 04/21/2009 - 11:05
User Badges:
  • Silver, 250 points or more

If slips are present on the E1 line, there is a clocking problem. The Customer Premises Equipment (CPE) will need to synchronize to the clocking from the E1 provider (telco). Complete the following steps to correct this problem: check that the clock source is derived from the network. In the show controller e1 EXEC command output, look for Clock Source is Line Primary.


John Blakley Tue, 04/21/2009 - 11:21
User Badges:
  • Purple, 4500 points or more

I just had this "type" of problem on T1 cards, so I'm going to tell you how I fixed it and hopefully it will help you:


Put this in global config, but change as needed:


network-clock-select 1 T1 0/0/0


Under the controller that you want to get your timing from, put the following:


controller t1 0/0/0

clock source line primary


The difference between you and I is that I was getting timing from the same provider for three different WICs.


What the above does is tell the router that controller x is going to be the primary clocking mechanism for the other cards. Then the network-clock-select command is setting the t1 controller to be the primary clocking source for all other cards on the router.


I can't tell you how frustrated I was with fighting this, and I hope this helps your issue. I was seeing CRC, framing, input errors, and aborts before doing this.


And make sure you take of the "clock source internal" on your one controller.



HTH,


John


Actions

This Discussion