CUCM 7.0 changed hostname causes database to fail to start

Unanswered Question
Apr 15th, 2009

I have CUCM 7.0 installed and it was working with the hostname lh; I have since changed it from the CLI using "set network hostname scratchy". Now I cannot access the web page. This is the only server in the cluster - there are no subscribers.


When accessing the ccmadmin or services page, the page loads & I can try to login but it returns a "database communication error". I can access the OS web page and confirm that the publisher ip address and hostname are what I have updated the server to.


In the CLI if i run "utils dbreplication status" I get an error: Database is down; please restart the database before reattempting a status check".


I have rebooted numerous times.


When I run "utils network host scratchy" I immediately get: "hostname resolves to x.x.x.x"

The address resolved to is correct.


None of the dbreplication commands really do anything (as far as cluster resets, reset all, etc.) because there is no connection to the database.


Any thoughts on missing steps in the document for changing the hostname in CUCM 7.0 would be greatly appreciated, because it does not appear to be as simple as this document references:


http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/install/7_0_1/ipchange/ipchg701.html


Incidentally, if i run the command "run sql seelct name, nodeid from ProcessNode" it throws an error, which, in short, is that it cannot connect to the database either.


Thanks,

Duane Brennan

CCIE 15289


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
gogasca Wed, 04/15/2009 - 18:40

Hi Duane,

Are you using IP address under CCM Admin - System - Server

Are you using DNS?

DNS is enabled?


Thanks

dubrennan Thu, 04/16/2009 - 05:04


I actually hadn't started the CCM services yet, so I would assume it's just using the name at this point, which I can resolve.


I am using DNS, but it points to a non-existent DNS server; however, again, it resolves the name.


At this point it surely is easier to re-install, but i want to make sure i can get this to work for future instances.


Thanks,

Duane

Tommer Catlin Thu, 04/16/2009 - 07:43

my understanding the hostnames are tricky to change and sometimes do not work. You need tac to fix the host table on the linux platform.


You can also go into the Tomcat services in the OS and re-issue the local cert to itself so it has the new name.


are you stuck on using the hostname for resolution? You should be able to use the IP address to access the web page.



dubrennan Thu, 04/16/2009 - 07:55

I actually plan on using the IP for resolution, but I have to get to the CCMadmin page to alter the server name to use this - and I think all that is furhter down the line than my initial problem, which is that the database won't start with the different hostname, let alone the CCM service or any of that.


Regardless of using the IP or the hostname to actually access the web page, the database service is not functioning properly for the Tomcat/web service to access it.


Is there a link on how to change the Tomcat settings or the host file on a Linux server?

Danilo Molini Sat, 03/20/2010 - 03:59

Hi all,

I had a similar problem after changing hostname on a Call Mnagaer 7.1.3


After change the name and server reboot, the tomcat servce and all other related service (expecially CM Admin) remain in starting state, so the web interface not work correctly.


If you have the same issue you need to verify che certificate that call manager self generate for the cisco tomcat with the command:

show web-security


In particular you need to verify if the canonical name (CN) of the issuer and the subject is update to new name or not.


admin:show web-security
Certificate:
    Data:
        Version: 3 (0x2)
        Serial Number:
            XX:XX:XX:XX:XX:XX:XX:XX
        Signature Algorithm: sha1WithRSAEncryption
        Issuer: CN=cm1.localdomain, OU=Company, O=Comp, L=City, ST=Italy, C=IT
        Validity
            Not Before: Mar 20 10:25:37 2010 GMT
            Not After : Mar 20 10:25:37 2015 GMT
       Subject: CN=cm1.localdomain, OU=Company, O=Comp, L=City, ST=Italy, C=IT
        Subject Public Key Info:


If isn't update and you see the old name of the server, you need to run the following command:


set cert regen tomcat


for update the certificate.


After this reboot the server and you should can access to the web interface.

Aaron Harrison Sat, 03/20/2010 - 04:33

Hi


It also sounds to me like some of you haven't followed the instructions correctly:


CM5/6 : http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/install/6_1_2/ipchange/ipchg612.html

CM7 : http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/install/7_1_2/ipchange/ipchg712.html


It's very important to change the Server name or IP from the System/Servers menu in CCM, and ensure it's written/replicated before you actually change the server hostname - otherwise the DB won't start, as it doesn't find itself in the config files.


If you've done this wrong, I've previously been able to change the name/IP back, and go through the steps properly. Otherwise you may need to go to TAC.


Regards


Aaron

Actions

This Discussion