3550 obtaining default route and dns addresses

Unanswered Question
Apr 16th, 2009

ok, I may be missing something simple, but I have 2 3550's no ip routes, no default gateway set, no dns servers set, yet I can ping outside addresses, traceroute to them and resolve names miraculously, any ideas where these default routes might be coming from


interface Vlan30

ip address


interface Vlan39

ip address


ip classless

ip http server






line con 0

line vty 0 4

password 7 070A20581D0C1C09


line vty 5 15

password 7 02050D480809

no login



ussw01#sho ip route

Default gateway is not set

Host Gateway Last Use Total Uses Interface

ICMP redirect cache is empty


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
thotsaphon Thu, 04/16/2009 - 10:00


I just want to know about the traceroute output to outside addresses you mentioned.


lamav Thu, 04/16/2009 - 10:04

Yes, lets see the PINGs and TRACES. Thanks.

And stop following me, Toshi!

mschooley Thu, 04/16/2009 - 10:06


Type escape sequence to abort.

Tracing the route to vnsc-pri.sys.gtei.net (

1 0 msec 0 msec 0 msec

2 33 msec 33 msec 17 msec

3 653230hfc242.tampabay.res.rr.com ( 25 msec 26 msec 50 msec

4 ge1-2-0.tampfledc-rtr3.tampflrdc.rr.com ( 17 msec 17 msec 50 mse


5 te-3-1.car2.Tampa1.Level3.net ( 143 msec 92 msec 51 msec

6 vnsc-pri.sys.gtei.net ( 58 msec 42 msec 34 msec


lamav Thu, 04/16/2009 - 10:13

My guess is that this device is broadcasting an ARP request for a default gateway when you run the trace. Since it is in the same vlan as the next hop,, the next hop receives the request and responds, since it has proxy-arp enabled.

This device forwards to the next hop, the next hop routes the packet to its next hop - and so on, and then, on the return trip, the next hop does a L2 forwarding to this device, since they are on the same vlan.

This is my guess...


mschooley Thu, 04/16/2009 - 10:25

heres my problem with that, since is on a differnet subnet, he doesn't arp for, he should arp for, but how does he know that is his default gateway, proxy arp is usually when you have varied subnet mask and the host arps and the router forwards the arp request, in this case i don't think an arp request for would be answered by anyone even if it was proxied.

lamav Thu, 04/16/2009 - 10:36

Then you have two choices:

1.) Turn on some debugging and see what the switch is doing when you execute a trace.

2.) Call a priest to perform an Exorcism on your switch because it may be possessed by a router demon. :-)



thotsaphon Thu, 04/16/2009 - 10:34


I'm a bit crazy right now.(grin) Is this lab environment? Would you please do "ping" and "debug ip packet detail"?

I just want to see which source ip address it is using. If it is something like 10.20.30.X. It should not do ARP for I would see "unroutable" in debug.


mschooley Thu, 04/16/2009 - 10:38

its not a lab environment, and you are correct it shouldn't arp for, it should arp for as that is the correct default gateway and it is working the problem being is how is it finding out what that default gateway is as it isn't configured, and how is it resolving names in the traceroute as there are no dns servers configured. My problem isnt that something isn't working and should be, it is that it is working and it shouldn't be.

lamav Thu, 04/16/2009 - 10:38


"I'm a bit crazy right now."

Just "now"????

Or always?? :-)

mschooley Thu, 04/16/2009 - 10:43

actually i have 2 switches, and .22, correct default gateway is .1 using glbp, and it is sending to .2 and .3. they are both working in this manner, there are no default routes, no ip routes, no dns servers, yet I can ping remotely, reach them from remote subnets and ping by name. Go figure.

ussw01#ping www.cisco.com

Translating "www.cisco.com"...domain server ( [OK]

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to, timeout is 2 seconds:


Success rate is 0 percent (0/5)

no where in the config is a dns server configured, so how is it resolving?

thotsaphon Thu, 04/16/2009 - 10:48


I thought that would be an "ip domain lookup " command is on. It's using

However I'm waiting for "ping" and "debug ip packet detail".


mschooley Thu, 04/16/2009 - 10:51

cant do that in middle of day, but it should show me sending the packet to the virtual mac of my glbp routers, and if i do a sho ip arp that is what it has for all external addresses

Internet 54 0007.b400.0101 ARPA Vlan30

Internet 229 0007.b400.0101 ARPA Vlan30

Internet 84 0007.b400.0101 ARPA Vlan30

Internet 25 0007.b400.0101 ARPA Vlan30

Internet 8 0007.b400.0101 ARPA Vlan30

Internet 90 0007.b400.0101 ARPA Vlan30

Internet 172 0007.b400.0101 ARPA Vlan30

Internet 156 0007.b400.0101 ARPA Vlan30

thotsaphon Thu, 04/16/2009 - 11:07


Why it sent to one of gblp routers. How can it request that mac-address,0007.b400.0101 if it didn't configure the default-gateway. Properly be

I will open TAC case for Victor.

Victor, Are you there? (grin)


thotsaphon Thu, 04/16/2009 - 11:13


Do you think reloading C3550 will solve this issue? (grin)

Don't forget to post the output I asked for If you're available to do that.



mschooley Thu, 04/16/2009 - 11:18

no as it is happening on two switches. odds of same glitch is small

lamav Thu, 04/16/2009 - 11:43

Hey, now that I got the 2 of you guys here, check this out for a sec:

I have a switch access port configured for switchport voice vlan 580.

Then I have the SVI for 580.

Then I plug the laptop into the switchport and try to PING SVI. Doesnt work.

When I remove the voice vlan command and make it a regular data vlan (switchport access vlan 580), it works.

Im wondering why. Have you encountered this before?

Taking a guess, I would think that the voice vlan command lets the switchport expect a voice packet with voice signalling information in the header. When it doesnt see that, it just kills the packet.

IS that what you think is happening?



mschooley Thu, 04/16/2009 - 11:45

i think that your laptop isn't sending cdp so switchport doesnt' recognize a cisco phone on the end so doesnt use voice vlan.

thotsaphon Thu, 04/16/2009 - 11:53


My turn, I think that switch is waiting for tagged packets and then untag it before sending it out to SVI(voice). Your pc can tag packets. NO! Voice Vlan? That's why IP-Phone has to do some with the packets to separate data(untagged) vlan and voice vlan.


mschooley Thu, 04/16/2009 - 12:01

the way that the switch determines to use the voice vlan is that it recognizes a cisco ip phone via cdp, no phone, no voice vlan. yes your pc can tag packets, but unless the switch sees an ip phone plugged in via cdp it wont use the voice vlan and the port will stay and access port.

thotsaphon Thu, 04/16/2009 - 12:08


Please correct me if I'm wrong. I used to do the following commands with Avaya IP phone. Well, Don't get me wrong. I indeed love cisco ip phone.


Interface f0/1

switchport mode access

switchport access vlan 100

switchport voice vlan 300


Well,Avaya will not know about cdp. What it does is that it will tag voice packets and leave data traffic as untag and send them to the switch.


thotsaphon Thu, 04/16/2009 - 12:17


I got nothing from cdp but interface is up and works like a charm. I think that CDP is pretty cool for cisco ip phone. IP-Phone will learn about you already configured. That's cool. Avaya engineer(not me(grin)) has to manually configure voice vlan on the avaya phone itself to tell it. Part of data traffic will depend on what we configured at the port because they are coming with untagged packets.


mschooley Thu, 04/16/2009 - 12:24

I was under the impression that the cisco switch wouldn't use the voice vlan unless it saw a phone via cdp, but the avaya gets its voice vlan via manual config or dhcp, so maybe as long as the device attached supports q tagging it will work. That would also mean that his laptop would have to have a nic that supported 802.1q tagging otherwise would be put in data vlan. I am verifying about the switchport

thotsaphon Thu, 04/16/2009 - 12:28


You're right.

Off topic, My country many customers use Avaya and Nortel. What about yours? and how are you doing? (grin)



mschooley Thu, 04/16/2009 - 12:36

yes a lot use avaya and nortel and my issue is resolved. proxy arp was enabling the routing and the ip domain lookup to the was resolving the names.

thotsaphon Thu, 04/16/2009 - 12:44


That's great. But I'm a bit confused. I'm not sure that why the switches do ARP for Am I missing something?



lamav Thu, 04/16/2009 - 14:50

"proxy arp was enabling the routing"

Ehem...seems like someone suggested that at the beginning of this thread. Gee, I wonder who it was. ;-)

I'll take my 5 POINTS now...from BOTH of you...

Thank you...thank you (blowing kisses to an endearing crowd)


This Discussion