TEHO Gatekeeper issue

Unanswered Question

Hi All,


We have a TEHO issue. It consit on that we are getting ARJ: unknown address and no default technology defined, when I send a call from a CallManager 555002145788320, where the zone prefix is zone prefix MCK_CCM 555500.......... gw-priority 10 and I have a Route pattern on called party Callmanager 55500.XXXXXXXXXX for receive the call, doing a Strip: predot and prefix digit 9 (on called party) in order to reach the PSTN

What command I have to add on the Gatekeeper? We are currently using gw-type-prefix 1#* default-technology on the GK and the trunk configuration into the Callmanagers. It is working for other zones pointed to the same called party callmanager like 33... or 35... (5 digit extension, but the zone that have more dots must to reach the PSTN and not an extension)

Bellow is the debug for the call:


10.10.10.4 = Gatekeeper

10.10.10.9 = Calling party - Callmanager


Apr 16 23:07:22.812: gk_process: QUEUE_EVENT (minor 0) wakeup

Apr 16 23:07:22.812: RecvUDP_IPSockData successfully rcvd message of length 122 from 10.10.10.9:54858

Apr 16 23:07:22.812: ARQ (seq# 26822) rcvd

Apr 16 23:07:22.816: gk_rassrv_arq: arqp=0x47005FB4, crv=0x68D, answerCall=0

Apr 16 23:07:22.816: gk_rassrv_sep_arq: ARQ Didn't use GK_AAA_PROC

Apr 16 23:07:22.816: gk_dns_query: No Name servers

Apr 16 23:07:22.816: rassrv_get_addrinfo: (555002145788320) Tech-prefix match failed.

Apr 16 23:07:22.816: rassrv_get_addrinfo: (555002145788320) Matched zone prefix 55500 and remainder 2145788320

Apr 16 23:07:22.816: gk_rassrv_get_ingress_network: returning default ingress network = 1

Apr 16 23:07:22.816: rassrv_arq_select_viazone: about to check the source side, src_zonep=0x46DEC43C

Apr 16 23:07:22.816: rassrv_arq_select_viazone: matched zone is SGO_CCM, and z_invianamelen=0

Apr 16 23:07:22.816: rassrv_arq_select_viazone: about to check the destination side, dst_zonep=0x46DEBABC

Apr 16 23:07:22.816: rassrv_arq_select_viazone: matched zone is MCK_CCM, and z_outvianamelen=0

Apr 16 23:07:22.816: rassrv_get_addrinfo: No tech prefix

Apr 16 23:07:22.816: rassrv_get_addrinfo: Alias not found

ALNGATE01#

Apr 16 23:07:22.816: gk_rassrv_get_ingress_network: returning default ingress network = 1

Apr 16 23:07:22.816: rassrv_get_addrinfo: (555002145788320) default-tech gateway selection failed, status = 0x805

Apr 16 23:07:22.816: rassrv_get_addrinfo: (555002145788320) unknown address and no default technology defined.

Apr 16 23:07:22.816: gk_rassrv_sep_arq: rassrv_get_addrinfo() failed (return code = 0x103)

Apr 16 23:07:22.816: IPSOCK_RAS_sendto: msg length 13 from 10.10.10.4:1719 to 10.10.10.9: 54858

Apr 16 23:07:22.816: RASLib::RASSendARJ: ARJ (seq# 26822) sent to 10.10.10.9


Please your suggest

Regards,

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
irisrios Wed, 04/22/2009 - 11:31

If you configure your CUCM cluster in different zone without tech prefix, please add the following command into the gatekeeper configuration:

gw-type-prefix 1# default-technology (1# can be different tech prefix in configuration base on your design)

e.huntley Wed, 04/29/2009 - 07:22

I am trying to troubleshoot a similar issue. What debug command did you issue to see this output.


Thanks


You must to enable the following debug, and then reproduce the issue


- debug gatekeeper main 10


- debug h225 ans1


- debug h225 ras


- debug gatekeeper main 10


Basically I created route pattern on the calling (outbound) and called (inbound) party Callmanagers clusters. On the GK the zone prefix associated to the CTI ID: that each server give to you.


Ensure that the CSS that trunk has in the called party contain the partition that have the route pattern (called) and the digit that you expect receive (Significant Digits*)


Regards

Andres


Actions

This Discussion