how to configure ssh ckient on LMS2.6 (Solaris)

Unanswered Question
Apr 17th, 2009

Hi,

Does someone knows how to configure the ssh client in LMS2.6 so that the Host key is not checked. (something like ssh -o StrictHostKeyChecking no).

Since we configured ssh on the network devices it seems that during the ssh session lms has to answer on Regenerate Key questions with yes/no. But how can I disable this interactive question?


Regards

Jan

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joe Clarke Fri, 04/17/2009 - 09:18

LMS doesn't care about host keys. What exactly are you doing that you would need to answer such a question? Is this a Netconfig job?

janvandek Sun, 04/19/2009 - 11:38

Indeed,


The netconfig job fails since the ssh was configured on the devices.


How can LMS avoid host keys ?


Jan


Joe Clarke Sun, 04/19/2009 - 11:43

What exactly is the error message you're seeing when the job fails? Exactly what commands are you deploying to the device?

janvandek Sun, 04/19/2009 - 23:27

We don't get an error message.

The process goes in timeout.

We use a sniffer to verify this.

So:

If we do this manually on the server (i.e. we use ssh to the device via cli) => it works. (the host key regeneration can be avoided by using the StrictHostKeySetting flag no )

If we use NetConfig it fails after 3 tries (timeouts). on most of the devices (300 succeeds, 500 fails)

Someone read that LMS should keep the host keys in some repository ?


Jan



Joe Clarke Sun, 04/19/2009 - 23:41

No, LMS doesn't do anything with host keys. SSH keys are not your problem. Since you are using SSH, the sniffer will be of little use. What will be helpful is to enable ConfigJob debugging under RME > Admin > System Preferences > Application Loglevel Settings, run the job, then post the contents of the job directory under NMSROOT\files\rme\jobs\NetConfigJob on Windows and /var/adm/CSCOpx/files/rme/jobs/NetConfigJob on Solaris.

Actions

This Discussion