Layer 2 etherchannel in 6500 IOS question.

Unanswered Question
Apr 17th, 2009

I've configured a L2 etherchannel between two ports on a WS-X6548-GE-TX on a 6509 and two ports on a WS-X6148-GE-45AF on a 6503. Both 6500s are at IOS 12.2(33)SXH4. (This is in a lab which is why I have a mix of chassis and blades.)

I config'd the individual interfaces first as switchports and access vlan 533, then config'd the channel-group which automatically created the port channel. Vlan 533 on each 6500 is configed with a /29 ip subnet. (I will be adding a WAE-7341 device on each 6500 in the same vlan for L2 connectivity, hence the /29). So far so good.

However the port channel on the 6509 is automatically created and config'd as a truck port, whereas the port channel on the 6503 is automatically created and has no trunk config.

And surprisingly the port-channel works and traffic passes between the two 6500s just fine.

Here is the resulting config:

ENGLAB-6509

interface Port-channel3

switchport

switchport access vlan 533

switchport trunk encapsulation dot1q <<-----???

switchport mode access

mls qos trust dscp

!

!

interface GigabitEthernet2/23

switchport

switchport access vlan 533

switchport mode access

speed 100

duplex full

mls qos trust dscp

spanning-tree portfast

channel-group 3 mode desirable

!

interface GigabitEthernet2/24

switchport

switchport access vlan 533

switchport mode access

speed 100

duplex full

mls qos trust dscp

spanning-tree portfast

channel-group 3 mode desirable

ENGLAB-6503

interface Port-channel1

switchport

switchport access vlan 533

switchport mode access

mls qos trust dscp

!

!

interface GigabitEthernet3/24

switchport

switchport access vlan 533

switchport mode access

speed 100

duplex full

mls qos trust dscp

spanning-tree portfast

channel-group 1 mode desirable

!

interface GigabitEthernet3/48

switchport

switchport access vlan 533

switchport mode access

load-interval 30

speed 100

duplex full

mls qos trust dscp

spanning-tree portfast

channel-group 1 mode desirable

If I try to remove the trunk statement from the 6509 to match the port-channel config on the 6503, it complains like:

ENGLAB-6509(config)#int p3

ENGLAB-6509(config-if)#no switchport trunk encapsulation dot1q

Command rejected! GigabitEthernet2/23 in port-channel only support Dot1q Trunk Encapsulation

Any idea why the 6509 port-channel includes the trunk, but the 6503 doesn't and is this a stable configuration?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Mark Yeates Fri, 04/17/2009 - 09:13

The reason you are seeing that is some of the newer linecards only support dot1q trunks. Therefor you don't need to specify "switchport trunk encapsulation dot1q" on the interface config. I know the WS-X6148-GE-45AF is one of those cards.

HTH,

Mark

jkeeffe Fri, 04/17/2009 - 09:21

So, should I add the "switchport trunk encapsulation dot1q" to the port-channel on the 6503 with the 6148 line card, or just keep the config on both 6500s the way it is?

Jon Marshall Fri, 04/17/2009 - 09:40

Mark

I'm a little confused, doesn't take much :-).

The ports were not configured as trunks ie. they are in switchport mode access so why is it even putting that line "switchport trunk encapsulation dot1q" into the config. I could understand if it was configured as a trunk link but it isn't.

On other switches eg 2960 when there is only one option the command "switchport trunk encap... etc." is simply not available.

Not questioning your answer, just would like a bit more clarification as to what is happening.

Jon

Mark Yeates Fri, 04/17/2009 - 10:19

Jon,

Good question! As to where the "switchport trunk encapsulation dot1q" came from I would like to know myself. My logic was that since switchport mode access was configured on all the ports he should be fine the way that it is. No trunk should form since it will fall back to the access vlan. Which is why it works.

Mark

Actions

This Discussion