EIGRP Question

Answered Question

I think I have a miss understanding of what the network statement is for in EIGRP.

Does the network statement say what networks to talk about or what networks to talk to?

Thank you

I have this problem too.
0 votes
Correct Answer by Richard Burts about 7 years 7 months ago

Jeff

Yes, assuming that your EIGRP uses AS 1, you would put that command on each interface of the core. The core would see all of the detail routes. But the other routers would have only a single entry in their routing table for the p2p links.

HTH

Rick

Correct Answer by Richard Burts about 7 years 7 months ago

Jeff

We are making good progress in getting this cleared up. Jon has explained well that (assuming no distribute lists or other route advertisement filtering) that an EIGRP router will advertise to neighbors routes that it has dynamically learned as well as advertising local routes controlled by the network statement.

Just to clear up one other thing from your post. You say that:

Router B has interfaces only in 10.0.0.0 However Both are network statements in EIGRP

If Router B has interfaces only in network 10.0.0.0 then there is no need to have a network statement for 192.168.0.0. It does not hurt anything if it is there, but it does no good to have it. It is superflous.

HTH

Rick

Correct Answer by Jon Marshall about 7 years 7 months ago

Jeff

"Would it make the explanation even more complicated to talk about advertising routes in the table that are not locally connected"

I think this is what Rick meant by the above. Router B will receive a route for 192.168.0.0 from Router A. Router B will then advertise this route for 192.168.0.0 to Router C. This is normal routing behaviour, well at least for EIGRP/RIP/IGRP. OSPF is slightly different.

The network statement only controls the neighborships formed and the local networks advertised. Any routes received via EIGRP from another router will still be advertised on.

Jon

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.7 (9 ratings)
Loading.
Richard Burts Fri, 04/17/2009 - 10:23

Jeff

Given your choices the one that is more close is networks to talk about. What it really does is to identify to EIGRP what interfaces it should include in the routing process. Once EIGRP knows what interfaces to include in the routing process then it looks at the interface IP address and subnet mask and then decides what to advertise.

HTH

Rick

Jon Marshall Fri, 04/17/2009 - 10:26

Jeff

The "network" statement under EIGRP/OSPF/RIP tell the router which interfaces to start the routing protocol on. So

router eigrp 1

network 192.168.5.0

means that any interfaces on the router that have an IP address that falls within the 19.168.5.0 network will have EIGRP run on them. The router will then form EIGRP neighborships with any other routers that have interfaces in the 192.168.5.x network and that are running EIGRP.

Note that for BGP the "network" statement does actually tell the router to advertise out that network.

Jon

Now I'm more confused!

If I'm reading the replies correctly...

Rick you said the statement is about what networks get forwarded in EIGRP. If my statement is 10.0.0.0, no routes for 192.168.0.0 will be passed.

Jon on the other hand said it will pass all routes it can, but only to neighbors in the 10.0.0.0 network.

Is it both?

Thank You

Jon Marshall Fri, 04/17/2009 - 11:23

Jeff

Apologies for any confusion. Let me be more specific.

The network statement tells EIGRP which interface(s) to run EIGRP on. Once EIGRP has been started on this interface then the EIGRP process will advertise this network + subnet mask to any EIGRP neighbors. So

(172.16.5.1/24 - fa0/0) R1 (s0/0 - 192.168.5.1/24) -> (192.168.5.2/24 S0/0) R2 (fa0/0 - 172.16.6.1/24)

R1

router eigrp 1

network 192.168.5.0

no auto-summary

R2

router eigrp 1

network 192.168.5.0

no auto-summary

So with the above config each router will only know about it's directly connected networks but they will form an EIGRP neighborship between each other.

If you then add

router eigrp 1

network 172.16.5.0

+ config already on R1

then R2 will no have a route for 172.16.5.0 pointing to R1 and this will have be learned from EIGRP.

Does this make sense ?

Jon

Richard Burts Fri, 04/17/2009 - 11:26

Jeff

Perhaps it will make more sense if we can build a small example and talk about it. Perhaps this can get us started:

interface fastethernet0/0

ip address 192.168.5.1 255.255.255.192

interface fastethernet0/1

ip address 10.0.0.1 255.255.255.0

router eigrp 1

network 10.0.0.0

So this little example has 2 interfaces and 2 networks. The EIGRP configuration has 1 network statement. So EIGRP will look at its network statement and look for any interface that matches it. fastethernet0/1 does match and fastethernet0/0 does not match. So interface fastethernet0/1 is included in EIGRP and fastethernet0/0 is not included in EIGRP.

Then EIGRP looks at the interface and determines that it should advertise network 10.0.0.0/24. It will not advertise 192.168.5.0.

Then EIGRP sends hello messages on its included interfaces (fastethernet0/1). If it receives a proper hello in response then it will form an EIGRP neighbor relationship and will advertise to its neighbor.

So in a sense the network statement does both functions you asked about: it derives information about what to advertise (what to talk about) and it determines where it will talk (who to talk to).

Would it make the explanation even more complicated to talk about advertising routes in the table that are not locally connected?

HTH

Rick

Great. I see we all agree now. That was my under standing as well.

However here is what I'm seeing.

I have three routers (Ok I have 30, but lets look at 3 of them)

A - B - C

Router A has interfaces in both 10.0.0.0 and 192.168.0.0. Both are network statements in EIGRP

Router B has interfaces only in 10.0.0.0 However Both are network statements in EIGRP

Router C has interfaces only in 10.0.0.0 and only network for 10.0.0.0 statements in EIGRP

Router C is getting routes in the route table for 192.168.0.0 via EIGRP.

I don't understand why I would be seeing this.

Correct Answer
Jon Marshall Fri, 04/17/2009 - 11:42

Jeff

"Would it make the explanation even more complicated to talk about advertising routes in the table that are not locally connected"

I think this is what Rick meant by the above. Router B will receive a route for 192.168.0.0 from Router A. Router B will then advertise this route for 192.168.0.0 to Router C. This is normal routing behaviour, well at least for EIGRP/RIP/IGRP. OSPF is slightly different.

The network statement only controls the neighborships formed and the local networks advertised. Any routes received via EIGRP from another router will still be advertised on.

Jon

Correct Answer
Richard Burts Fri, 04/17/2009 - 11:51

Jeff

We are making good progress in getting this cleared up. Jon has explained well that (assuming no distribute lists or other route advertisement filtering) that an EIGRP router will advertise to neighbors routes that it has dynamically learned as well as advertising local routes controlled by the network statement.

Just to clear up one other thing from your post. You say that:

Router B has interfaces only in 10.0.0.0 However Both are network statements in EIGRP

If Router B has interfaces only in network 10.0.0.0 then there is no need to have a network statement for 192.168.0.0. It does not hurt anything if it is there, but it does no good to have it. It is superflous.

HTH

Rick

Thanks Rick. I see that now. Someone else configured the EIGRP and I'm just trying to clean up the system.

So if all learned routes are advertised then to advertise a default route all I should have to do is set it on the firewall to redistribute a default route and then the whole network would get it.

The network is currently setup with a default route on each device that just points toward the core routers, then the cores know the real exit point.

sdoremus33 Fri, 04/17/2009 - 12:03

Rick,

Thanks for the detailed explanation, this post was very helpful, and cleared alot of questions I had regarding EIGRP and its process. Thanks

Rick and Jon you have both been very helpful.

Thank You

One more question. I have a lot of point to point links (VPN/dialup tunnels) that are flooding my route tables with routes no one cares about.

All my p2p links are in the 10.99.0.0 network. Is there a way to remove these destinations from EIGRP, or do I really need to keep them?

Richard Burts Fri, 04/17/2009 - 12:16

Jeff

There are a couple of things that you might do about the point to point subnets. One alternative would be to write a distribute list out in EIGRP which could deny the point to point subnets and permit other routes. Another alternative might be to configure manual summarization and advertise a block of addresses rather than each individual address (this could be especially effective if the point to point links terminate on a single router and if the addresses of the subnets were assigned to form a contiguous block of addresses).

[edit] now that I look again at your post you say that the p2p links are in 10.99.0.0. So it would be easy to configure something like this:

ip summary-address eigrp 1 10.99.0.0 255.255.0.0

you would configure this under the interface rather than under router eigrp. You would do it on each interface where you have EIGRP neighbors who do not need to see the detail routes.

HTH

Rick

Correct Answer
Richard Burts Fri, 04/17/2009 - 12:29

Jeff

Yes, assuming that your EIGRP uses AS 1, you would put that command on each interface of the core. The core would see all of the detail routes. But the other routers would have only a single entry in their routing table for the p2p links.

HTH

Rick

Giuseppe Larosa Sat, 04/18/2009 - 10:23

Hello Jeff,

to take advantage of manual summarization you need to have no auto-summary.

So your current configuration is good and ready for applying Rick's suggestions on how to avoid to have the details of point-to-point links in 10.99.0.0/16.

the command works on EIGRP updates sent out the interface(s) in which it is applied.

Hope to help

Giuseppe

Richard Burts Sat, 04/18/2009 - 18:03

Giuseppe

The last time I tested it manual summarization in EIGRP worked regardless of whether auto summarization was enabled or disabled. Can you tell me that this has changed?

HTH

Rick

Giuseppe Larosa Sat, 04/18/2009 - 23:24

Hello Rick,

I always used EIGRP with no auto-summary.

However, I was meaning to have full control of what summary routes are generated in the network.

What happens at an interface that is at a major network boundary between 10/8 and 172.18.0.0/16 ?

I see 10/8 (classful auto-summarized) or 10/9 (configured with ip summary-address) or both ?

I've checked the command reference and it tells only that auto-summary can be disabled to perform per interface subnet based summarization.

The small example of the command usage shows also no auto-summary.

http://www.cisco.com/en/US/docs/ios/iproute/command/reference/irp_eig1.html#wp1013188

Thanks for your note you are right there is no strict need of no auto-summary command.

Best Regards

Giuseppe

Actions

This Discussion