SSH client not found

Answered Question
Apr 17th, 2009

i want to enable sshv2 in CW LMS 3.0.1,Am giving a path to ssh client in windows start>control panel>java>java>Java applet runtime setting>Java runtime parameters for the ssh client installed in c drive program files in 8.3 naming convention format,i.e(DCMSSH=C:\PROGRA~1\ZOC6\zoc.exe).when i try to do ssh from topology services by right clicking on router it gives me a error ssh clint not found,

Please help me to solve this problem


I have this problem too.
0 votes
Correct Answer by Joe Clarke about 7 years 5 months ago

Make sure the C:\Documents and Settings\Administrator\ file exists. Often times, there is a hidden ".txt" extension on files, so make sure the file is not named Post this file from the server.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Marvin Rhoads Fri, 04/17/2009 - 11:14

I checked the 5.0 User Guide ( and it has your syntax WITH THE EXCEPTION of a "-" preceding the "DCMSSH" statement. Have you included that?

"Step 1 Go to the Microsoft Windows desktop and select Start > Settings > Control Panel > Java Plug-in from the Microsoft Windows desktop.

The Java Plug-in Control Panel appears.

Step 2 Click Advanced.

Step 3 Enter the path to an SSH client executable in the Java Runtime Parameters field.

For example, if the ssh executable is located at E:\PROGRA~1\SSHCOM~1\SSHSEC~1\ssh2.exe,

add the following in the Java Runtime Parameter field:-DCMSSH=E:\PROGRA~1\SSHCOM~1\SSHSEC~1\ssh2.exe

(Directory and file names must follow the 8.3 naming format.)

Step 4 Click Apply."

It appears the syntax changed in 5.1 See the Campus Manager 5.1 User Guide. It states:

"Step 1 Create a file named

Step 2 Write the following property in the file:

CMSSH=SSH executable file name

For example,

If you are using Secure Shell:


If you are using Putty:


Step 3 Save the file in your home directory.

For example, your home directory can be D:\Documents and Settings\admin."

Note the double backslashes.

(Reference User Guide for Campus Manager Software Release 5.1, found at )

lambay2000 Fri, 04/17/2009 - 12:08

Hi dear,

I tried according to 5.0 user guide just i tried by adding "-" preceeding DCMSSH,according to ur guidance but still it is not,the below solution is for 5.1,

Any alternative.


lambay2000 Fri, 04/17/2009 - 12:36

my campus manager is 5.0.1 should i try with 5.1 ssh solution? but it is prompting to specify the client in java runtime parameters in control panel.

Any comments please.

Marvin Rhoads Fri, 04/17/2009 - 15:19

Have you tried running the command line specification from a Windows "Run" prompt? (Winkey > R > C:\PROGRA~1\ZOC6\zoc.exe). If that works, the problem is in CM parsing the variable. If it doesn't, your command line entry is incorrect.

Just a thought....

lambay2000 Sat, 04/18/2009 - 21:14


I m not able to execute the

(Winkey > R > C:\PROGRA~1\ZOC6\zoc.exe)

what i understand from this command is start>run>Winkey > R > C:\PROGRA~1\ZOC6\zoc.exe and then press enter it doesnt work,

Can u put some step by step to easy to understand.

Sorry to reply late

lambay2000 Sat, 04/18/2009 - 21:32

Hi friends,

pls have a look on the attachment i had given a path according to 8.3 naming convention,

when i try to do from run C:\PROGRA~1\ZOC6\zoc.exe by 8.3 naming format it open the zoc6 ssh terminal window that means my naming convention r proper than what could b the possible reason that campus manager is not able to find the path in Java control panel.

Pls refer the attachment i have took the print screen for the error.

lambay2000 Sun, 04/19/2009 - 04:13

have anybody face this problem ever before,

waiting for ur replies friends replies will be appreciable.

Marvin Rhoads Sun, 04/19/2009 - 05:24

I do see a SSH bug (CSCsr89218: SSH is not launching from TOPO. SSH flow code has been removed in this release due to jacorb changes.) noted as being fixed in CM 5.1.1. The bug toolkit notes that it was initially reported in 5.1 though, not 5.0.x.

Perhpas Joe Clarke can weigh in regarding the status of this problem in 5.0.x releases. I don't have a system I can test it on.

lambay2000 Sun, 04/19/2009 - 09:25

Hi mklemovitch,

Can i upgrade from campus manger 5.0 to 5.1.1? Do i have to buy any new licence for 5.1.1 because my LMS is new installation just before 2 months back.

appreciate for ur reply.


Thanks a tons

Marvin Rhoads Sun, 04/19/2009 - 09:53

If you have a Software Application Support (SAS) or SASU (SAS plus Upgrades) contract covering your CiscoWorks product, you are eligible to download minor (SAS) or major (SASU) product upgrades.

Check with your account team or the TAC if you are not sure of your eligibility.

lambay2000 Tue, 04/21/2009 - 12:38


I don't have SAS OR SAUS

If i upgrade to CM 5.0.4 it will help me.

This task is imp for client


lambay2000 Mon, 05/11/2009 - 00:30

Hi Joe,

Waiting for ur reply,give me alternate client is waiting for the task to complete.

Joe Clarke Mon, 05/11/2009 - 14:36

You got lucky. I typically don't read threads if someone else has already replied. There's just so much else to do (and I miss some threads as it is).

Campus Manager 5.0.5 has all of the fixes for SSH support in Campus. So you will need to be on LMS 3.0.1 (downloaded from ), then upgrade to 5.0.5 from Common Services > Software Center > Software Update.

Then, you need to make sure that a file exists on your client in your home directory (e.g. C:\Documents and Settings\lambay2000) with contents like the following (assuming this is the path to your SSH client):


Then SSH should work from the Topology Map.

lambay2000 Sat, 05/16/2009 - 03:59

Hi Joe,

i have done according to ur guidance but still the same error,"ssh client configuration missing"

I have created a txt file named and specified the ssh client path CMSSH=C:\\PROGRA~1\\PUTTY\\putty.exe i.e (already exist in program files) and saved in administrator profile c:\Documents and Settings\administrator as am logging in windows 2003 server with administrator account for using LMS.

As u look in the error attached it is searching a SSH client in control Panel\JAVA\java runtime parameters.

Also specfied CMSSH=C:\\PROGRA~1\\PUTTY\\putty.exe path in java\java runtime parameters in control panel.

Awaiting for ur reply.

Joe Clarke Sat, 05/16/2009 - 10:49

Did you upgrade to CM 5.0.5? This error points to a problem with Campus not being able to find the file. Post the output of the SET command from a DOS prompt on your client machine as well as the Java console after reproducing this error.

lambay2000 Sat, 05/16/2009 - 11:57


Yes i upgrade to 5.0.5

I did'nt understood by the below words:

You want the SET command output from command prompt of the LMS server?

How to get output from java console?

Am not clear pls can u mail me in steps.

I want to get rid of this issue help me clarke.


Joe Clarke Sat, 05/16/2009 - 12:00

I want the SET output from the DOS prompt on the client machine.

If you launch the Java control-panel, go to Advanced, and choose "Show console" under the Java Console option, a console screen will appear when you launch Topology. Post the output in this console after reproducing the SSH problem.

lambay2000 Sat, 05/16/2009 - 12:53

hi clarke,

AM confuse clarke

what the instruction u gave me for file i have done all those on LMS server,not on the client machine.

Is it that all i have to do on client machine?


lambay2000 Sat, 05/16/2009 - 13:18

Sorry clarke,

I made a mistake what i was thinking that i have to do all that on LMS server but i have to do on client machine.

I will configure it on client machine and reply u back.

appreciate ur reply,help me to get rid of this issue.

apologize for my silly mistake.

Thanks a tons clarke.

lambay2000 Sat, 05/16/2009 - 22:14

Hi Clarke,

Success clarke,

From the Client Machine i got the success.

i configured on client machine it worked but the same am doing on server it is not working it giving me the same error as before attached.

Is it any additional configuration to be done on LMS server.

attaching the logs of java console and SET command while accessing from the LMS server.

Thanks tons clarke.

Correct Answer
Joe Clarke Sat, 05/16/2009 - 22:34

Make sure the C:\Documents and Settings\Administrator\ file exists. Often times, there is a hidden ".txt" extension on files, so make sure the file is not named Post this file from the server.

lambay2000 Sat, 05/16/2009 - 23:05

Hey Clarke,


Yes when i saw the properties it is a txt file my server creating a notepad with version 5.2 and on my client machine it is a 5.1 i copied the file from the client machine and paste it in server and finally it worked

Thanks a tons and tons to get me rid of this issue.



This Discussion