Problem with Router 877 configuration

Unanswered Question
Apr 17th, 2009

I have a Router 877. Which i configured but there are no internet. all interfaces are UP.

Here's the configuration. Should Be missing any command

urrent configuration : 3201 bytes

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

!

!

crypto pki trustpoint TP-self-signed-1611738257

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-1611738257

revocation-check none

rsakeypair TP-self-signed-1611738257

!

!

crypto pki certificate chain TP-self-signed-1611738257

certificate self-signed 01

3082023E 308201A7 A0030201 02020101 300D0609 2A864886 F70D0101 04050030

31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274

69666963 6174652D 31363131 37333832 3537301E 170D3038 30383234 30303037

32335A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649

4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 36313137

33383235 3730819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281

8100AAA0 275B05DF C7B89FE5 1D879B6B FF90B027 E94663B3 C638D434 69F42DA2

9167DBCA 124C90AF 80917875 65B9579E 28A25D41 8040862B 4B57680B 827D08CE

CA330F9E 3013E15B 784FBC79 8CAEADAC 36AA0EFC 46EFCAA3 7E602750 A20AC4ED

31FA9C1F 2AA0AAC4 904A499E 0652AA23 E8F33883 BA8BD4FF 1AF89BC2 16908E99

B50D0203 010001A3 66306430 0F060355 1D130101 FF040530 030101FF 30110603

551D1104 0A300882 06526F75 74657230 1F060355 1D230418 30168014 33E1E62F

F2BF55B7 FCEA1CBC 5AB302CF E39FB5AB 301D0603 551D0E04 16041433 E1E62FF2

BF55B7FC EA1CBC5A B302CFE3 9FB5AB30 0D06092A 864886F7 0D010104 05000381

8100769D 71547680 713F0749 36DD236A 5394FD90 5C8834EA EA558F22 F5474938

974FF284 246288D3 F80F653D 3055B6C1 93A1372B D83CD656 5DC15F19 D7C4B952

8A5D449D A55B20F5 65AFA8DF 53F88EAF 83DBAC69 D694DA4D 6FD0D113 D25A3A9E

D51BDF6F C3A15AD0 B98CE81A 06208662 30CC659C 6C5D69DF B3A8C335 E45016B5 102C

quit

dot11 syslog

ip cef

!

!

!

!

ip auth-proxy max-nodata-conns 3

ip admission max-nodata-conns 3

!

multilink bundle-name authenticated

!

!

!

archive

log config

hidekeys

!

!

!

!

!

interface ATM0

no ip address

no atm ilmi-keepalive

dsl operating-mode auto

no shu

!

interface ATM0.1 point-to-point

pvc 8/60

encapsulation aal5mux ppp dialer

protocol ppp dialer

dialer pool-member 1

no shu

!

!

interface FastEthernet0

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface Vlan1

ip address 192.168.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly

no shut

!

interface Dialer0

ip address negotiated

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication chap pap callin

ppp chap hostname garciaaldana@speedy

ppp chap password 0 xxxxx

ppp pap sent-username garciaaldana@speedy password 0 xxxxx

no shut

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 Dialer0

!

!

ip http server

ip http secure-server

ip nat inside source list 1 interface Dialer0 overload

!

access-list 1 remark INSIDE_IF=Vlan1

access-list 1 remark SDM_ACL Category=2

access-list 1 permit 192.168.1.0 0.0.0.255

dialer-list 1 protocol ip permit

!

!

!

!

control-plane

!

!

line con 0

no modem enable

line aux 0

line vty 0 4

login

!

scheduler max-task-time 5000

end

Thank you

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
connectone Fri, 04/17/2009 - 12:47

I want to rule out the obvious, but is anything pluged into a port that is part of VLAN 1. If you do a show interface vlan 1 does it show the vlan interface up and the line protocol also being up.

andrew.butterworth Sat, 04/18/2009 - 02:29

I am presuming here that you don't have your own infrastructure behind this router and you just have some PC's?

If that is the case then you will need to either statically configure the IP settings on each PC or enable DHCP on the 877. You will also need to get name-resolution (DNS) working. You can either statically configure this on each workstation, add your ISP's DNS servers to the DHCP config on the router or get the router to negotiate them on the dialer interface and automatically pass them on to the DHCP scope it is configured for.

I think you can even get the router to act as a DNS server (proxy?), however I have never configured this.

To get the router to request the DNS server addresses on the dialer interface add the line 'ppp ipcp dns request accept' under the dialer interface. You then need to add the line 'import all' under the dhcp pool configuration (which you don't currently have).

Plus make sure the interfaces are actually Up, that the dialer interface has negotiated an IP address and that NAT translations are taking place.

HTH

Andy

Actions

This Discussion