2811 IOS Software

Unanswered Question
Apr 17th, 2009

My 2811 has IOS Software c2800nm-ipbase-mz.124-15.t7.bin. When I try to do a tftp copy of c2800nm-ipbase-mz.124-24.t.bin to it I get "File not a valid executable for the system". I was able to use the same tftp server connection to copy the c2800nm-ipbase-mz.124-15.t7.bin file from my 2811 to my tftp server. What IOS should I be using to upgrade my the IOS I am using now?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
connectone Fri, 04/17/2009 - 12:59

did you try downloading the file again. This has happened to me in the past, somehow the file downloaded incorectly.

Richard Burts Fri, 04/17/2009 - 13:08

Kenneth

By looking at the file name it would appear that this should be a valid IOS for your router. I wonder if there was perhaps some problem in copying the IOS image file from Cisco to your TFTP server? Or perhaps some issue in the way that you tried to do the copy from the server to the router?

It might be helpful if you would try to load the image again, capture the command that you entered and any responses that you receive, and post them to the forum.

HTH

Rick

route2null Fri, 04/17/2009 - 17:31

Try eilminating TFTP from the equation and copy the IOS via one of the Routers USB slots.

diek Mon, 04/20/2009 - 04:58

Thnks everyone for there responses.

Below is the command and responses I got.

I did the download again from Cisco and got the same error as shown below. This is the first router I got with USB ports.

Do I have to format the USB drive from the router before I can use it? It recognizes the drive when I put it in but

it says devies need formatting befor use.

ETSB2811#copy tftp: flash:

Address or name of remote host [10.12.0.2]?

Source filename [c2800nm-ipbase-mz.124.24.T.bin]? c2800nm-ipbase-mz.124-24.T.bin

Destination filename [c2800nm-ipbase-mz.124-24.T.bin]?

Accessing tftp://10.12.0.2/c2800nm-ipbase-mz.124-24.T.bin...

%Warning: File not a valid executable for this system

Abort Copy? [confirm]

Richard Burts Mon, 04/20/2009 - 07:59

Kenneth

Thank you for posting the additional information that I requested. I had hoped that it would lead us to a better understanding of the problem. But unfortunately it does not.

If this router is covered by a maintenance contract I would be inclined to suggest opening a case with Cisco TAC to investigate the problem. Or if you want to continue through this forum I would ask that you post the output of show version and the output of show diag from the router.

HTH

Rick

diek Mon, 04/20/2009 - 12:38

I tried using the cisco tftp server and it failed with a microsoft error on the tftpserver.exe file. If I start the tftp server back up before the 2811 timesout it picks up the file and loads it. So I got what I needed loaded. It seems to fail on larg files. The smaller filed below 20M worked ok with no errors.

Richard Burts Mon, 04/20/2009 - 13:03

Kenneth

I am glad that you got what you needed loaded. I am a bit surprised that a problem with a large image file would produce the error about not a proper executable. I would have expected the copy to start, run for a while, and then abort. But apparently that is not what it did.

It is a fairly well known issue with some (older) implementations of TFTP and large file. The original specification and implementation of TFTP did put a limit on the size of file that it could transport. Apparently your TFTP server has that limitation. There are a number of TFTP servers available, some of them freeware, which do not have the limitation on file size. I have used 3Cdaemon for quite a while with good success, and have recently been using tftpd32 and am happy with it. Both of these are quite capable of handling image files of large size.

I would also make a suggestion that for large image file that you consider an alternative to TFTP. If you use FTP there is no limit to the size file that you can transmit. And FTP is much more efficient in transmitting large files that TFTP is.

HTH

Rick

Actions

This Discussion