bpduguard to disable the port automatically

Unanswered Question
Apr 18th, 2009
User Badges:

I have enabled bpduguard to disable the port automatically whenever host flap issue occurs. And have found BPDU-Guard to be very effective. But it's not working in some times. Any ideas? Thanks in advance.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (2 ratings)
Loading.
andrew.prince@m... Sat, 04/18/2009 - 11:15
User Badges:
  • Green, 3000 points or more

bpduguard should be configured on a switch that has ports configured as "portfast" if none of the ports are configured for portfast, the switch will go thru the listening,learning,forwarding or blocking if the switch port recevies a BPDU.


HTH>

arun@fuzzy15s.com Sat, 04/18/2009 - 12:13
User Badges:

yes, i have configured spanning-tree portfast in all access ports.


configuration:

(config)# spanning-tree portfast bpduguard default

(config-if)#spanning-tree portfast


the ports will be disbled whenever the hostflap issue occurs. but some times its not working.



andrew.prince@m... Sat, 04/18/2009 - 12:36
User Badges:
  • Green, 3000 points or more

BPDUGuard has absolutely nothing to do with ports flapping, you need to look into the err-disable settings.

andrew.prince@m... Sat, 04/18/2009 - 13:26
User Badges:
  • Green, 3000 points or more

vlan flapping is handled by spanning-tree


diretcly connected host flapping can only be managed by port flapping.


What exactly is your issue?

arun@fuzzy15s.com Sat, 04/18/2009 - 13:50
User Badges:

i like to disable the switch port automatically whenever physical loop occurs.

Actions

This Discussion