DTMF and Voice Mail issue

Answered Question
Apr 18th, 2009
User Badges:
  • Bronze, 100 points or more

We are doing a SIP trunk test using CME and Huawei SIP platform for providing SIP service to our Customers.


Please see the below listed two issues.


1. Voice mail and Auto Attendant can't access threw SIP trunk


   When we dial from outside to CME AA or Voice Mail, we are getting ringback tone instead of AA message, but its working fine internally and from other Cisco SIP trunk


2. Outbound DTMF tone is not working


DTMF messages are not receiving by Huawei SIP Server from CME.


When i do "debug voip rtp session named-event" i can see the debug messages in CME


eg :
Mar 19 09:02:11.151: s=DSP d=VoIP payload 0x65 ssrc 0x41378733 sequence 0x1D24 timestamp 0x2950B88
Mar 19 09:02:11.155: Pt:101 Evt:1 Pkt:04 00 00 <Snd>>>
Mar 19 09:02:11.155: s=DSP d=VoIP payload 0x65 ssrc 0x41378733 sequence 0x1D25 timestamp 0x2950B88
Mar 19 09:02:11.155: Pt:101 Evt:1 Pkt:04 00 00 <Snd>>>


but Huawei SIP server is not receiving any DTMF tones.


Trace from Huawei Softswitch:


From: "Cisco 3"<sip:[email protected];user=phone>;tag=144D50E8-9A0
To: <sip:[email protected];user=phone>;tag=604d2523-cc-32-trc-586
CSeq: 101 INVITE
Allow: INVITE,ACK,OPTIONS,BYE,CANCEL,REGISTER,INFO,PRACK,SUBSCRIBE,NOTIFY,UPDATE,MESSAGE,REFER
Session-Expires: 300;refresher=uac
Require: timer
Contact: <sip:10.193.1.2:5060>
Supported: 100rel,replaces,timer,precondition,histinfo
Content-Length: 179
Content-Type: application/sdp


v=0
o=HuaweiSoftX3000 141265 141265 IN IP4 10.193.1.2
s=Sip Call
c=IN IP4 10.194.1.13
t=0 0
m=audio 44800 RTP/AVP 18
a=rtpmap:18 G729/8000
a=ptime:20
a=fmtp:18 annexb=no


CISCO CME --------> Huawei sx3000


INVITE sip:[email protected]:5060;user=phone SIP/2.0
Via: SIP/2.0/UDP 10.194.1.133:5060;branch=z9hG4bK13bcea40f20707e29eb76febd
Call-ID: [email protected]
From: "Cisco 3"<sip:[email protected];user=phone>;tag=144D50E8-9A0
To: <sip:[email protected];user=phone>
CSeq: 101 INVITE
Allow: INVITE,OPTIONS,BYE,CANCEL,ACK,PRACK,UPDATE,REFER,SUBSCRIBE,NOTIFY,INFO,REGISTER
Call-Info: <sip:10.121.0.5:5060>;method="NOTIFY;Event=telephone-event;Duration=2000"
Date: Sun, 05 Apr 2009 07:53:03 GMT
Expires: 180
Max-Forwards: 70
Supported: 100rel,timer,resource-priority,replaces
User-Agent: Cisco-SIPGateway/IOS-12.x
Allow-Events: kpml,telephone-event
Min-SE: 90
Contact: <sip:[email protected]:5060;user=phone>
Remote-Party-ID: "Cisco 3" <sip:[email protected]>;party=calling;screen=no;privacy=off
Cisco-Guid: 2673813588-552407518-2172701569-3723580369
Content-Length: 388
Content-Type: application/sdp
Content-Disposition: session;handling=required


v=0
o=CiscoSystemsSIP-GW-UserAgent 6125 7495 IN IP4 10.194.1.133
s=SIP Call
c=IN IP4 10.194.1.133
t=0 0
m=audio 26498 RTP/AVP 18 4 15 0 8 101
c=IN IP4 10.194.1.133
a=rtpmap:18 G729/8000
a=fmtp:18 annexb=no
a=rtpmap:4 G723/8000
a=fmtp:4 bitrate=6.3;annexa=no
a=rtpmap:15 G728/8000
a=rtpmap:0 PCMU/8000
a=rtpmap:8 PCMA/8000
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-16

Correct Answer by Maulik Shah about 8 years 1 month ago

Check this PDF

https://supportforums.cisco.com/docs/DOC-9562


Section 4.4.11 gives you the config required for this

Correct Answer by Marcos Hernandez about 8 years 1 month ago

You will have to reassign the feature mapped to this value, before you can use it for NTE. Refer to the following table (click to enlarge):


defaultpayloadtype.png

Under the dial peer, change the "rtp payload-type cisco-codec-fax-ack" to any value between 96 and 127 THAT IS NOT RESERVED. Then you will be able to change the type for NTE.


Thanks,


Marcos

Correct Answer by Maulik Shah about 8 years 1 month ago

A couple of comments:


1. Can you remove the voice class codec on the inbound / outbound SIP Trunk dial-peers - just make it codec g711alaw as that is what the Huawei switch is sending


2. Per the SIP message logs - here is the sequence:


Huawei            UC520            AA on CUE

INVITE --->            

                             INVITE --->

                             <--- 180 Ringing

<--- 180 Ringing

                             <--- 200 OK

<--- 200 OK

                             ACK --->

<--- 200 OK

<--- 200 OK

<--- 200 OK

TIMEOUT

<--- BYE


The Huawei never ACKs the 200 OK to the UC520 and hence call fails - can you check why this is the case on the Huawei side?

Correct Answer by Marcos Hernandez about 8 years 1 month ago

I honestly don't know what they are referring to here, Probably SRTP?


Can you email me your full config and also the inbound called number that gives you a fast busy? "debug ccsip message" would be useful too.


Thanks,


Marcos Hernandez
Technical Marketing Engineer
Cisco Systems, Inc.

Correct Answer by Marcos Hernandez about 8 years 1 month ago

Looking quickly at your debugs I see that Huawei is not doing RFC2833 for DTMF, but inband rather. We do support inband DTMF (just remove any dtmf-relay command from the voip dial peers), but this will cause problems with CUE (which supports NOTIFY) and we can’t do inband to NOTIFY DTMF.


Regarding the ringback tone, I am guessing you are not matching the correct inbound dial peer and possibly ringing an extension instead. You need to verify that a voip peer exists with “incoming called-number XXXX” where XXXX is an exact match of the SIP URI for the inbound call into AA.


Thanks,


Marcos Hernandez
Technical Marketing Engineer
Cisco Systems, Inc.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (5 ratings)
Loading.
Correct Answer
Marcos Hernandez Sun, 04/19/2009 - 10:59
User Badges:
  • Blue, 1500 points or more

Looking quickly at your debugs I see that Huawei is not doing RFC2833 for DTMF, but inband rather. We do support inband DTMF (just remove any dtmf-relay command from the voip dial peers), but this will cause problems with CUE (which supports NOTIFY) and we can’t do inband to NOTIFY DTMF.


Regarding the ringback tone, I am guessing you are not matching the correct inbound dial peer and possibly ringing an extension instead. You need to verify that a voip peer exists with “incoming called-number XXXX” where XXXX is an exact match of the SIP URI for the inbound call into AA.


Thanks,


Marcos Hernandez
Technical Marketing Engineer
Cisco Systems, Inc.

Imthiyas Khan K I Mon, 04/20/2009 - 03:42
User Badges:
  • Bronze, 100 points or more

Thanks Marcos.


regarding DTMF issue, this is the replay i received from Huawei


For RFC2833, currently its disabled on SIP-T, in case to enabled its require for 2833 encryption key It is one of the parameters for the SoftX3000 to interwork with your  SIP device. It specifies the RFC2833 shared secret key between the SoftX3000 and the SIP device. It is a string of 8 to 16 characters.


is there any such setting in the CME ?


Voicemail/AA.


I think there is no issue with the inbound dial-peer. becuase when i do SIP Trunk from the same system with the same conf to another Cisco CME, i am able to access the Voice mail and AA.


Thanks in advance

Correct Answer
Marcos Hernandez Mon, 04/20/2009 - 11:57
User Badges:
  • Blue, 1500 points or more

I honestly don't know what they are referring to here, Probably SRTP?


Can you email me your full config and also the inbound called number that gives you a fast busy? "debug ccsip message" would be useful too.


Thanks,


Marcos Hernandez
Technical Marketing Engineer
Cisco Systems, Inc.

Maulik Shah Mon, 04/20/2009 - 12:15
User Badges:
  • Silver, 250 points or more

I looked at the RFC2833 RFC and there is no encryption key unique to RFC2833 so not sure what Huawei is telling you - you can look for yourself:


http://www.faqs.org/rfcs/rfc2833.html


The only way to encrypt the RFC2833 packets is to encrypt the whole RTP stream as sRTP (secure RTP) in which case the key exchange happens through SIP negotiation, not entered statically on the devices. My guess is this is a NON standard RFC2833 implementation on Huawei - you really want them to change this to be standards based. Not much we can do on the UC520 other than you may try using SIP KPML as an option though again we have not tested this extensively on the UC520. By the way, does Huawei require RFC2833 on a specific RTP payload type - UC520 uses 101 by default - you should ask that.


On the issue for inbound call just ringing, not going to AA - we need debugs & the exact number you call as Marcos mentioned as I looked at the config you attached and seems ok. Is the transcoder registered as well? Can you make inbound calls to an IP phone directly from the SIP trunk if you mapped the DID to the IP phone extension?


On a side note - which SP is the testing for?


Thanks

Maulik

Maulik Shah Wed, 04/22/2009 - 13:45
User Badges:
  • Silver, 250 points or more

Pls upload your debugs here so others on this forum can help as well


Thx

Correct Answer
Maulik Shah Wed, 04/22/2009 - 22:17
User Badges:
  • Silver, 250 points or more

A couple of comments:


1. Can you remove the voice class codec on the inbound / outbound SIP Trunk dial-peers - just make it codec g711alaw as that is what the Huawei switch is sending


2. Per the SIP message logs - here is the sequence:


Huawei            UC520            AA on CUE

INVITE --->            

                             INVITE --->

                             <--- 180 Ringing

<--- 180 Ringing

                             <--- 200 OK

<--- 200 OK

                             ACK --->

<--- 200 OK

<--- 200 OK

<--- 200 OK

TIMEOUT

<--- BYE


The Huawei never ACKs the 200 OK to the UC520 and hence call fails - can you check why this is the case on the Huawei side?

Imthiyas Khan K I Thu, 04/23/2009 - 03:08
User Badges:
  • Bronze, 100 points or more

Thanks Maulik,


I send the details to Huawei, expecting the replay soon.


Regarding the DTFM issue.


Huawei is using 97 as the payload type, but when i try to change the payload type under dial-peer to 97 am getting an error.


Router(config-dial-peer)#rtp payload-type nte 97  
ERROR: value 97 in use!


Thanks

Correct Answer
Marcos Hernandez Thu, 04/23/2009 - 06:01
User Badges:
  • Blue, 1500 points or more

You will have to reassign the feature mapped to this value, before you can use it for NTE. Refer to the following table (click to enlarge):


defaultpayloadtype.png

Under the dial peer, change the "rtp payload-type cisco-codec-fax-ack" to any value between 96 and 127 THAT IS NOT RESERVED. Then you will be able to change the type for NTE.


Thanks,


Marcos

Imthiyas Khan K I Sun, 04/26/2009 - 23:31
User Badges:
  • Bronze, 100 points or more

Thanks Marcos and Maulik


After chaning the rtp payload to 97, DTMF issue is solved.


thank you once again for the support.


now the only remaming part is Voicemail/AA issue.

Maulik Shah Mon, 04/27/2009 - 08:59
User Badges:
  • Silver, 250 points or more

Glad to hear the DTMF issue is resolved. Issue with VM / AA needs Huawei's insight on why there is no response to the 200 OK.


As a side note, once you are done with this testing - it may be good to write up a tech note on how to setup the UC520 with your service and post to the community.

Imthiyas Khan K I Thu, 04/30/2009 - 03:50
User Badges:
  • Bronze, 100 points or more

Hi,


  Sure i will do that, if you have any sample tech note, plese share with me.


regarding the VM/AA issue, i send the details to Huawei and waiting for the replay.


Today i upgraded the IOS to c2800nm-adventerprisek9_ivs-mz.124-24.T.bin CME Version 7.1


after the upgrade, i am able to hear the message from VM and AA, again inbound DTMF is not working. But it is working with the ip phones. so i changed the rtp paylord type in voice mail and AA dial peer.


How can i change the paylord type in CUE.


thanks in Advance

Marcos Hernandez Thu, 04/30/2009 - 05:41
User Badges:
  • Blue, 1500 points or more

CUE uses 'sip-notify' as the DTMF method. Make sure this is what you have under the dial-peer that points to CUE.


Thanks,


Marcos Hernandez
Technical Marketing Engineer
Cisco Systems, Inc.

Imthiyas Khan K I Thu, 04/30/2009 - 06:07
User Badges:
  • Bronze, 100 points or more

Thanks Marcos,


No luck, still not working


correct me if i am wrong.


CME conf


dial-peer voice 1 voip
description **Incoming Call from SIP Trunk**
rtp payload-type cisco-codec-fax-ack 105
rtp payload-type nte 97
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
session protocol sipv2
session target sip-server
incoming called-number .%
dtmf-relay rtp-nte
no vad


dial-peer voice 2 voip
description **Outgoing Call to SIP Trunk**
translation-profile outgoing PSTN_Outgoing
destination-pattern [1378].......
rtp payload-type cisco-codec-fax-ack 105
rtp payload-type nte 97
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
session protocol sipv2
session target ipv4:10.121.255.1
dtmf-relay rtp-nte
no vad
!
dial-peer voice 10 voip
description **CUE Voicemail**
destination-pattern 2006
b2bua
session protocol sipv2
session target ipv4:10.121.0.2
dtmf-relay sip-notify
codec g711ulaw
no vad
!
dial-peer voice 11 voip
description **CUE Auto Attendant**
destination-pattern 2005
b2bua
session protocol sipv2
session target ipv4:10.121.0.2
dtmf-relay sip-notify
codec g711ulaw
no vad



CUE Conf


ccn subsystem sip
gateway address "10.121.0.5"
dtmf-relay sip-notify
end subsystem


ccn trigger sip phonenumber 2005
application "autoattendant"
enabled
maxsessions 8
end trigger


ccn trigger sip phonenumber 2006
application "voicemail"
enabled
maxsessions 8
end trigger


thanks in advance

Imthiyas

Maulik Shah Thu, 04/30/2009 - 10:12
User Badges:
  • Silver, 250 points or more

Couple of comments:


- Are you testing this on an ISR (2800) or a UC520? Thought this was UC520. The sample guide is at:

https://supportforums.cisco.com/docs/DOC-9562


- The DTMF config looks ok - does this work just fine on the UC520 on the 12.4(20)T image? Would need deb ccsip mess / deb voip rtp session named-events for a failed call

Imthiyas Khan K I Mon, 05/04/2009 - 02:15
User Badges:
  • Bronze, 100 points or more

Yes, i am testing with 2811.


after i enabled the voip rtp session named-events, i can't see any debug messages when i press any keys from outside to AA.

but when i call from outside to any ip phone, i am able to hear the dtmf tone but can't see any messages from debug


please see the attachment for ccsip mess

Maulik Shah Mon, 05/04/2009 - 12:12
User Badges:
  • Silver, 250 points or more

This forum is more for Cisco small business -i.e. UC520 and from an earlier post you mentioned the DTMF issue was resolved on the UC520. Now your issue appears to be on the 2800. Would recommend you either post this issue to netpro (http://forums.cisco.com/eforum/servlet/NetProf?page=main) or open a Cisco TAC case (http://tools.cisco.com/ServiceRequestTool/create/launch.do) to get you further as this seems to be drawing out a fair bit and it may be best to troubleshoot this via a formal TAC case.


A cursory glance at the debugs shows Huawei is not even sending RFC2833 in the initial INVITE SDP - not sure why so you may want to check with them.


May  4 09:41:07.560: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
INVITE sip:[email protected]:5060;user=phone SIP/2.0
...

m=audio 12498 RTP/AVP 8

a=rtpmap:8 PCMA/8000
a=ptime:20


May  4 09:41:07.848: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
SIP/2.0 200 OK

...

m=audio 16456 RTP/AVP 8 97

a=rtpmap:97 telephone-event/8000
a=fmtp:97 0-16

Imthiyas Khan K I Tue, 05/12/2009 - 21:50
User Badges:
  • Bronze, 100 points or more

Thanks Maulik,


Sorry for the delay, I was out of country for a week.


As you mentioned in the last replay, the DTMF issue was solved but only outbound DTMF not inbound. That is why i tested with 2811 with CME 7.0

Maulik Shah Tue, 05/12/2009 - 22:49
User Badges:
  • Silver, 250 points or more

Go  back to testing with the UC520 - if DTMF does not work for inbound calls to the UC520 - then gather the debug output and compare with what I pointed out in my previous email - if its the same, please ask Huawei the below:


- why is RFC2833 not supported in the SDP

- why are not RFC2833 RTP packets being seen


To be sure that its not a UC520 issue, you can even run a wireshark capture on the UC520 WAN interface and check if you see any RFC2833 RTP packets from Huawei.

Actions

This Discussion