Ether-Channel Frequent problem

Unanswered Question
Apr 19th, 2009
User Badges:

Hii Freinds,

Facing some strange problem with Ether-Channel. We have two cisco 4507 switches placed remote to each other (i.e not at same place), connected with two parallel simataneous links(on gig ports) on which L2 etherchannel is running.


When there is problem with any of the link, remote end (i.e Switch-2 ) unreachable and always we have to manually shut first link port from Switch-1 ... then after reachability of switch-2 is fine on another/second link.


Second case, In case of unreachability os switch-2, When we only shut second link port from Switch-1 end. Switch-2 is not getting reachable i.e Switch-2 unreachable.


We have checked for solution in all way. But still have to find out the root cause, Whether problem is happening due to issue from transmission end or due to our switches configs(etherchannel/ port channel related).


Configs of ether-channel from both the Switches are as:-


Switch-1 EtherChannel Config :-


Cisco_4507_Sw1#sh run int po1

Building configuration...

Current configuration : 269 bytes

!

interface Port-channel1

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 2,4,6,8,10,12,14

switchport mode trunk

switchport nonegotiate

speed nonegotiate

end



Cisco_4507_Sw1#sh run int gi1/2

Building configuration...

Current configuration : 371 bytes

!

interface GigabitEthernet1/2

description ++ GigaLink 4507 on Switch-2 Corresponding port Gigi1/4 ++

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 2,4,6,8,10,12,14

switchport mode trunk

switchport nonegotiate

speed nonegotiate

channel-group 1 mode on

end



Cisco_4507_Sw1#sh run int gi1/3

Building configuration...

Current configuration : 370 bytes

!

interface GigabitEthernet1/3

description ++ GigaLink 4507 on Switch-2 Corresponding port Gigi1/5 ++

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 2,4,6,8,10,12,14

switchport mode trunk

switchport nonegotiate

speed nonegotiate

channel-group 1 mode on

end


++++++++++++++++++++++++



Ether-Channel config on Switch-2 :-


Cisco_4507_Sw2#sh run int po1

Building configuration...

Current configuration : 269 bytes

!

interface Port-channel1

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 2,4,6,8,10,12,14

switchport mode trunk

switchport nonegotiate

speed nonegotiate

end



Cisco_4507_Sw2#sh run int gi1/4

Building configuration...

Current configuration : 356 bytes

!

interface GigabitEthernet1/4

description ++ Gig Connectivity on Switch-1 corresponding port Gigi1/2 ++

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 2,4,6,8,10,12,14

switchport mode trunk

switchport nonegotiate

speed nonegotiate

channel-group 1 mode on

end



Cisco_4507_Sw2#sh run int gi1/5

Building configuration...

Current configuration : 356 bytes

!

interface GigabitEthernet1/5

description ++ Gig Connectivity on Switch-1 corresponding port Gigi1/3 ++

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 2,4,6,8,10,12,14

switchport mode trunk

switchport nonegotiate

speed nonegotiate

channel-group 1 mode on

end



Please help to diagnose the reason of problem.


Network snerio attached here.


regards




  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Sun, 04/19/2009 - 03:39
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Jimmy,

if the transport MUXs are able to keep the interface up/up you should use LACP:

lacp provide signalling messages that are exchanged every few seconds


try to do the following on both ends


int gix/y

channel-group 1 mode active


in this way the remote switch should be able to detect when a link is seen as not working : it stops to receive LACP messages and so it can disable the link.



Hope to help

Giuseppe



cisco.net Sun, 04/19/2009 - 08:40
User Badges:

Hiii Giuseppe,


Seems you are almost close and very right that in all condition / always Gig ports at both the switches are UP even when fiber link between both the MUXes went down then also ports are reflecting as UP only.


But ideally if problem happen in any of the link, then respective ports should go down at both switches.


So..."channel-group 1 mode active" command is only for this purpose...? is this command will do the same thing which UDLD feature is doing..? I am putting this concern just b'coz i have also checked by enable "udld port aggresive" in respective port-channel bundled Gig interfaces at both switches, but problem was as it is.



Regards

Jimmy.

Giuseppe Larosa Sun, 04/19/2009 - 11:09
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Jimmy,

UDLD is for detecting uni-directional links.


LACP is a protocol designed for negotiating, setting up and to dynamically adjust/mantain etherchannels and it is standards based


see


http://www.cisco.com/en/US/docs/switches/lan/catalyst3750/software/release/12.2_44_se/configuration/guide/swethchl.html#wpxref12539


Hope to help

Giuseppe


cisco.net Mon, 04/20/2009 - 01:07
User Badges:

HI Giuseppe ,


Thanks,


Oe more observation found.


very Few access nodes(lets say 2 nodes out of 10) which are connected from Switch-2 are going unreachable while shutting first link. rest nodes are reachable fine.


On shutting second link, as mentioned in first updates Switch-2 totally unreachable for us but the same sites connected from switch-2 which are unreachable while shutting first links are now reachable. just amazing. what could be the reason.

Giuseppe Larosa Mon, 04/20/2009 - 01:33
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Jimmy,

from the point of view of the bundle each telnet session is a flow.

Each flow is associated with one member link.


Flows associated to the link that actually is not working are sent to a black hole.


This is the reason you see some switches behind the bundle unreachable and other reachable.


And it is for this kind of problems that I suggest to move to an LACP managed bundle.


Hope to help

Giuseppe

cisco.net Mon, 04/20/2009 - 03:09
User Badges:

Is same thing also happening with PING..?? (as you mentioned above for telnet session).


regards

Giuseppe Larosa Mon, 04/20/2009 - 04:04
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Jimmy,

yes traffic flows are defined by IP SA and IP DA for etherchannel load-balancing purposes so it doesn't change with ICMP or with TCP port 23 (telnet)


Hope to help

Giuseppe


cisco.net Mon, 04/20/2009 - 09:26
User Badges:

Hii Giuseppe,


I have tryed you suggestion i.e configured "channel-group 1 mode active" on switch-1 and switch-2 Gig ports, But again after that Switch-2 was totally un-reachable.


Hence when i tryed to revert the config mode active command was removed but now all Gig ports are not taking old command "channel-group 1 mode on". We were in trouble. traffic only follwing path of 1st link.


However we removed command "mode active" from all ports. But still etherchannel is showing LACP protocol.


Cisco_4507_Sw1#sh etherchannel 1 summary

Flags: D - down P - in port-channel

I - stand-alone s - suspended

R - Layer3 S - Layer2

U - in use f - failed to allocate aggregator

u - unsuitable for bundling

w - waiting to be aggregated

d - default port



Number of channel-groups in use: 2

Number of aggregators: 2


Group Port-channel Protocol Ports

------+-------------+-----------+-----------------------------------------------

1 Po1(SU) LACP Gi1/2(P) Gi1/3(P)


ISP#



PLease help to revert disable the LACP for which we tryed all command but the same is not removing.

Actions

This Discussion