Factory reset on Cisco 7940G with SIP "POS3-06-3-00"

Unanswered Question
Apr 19th, 2009

I am not able to perform a factory reset on a Cisco IP Phone 7940G with SIP.

The password for the "unlock config" got lost! Tried also the default "cisco". The 7940G got configured by a coworker, who left the company.

Allready I tried with pressing "*+ 6 + Settings" and holding down # before the headset led starts blinking, but the option for a reset will not be shown.

Please provide a solution for a factory reset

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Paolo Bevilacqua Mon, 04/20/2009 - 09:21

Factory reset is holding # until leds flash in sequence, then 123456789*0#.

If that fails you've to trick the phone via config files, but it's complicated and you would be probably better selling it and getting an unlocked one.

czapkapat Mon, 04/20/2009 - 23:28

Holding # until leds flash in sequence does not work! I allready tried that many times.

Actually I do not want to sell the phone.

What do I have to do to get this done with the trick of the Config files?

As I sad before SIP Version POS3-06-3-00 is installed on it.

czapkapat Sun, 04/26/2009 - 23:41

Hello all,

does nobody has any information how to perform a factory reset on the 7940 with SIP?

I can not believe that it happened before, that a config-password got lost and that there is no way to reset the phone?

I am very happy to get any kind of help, resolving this issue.

Paolo Bevilacqua Mon, 04/27/2009 - 00:36

Do you get to the point where the phone says "reset sequence detected" and prompt 1 o 2 ?

czapkapat Mon, 04/27/2009 - 00:46

no, the Phone is not comming up with this point.

It is like never pushed and hold # wright after powered on the 7940G, but I really did :-(

Paolo Bevilacqua Mon, 04/27/2009 - 05:00

With some version of FW, it is possible to disable the reset sequence.

You can try with wireshark to find which IP address and CM address the phone wants to use.

Then, again with a PC using TFTPD32, you give it a configuration file that either specifies a known configuration password, or a different firmware.

As I said it is quite an hacker job that most peple doesn't have the time or the skills to do.

wg wireless Thu, 11/11/2010 - 03:19

Hi,

Em having the exact problem, the phone has POS-06-3-00 firmware and "Unlock Config" option has default password "cisco" but em not able to restore the phone to factory defaults. I have tried holding "#" button at startup but nothing happens and the phone boots normally. Anyone knows the procedure to reset it? (it does not matter if its a lengthy or difficult procedure)

Thanks...

Paolo Bevilacqua Thu, 11/11/2010 - 04:36

As mentioned above, you need to start capturing, to see which address the phone wants TFTP from.

pb2aupb2au Wed, 12/29/2010 - 12:53

Hello!

This might be a little late for some, but I had the exact same problem.  What resolved it was to setup a tftp server on the IP address currently in the phone, and then update the SIP firmware.  I was then able to reboot the phone, press #, and then 123456789*0# to reset the phone.

Steps

1. Setup a tftp server on the IP address configured within the phone

    o To find the tftp IP address

    o Press Setting

    o Press Network Settings

    o Scroll Down to the TFTP Address

2. Download and install the latest SIP firmware on the tftp server

3. Reboot the Phone without pressing any keys.  The phone should update the firmware automatically.

4. Once the SIP update is complete,

    o Restart the phone (unplug/plug in the phone)

    o Press #, and then 123456789*0# to reset the phone

cheers

Actions

This Discussion