Auto-rp

Unanswered Question
Apr 20th, 2009

Hi ,

We have 3 routers connected as attached topology. All routers and interfaces are enabled for multicasting spares-dense mode. Router A is also configured as below,

ip multicasting-routing

ip pim spare-dense mode


ip pim send-rp-announce vlan 355 scope 23 group-list rp

ip pim send-rp-discovery scope 23 vlan 355

access-list rp permit 239.255.1.1


I can see "show ip pim rp" on router A , and also mroute for group 239.255.1.1.

but on other 2 routers I can only see "show I Pim rp mapping" for group 239.255.1.1 maped to rp, but no mroute for that group nor any thing under "sh ip pim rp" .Is this normal behaviour.


Regards,



Attachment: 
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Giuseppe Larosa Mon, 04/20/2009 - 10:35

Hello Mohammed,

on the router acting as the mapping agent you should specify a loopback as the ip address in use.


under that loopback interface you need

int loop M

ip pim sparse-mode


this is necessary for the mapping agent to process candidate rp advertisements and to create mappings


the loopback should be used also for RP and has to be advertised in the unicast IGP.


see


http://www.cisco.com/en/US/docs/ios/ipmulti/command/reference/imc_04.html#wp1014843



Hope to help

Giuseppe


mohammedrafiq Mon, 04/20/2009 - 12:20

Thanks Guiseppe,

Hope you are well,I did not use loopback cos lookbacks was not advertise into IGP.I thought you can use any interface as RP and mapping agent as long other routers can reach to it.


Regards,

Giuseppe Larosa Mon, 04/20/2009 - 12:29

Hello Mohammed,

I'm well thanks so I hope you are.

You probably can use interfaces that are not loopbacks but I think you should use the interface option to specify one.

That is only one ip address can be used for RP advertise and for the mapping agent.

This is the reason why usually loopbacks are used for this job.


Hope to help

Giuseppe


mohammedrafiq Mon, 04/20/2009 - 12:37

ok,

can I use looback0 of router A for both RP adv and mapping agent?,I need to keep RP adv and maping agent on same router.


Regards,

mohammedrafiq Tue, 04/21/2009 - 01:02

Thanks Harlod,

Any idea why I cant see the mroute on router B and C for group 239.255.1.1 ?


Regards,

thotsaphon Tue, 04/21/2009 - 02:18

Mohammed,

That should work. I'm not sure that the RouterB and RouterC have these command on.


All Routers

ip multicasting-routing


All interfaces:

ip pim spare-dense mode


You need to use a spare-dense mode in this case because you are flooding 239.0.1.39 and 239.0.1.40 as dense.


However, To make sure that the RouterC can reach VLAN_355 on RouterA.


Toshi

Harold Ritter Tue, 04/21/2009 - 05:02

Toshi,


An alternative to using sparse-dense mode would be to configure "ip pim autorp listener" in global configuration mode. This commands allows you to use auto-rp and to configure the interfaces in sparse rather than sparse-dense mode.


Regards

thotsaphon Tue, 04/21/2009 - 05:09

Harold,

You're right. That works as well.


Harold one question,I no longer see Francois(Switching Hero) and Russ(Routing Hero).Where are you guys? (grin)


Thanks, 5P! for you

Toshi

Harold Ritter Tue, 04/21/2009 - 05:09

Mohammed,


Make sure that the receiver has sent is IGMP membership report message ("show ip igmp group"). Also, verify that both router B and C see the RP ("show ip pim rp map").


Regards

Actions

This Discussion