CRS 5.0(2): calls recorded - hear silence

Unanswered Question
Apr 20th, 2009

Hi. I have configured my UCCX to record incoming calls. I have a server with 2 NICs, one of them is configured for Monitoring and Recording (it's connected to a SPAN switch port).

I've been trying to record calls in two ways:

- automatically via WorkFlow;

- by pressing Start Record button in CSD;

No matter how I try to record them, the calls seem to be recorded. When I open Supervisor Record Viewer, I can see a lot of recroded calls. But when I try to play them - I hear silence. If I choose Play and Save, I have a .wav file saved on my PC, that seems not to be empty. The size of the file is big enough (about 900Kbyte for 1 minute call). But when I try to play that file on Windows Media Player - I hear only silence again.

So, it looks like that CRS captures VoIP traffic pretty well, saves calls, but why I can't hear a thing?

Does anyone have an experience in solving such a problem?

Thanks.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
ugin Mon, 04/20/2009 - 12:23

safety2008

Thank you for your docs, but it's not my case. In my configuration all the inbound calls must be recroded automatically. This can be configured only in Work Flow Group on UCCX server, when all VoIP traffic is mirrored (via SPAN) to one of the server's NICs.

So the problem is not to be in agents' workstations.

I have followed all the common recomendations on servers. I mean order of TCP binding of NICs etc.

But the problem still exists.

Jason Hutchinson Mon, 04/20/2009 - 13:03

Make sure the device has g722 codec to disabled from teh call maanger page. Do not use default, select disabled.

.

Sounds like everything else is checked over

.

JMH

ugin Tue, 04/21/2009 - 03:43

jashutch

CUCM > System > Service Parameter COnfiguration > Service Cisco CallManager;

Section "Clusterwide Parameters (System - Location and Region);

item "G722 Codec Enabled"

Did you mean this setting?

ugin Tue, 04/21/2009 - 04:21

I have some progress :)

I've looked into "c:\Program Files\Cisco\Desktop_Audio" directory on the server. It's where it keeps recroded calls in raw format.

I see that all files have size 1KB, except some, that have been recorded by one particular agent. I can play and hear that agent's calls!

Very strange... Only one agent of 60 is recorded.

sean.moore Mon, 05/04/2009 - 13:20

No sure about 5, but in 7 you need to make sure Built In Bridge is ON on the agents phone.

sebastiaanv Tue, 04/21/2009 - 23:13

I suppose you already compared the phone settings from that particular agent with the other phone settings?

ugin Thu, 04/23/2009 - 02:54

The settings were absolutely the same.

Suddenly another agent started being recorded. Anf I know for sure, that no setteings on his phone or profile or CAD were changed.

Then I found out that if I choose some agent and start Voice Monitor via CSD, then the program "hangs" for aboout 30 sec, and then I can hear the conversation. And finally, after that, the UCCX starts to record that agent's calls.

Sometheing is initialized when start voice monitor... So, it's good that it started working. But the bad thing is that I still don't understand the way it happens.

Yue bun Yuen Sat, 04/25/2009 - 20:34

I have the same problem as you.

I use CCM 6.13 with UCCX 7.01sr1 enh version. I don't want to use CSD or CAD to activite the recording. Just want to use the UCCX server second NIC as a capture port to auto recording all the agents' call.

The following are the procedures what I have done.

1. All the ccm, uccx, and IP phone are connected to same switch and on the same vlan.

2. copy all the vlan 10 traffic to the destination switch port ( connect to the UCCX second nic )

3. Set the binding order of the two network card in UCCX.

4. Run Postinstall.exe, set the Voip monitor service to the UCCX second nic ip address.

5. Assign the Voip monitoring device in the Cisco Desktop Administrator under the Slient Mointoring & Recording ( I am not sure if it is neccessary or not )

6. Set Enable IPPA Recording under the Cisco Desktop Work Flow Administrator.

7. G722 codec is disabled in CCM

The server fail to record the agent call automatic, there are not files in the desktop_audio folder.

Does anyone has idea?

ugin Mon, 04/27/2009 - 02:23

Did you configure Work Flow Rules and Actions?

ALLYSON REAVES Tue, 05/19/2009 - 06:46

When using the play/save option, you must wait until the download bar has completed before saving. Then you should be able to hear your recordings.

ugin Tue, 06/16/2009 - 07:17

Found a solution to original problem.

In Cisco Desktop Admin:

Locations -> CallCenter1 -> Enterprise Data Configuration -> Voip Monitor

I had to uncheck "Enable Desktop Monitoring" for all extensions. Now it records the calls the way it should ;)

Actions

This Discussion