Router on a stick

Unanswered Question
Apr 20th, 2009

I have a 1841 router and a catalyst switch. On the switch I created 2 VLANs. VLAN 1 ports 1-12. VLAN 2 ports 13-24. The switch also has 2 Gi ports and I am using those to connect to the 1841 on the Fa0/0 and Fa0/1 ports. Each port is on a different network. The problem I am having is I can not router traffic from one network to the other. I have covered all the basics I think it should be working. Any ideas?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Richard Burts Mon, 04/20/2009 - 09:19


How are the Gig interfaces on the switch configured? Is one of them carrying VLAN 1 and the other carrying VLAN 2?

It might be helpful if you would post the configuration of the interfaces on the 1841.

It might be helpful if you would also post the output of show vlan from the switch.



HMidkiff Mon, 04/20/2009 - 09:44

Thanks for replying to my post. On the switch each Gig port is on a VLAN. Here is a little out put.

*** Interfaces ***

interface GigabitEthernet0/1

description Connected to TAMPA-GUEST Public VLAN (

speed 100

duplex full


interface GigabitEthernet0/2

description Connected to TAMPA-GUEST Private VLAN (

switchport access vlan 2

speed 100

duplex full

*** Show VLAN ***

VLAN Name Status Ports

---- -------------------------------- --------- -------------------------------

1 default active Fa0/1, Fa0/2, Fa0/3, Fa0/4

Fa0/5, Fa0/6, Fa0/7, Fa0/8

Fa0/9, Fa0/10, Fa0/11, Fa0/12


2 VLAN0002 active Fa0/13, Fa0/14, Fa0/15, Fa0/16

Fa0/17, Fa0/18, Fa0/19, Fa0/20

Fa0/21, Fa0/22, Fa0/23, Fa0/24


1002 fddi-default act/unsup

1003 trcrf-default act/unsup

1004 fddinet-default act/unsup

1005 trbrf-default act/unsup

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2

---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------

1 enet 100001 1500 - - - - - 0 0

2 enet 100002 1500 - - - - - 0 0

1002 fddi 101002 1500 - - - - - 0 0

1003 trcrf 101003 4472 1005 3276 - - srb 0 0

1004 fdnet 101004 1500 - - - ieee - 0 0

DELL ACORD Mon, 04/20/2009 - 09:23

Plz post the config for the router.

Make sure you have configured the correct trunk protocol and have configured the native vlan to match the primary vlan with the switch.

Hope this helps.

HMidkiff Mon, 04/20/2009 - 11:14

I solved part of the routing problem. I didn't have routing configured on the router. Since the networks are on accociated interfaces (Fa0/0 & Fa0/1) I would have thought routing would work. I configured EIGRP and then I was able to passing traffic.

Richard Burts Mon, 04/20/2009 - 11:23


Ordinarily routing is automatically enabled on the 1841 router. Perhaps something had been configured to prevent it? Anyway I am glad that you have the routing issue solved.

This post says that you solved "part of the routing problem". Are there still things that are not working? If so, what are they?



HMidkiff Mon, 04/20/2009 - 11:56

The other part is the VLAN. I just might not be understanding them correctly. The C2950 is a layer 2 switch and can only have 1 active VLAN as a time. I configered 2 VLAN. I guess even though I see one down both VLANs are working?

Jon Marshall Mon, 04/20/2009 - 12:01


The key concept to understand is the difference between a L2 vlan and a L3 vlan interface for that vlan.

So a L3 capable switch can have multiple vlans and also multiple L3 vlan interfaces.

A L2 switch such as the 2960 can have multiple L2 vlans but only one active L3 vlan interface. This L3 vlan interface is used purely for remotely managing the switch.

"sh vlan" will show you the L2 vlans

"sh ip int brief" will show the L3 vlan interfaces and any other L3 interfaces.



This Discussion