Tunnel Interface to Area 0

Unanswered Question
Apr 20th, 2009
User Badges:

Hi,


I just did a lab last night and got confused with the message I got from OSPF. Here's the setup.


R1----R2----R5-----R4


The link between R1 and R2 is area 0 and the link between R2 and R5 is area 1. R5 and R4 segment is area 2. The task mentioned that I can use another IP subnet to connect area 2 to the backbone so it gave me the idea that I should be using tunnel interface. I created a tunnel interface between R2 and R5 and put it in area 0. The routes propagated properly but on R5, i keep on receiving this message on the console.


Apr 8 12:15:31.011: %OSPF-4-ERRRCV: Received invalid packet: mismatch area ID, from backbone area must be virtual-link but not found from 141.11.123.2, Serial0/0


R1 and R2 segment is a frame-relay link. That is the 141.11.123.2 IP. The routing table is stable but I just wonder why do I keep on getting these message. I tried to change the tunnel interface to area 2 but I still receive the same error message. Thanks in advance.


Oh wait...I checked out the solution guide and the one I did was correct. It didn't use virtual-link because area 1 is an NSSA.


John



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (1 ratings)
Loading.
Laurent Aubert Mon, 04/20/2009 - 18:44
User Badges:
  • Cisco Employee,

Hi,


You are receiving those packets on serial0/0.


It seems R5 is connected to your FR backbone either with a static or dynamic mapping..


Also R5 should be configured with the no-summary option as it's an ABR like R2


HTH


Laurent.

John Patrick Lopez Mon, 04/20/2009 - 23:51
User Badges:

Oh yeah... Maybe that's the reason why. R5 learned a mapping thru inverse-arp.


area 1 is a totally-NSSA but area 2 is not so I did not issue the no-summary option at R5 for area 2.

Laurent Aubert Tue, 04/21/2009 - 04:43
User Badges:
  • Cisco Employee,

I was thinking about area 1 not area 2.


R5 is an ABR for area 1 too just like R2


Laurent.

Actions

This Discussion