vlan routing.

Unanswered Question
Apr 20th, 2009
User Badges:


I set up router and switch to check vlan routing. below is the configuration I made. but ping is not successd.

could you please tell me what's wrong with my config?


[Router]

interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0.1

encapsulation dot1Q 2

ip address 10.43.2.1 255.255.255.0

!

interface FastEthernet0/0.2

encapsulation dot1Q 6

ip address 10.43.6.1 255.255.255.0



[Switch]

interface FastEthernet0/1

switchport access vlan 2

switchport mode access

!

interface FastEthernet0/2

switchport mode trunk

!

Switch#ping 10.43.2.1


Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.43.2.1, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)




  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
bmcginn Mon, 04/20/2009 - 19:24
User Badges:
  • Bronze, 100 points or more

Hi there,


Depending on the model of switch you're using, the encapsulation may be required for the trunk port.


ie:

interface fa0/2

switchport trunk encapsulation dot1q

switchport mode trunk


Also, you should check to ensure that your VLAN 2 SVI is working and not shutdown. (switches default to vlan1).


Have you created the actual VLAN on the switch?


you should also check to ensure you have the default gateway on the switch.


good luck!


Brad

glen.grant Tue, 04/21/2009 - 03:22
User Badges:
  • Purple, 4500 points or more

On the switch if you do a "show vlan" does vlan 2 and 6 show active ? If not you have not created the layer 2 vlan on the switch side . The rest of the config looks ok .

Actions

This Discussion