1242 connectivity issue

Unanswered Question
Apr 20th, 2009
User Badges:

Please see attached Visio to understand my topology. I am using a 1242 that is running c1240-k9w7-mx.124-10b.JDA.

Issue: When I try to use TCP 80 (HTTP) from the laptop I get "the page cannot be displayed" even though I can ping the server with 30 to 40ms ping times. If I used the wired computer I am able to HTTP to the server. Any idea what would allow the wired machine to connect but the wireless laptop to fail when using HTTP or any other application layer protocol? Please note that all the devices exist on a flat network and both the laptop and bridge are using the "A" radio on the 1242.


Thanks in advance!


Here is my config...

Wireless#sh run

Building configuration...


Current configuration : 2773 bytes

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname Wireless

!

logging buffered warnings

logging console notifications

logging monitor notifications

enable secret 5 $1$7/oA$hurwSP15N3UgLWSzTvE6//

!

aaa new-model

!

!

aaa authentication login default local

aaa authentication login eap_methods group rad_eap

aaa authentication login mac_methods local

aaa authorization exec default local

aaa accounting network acct_methods start-stop group rad_acct

!

aaa session-id common

clock timezone EST -5

clock summer-time EST recurring

no ip domain lookup

ip domain name MyHouse.com

!

!

!

dot11 ssid MySSID

authentication open

authentication key-management wpa

guest-mode

wpa-psk ascii 7 020E542200085E271D2f52

!

dot11 ssid aSSID

authentication open

authentication key-management wpa

guest-mode

wpa-psk ascii 7 011B335450055709721342

!

dot11 network-map

power inline negotiation prestandard source

!

!

username anthony privilege 15 password 7 XXXXXXXX

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

!

encryption mode ciphers tkip

!

ssid MySSID

!

speed basic-1.0 basic-2.0 basic-5.5 basic-11.0 basic-6.0 basic-9.0 basic-12.0 basic-18.0 basic-24.0 basic-36.0 basic-48.0 basic-54.0

channel 2437

station-role root

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface Dot11Radio1

no ip address

no ip route-cache

!

encryption mode ciphers tkip

!

ssid aSSID

!

dfs band 3 block

speed basic-6.0 basic-9.0 basic-12.0 basic-18.0 basic-24.0 basic-36.0 basic-48.0 basic-54.0

channel 5200

station-role root

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface FastEthernet0

no ip address

no ip route-cache

duplex auto

speed auto

bridge-group 1

no bridge-group 1 source-learning

bridge-group 1 spanning-disabled

!

interface BVI1

ip address 10.10.10.5 255.255.255.0

no ip route-cache

!

ip default-gateway 10.10.10.1

ip http server

ip http authentication aaa

no ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

bridge 1 route ip

!

!

!

line con 0

line vty 0 4

password 7 104A54327947165B0B

line vty 5 15

!

sntp logging

sntp server x.x.x.x

sntp broadcast client

end



Attachment: 
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
gamccall Tue, 04/21/2009 - 05:13
User Badges:
  • Silver, 250 points or more

If you can ping the server, then layers 1-3 are working correctly. I'd check to see if there are any firewall/ port forwarding rules in your Linksys which might cause this.

anowell Tue, 04/21/2009 - 12:01
User Badges:

Thanks for the response!


The Linksys bridge does not allow you to configure port forwarding and it does not have any firewall rules. Any other ideas?

gamccall Tue, 04/21/2009 - 12:06
User Badges:
  • Silver, 250 points or more

Hmm. Put a sniffer on your "small switch" and observe both a ping conversation and an http attempt. It'd be helpful to know which packets are getting how far.


This isn't a DNS problem, is it? If you're pinging by numeric IP but browsing by hostname, that'd be one possibility...

anowell Tue, 04/21/2009 - 12:09
User Badges:

I am using the IP to "http" to the box.


I will put a sniffer on the "small switch" side and capture the packets. Stay tuned! Thanks again.

Actions

This Discussion

 

 

Trending Topics: Other Wireless Mobility

client could not be authenticated
Network Analysis Module (NAM) Products
Cisco 6500 nam
reason 440 driver failure
Cisco password cracker
Cisco Wireless mode