Copy IOS (using Software Repository) to device (3750) fails

Answered Question
Apr 22nd, 2009
User Badges:

Hello:

I try to distribute the 12.2-44SE3 image that is in my Ciscoworks repository to a 3750 but during the verifation phase it fails with "Warning -SWIM1063: Minimum RAM rwequirement of the slected image cannot determined. Ram available on the device may not be enough to activate this image. Update the minimum RAM using View/Edit Image attributes or make sure that the device has enough RAM to activte the selected image or select a different image"

I did a sh ver on the device and it shows 128 meg of RAM. I did a dir flash: and it show 28 meg available in flash:

This IOS requires 128 meg on RAM and 16 meg of flash.

Correct Answer by Sven Hruza about 7 years 11 months ago

You can add bin and tar files out of the file system.


It is not so well configured by cisco, because you have to put in the path with the file name!


This is not enough:

C:\Progra~1\IOS\


This should work:

C:\Progra~1\IOS\c3750-ipbasek9-tar.122-25.SEE4.tar

Correct Answer by Sven Hruza about 7 years 11 months ago

LMS is right ;-)


You can't use a .bin file for a stack.


For stacks you have to use the full .tar file.


The failure with the deferred status I do not understand....

On which way you put the images to your repository?

I do that with the option "Added through File System". And I don't have such failures.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.5 (2 ratings)
Loading.
Sven Hruza Wed, 04/22/2009 - 08:16
User Badges:
  • Bronze, 100 points or more

That is not a problem of the device.


It is a problem of LMS, because it can't discover the available RAM and flash of the device.


Go to

RME -> Software Mgmt -> Software Repository

There are all your IOS versions listet.


Then click into a IOS versions name, it is a link to further informations.

There you will find

Minimum RAM (MB): and

Minimum Flash (MB):


Per default the value is UNKNOWN.


I think that is the problem of your error message.

didentx01 Wed, 04/22/2009 - 10:13
User Badges:

Hi...I don't get the other error anymore but it now says "Warning - SWIM1105: Image status for the selected image cannot be determined. Ensure image is not in the deferred status. See the revelent documentation on cisco.com before upgrading the images"


"Catastrophic - SWIM1110: .bin images are not supported for stack upgrade. Select a tar image for Stack Upgrade"

Correct Answer
Sven Hruza Wed, 04/22/2009 - 23:37
User Badges:
  • Bronze, 100 points or more

LMS is right ;-)


You can't use a .bin file for a stack.


For stacks you have to use the full .tar file.


The failure with the deferred status I do not understand....

On which way you put the images to your repository?

I do that with the option "Added through File System". And I don't have such failures.

didentx01 Thu, 04/23/2009 - 09:56
User Badges:

Thanks. You do need a tar file instead of the bin.

didentx01 Thu, 04/23/2009 - 13:49
User Badges:

Ok....I have the tar file on my server, but when I go to the Software Repository, add file through file system, put in my path and the file does not show up. Can you only add .bin files to the repository from the file system? Any help will be greatly appreciated.

Correct Answer
Sven Hruza Thu, 04/23/2009 - 23:34
User Badges:
  • Bronze, 100 points or more

You can add bin and tar files out of the file system.


It is not so well configured by cisco, because you have to put in the path with the file name!


This is not enough:

C:\Progra~1\IOS\


This should work:

C:\Progra~1\IOS\c3750-ipbasek9-tar.122-25.SEE4.tar

Actions

This Discussion