PPOE help only ever used PPOA on 877 routers

Unanswered Question
Apr 22nd, 2009
User Badges:

Hi,


I have only ever configured Cisco 877 routers for PPOA ADSL lines in the UK, I now have to configure another 877 for a new VPN on Ireland which use PVC 8/38 (normally 0/38 in UK) and PPOE instead of PPOA.


I have the configure attched, what do I need to change for PPOE? I can see I need to change the PVC to 8/38, but I'm not sure from then on.



Attachment: 
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Collin Clark Thu, 04/23/2009 - 05:28
User Badges:
  • Purple, 4500 points or more

Here's the working config of my PPoE connection at home.

<font size="2"></p><p>interface FastEthernet0/1</p><p> description DSL WAN Interface</p><p> no ip address</p><p> no ip redirects</p><p> no ip unreachables</p><p> no ip proxy-arp</p><p> no ip mroute-cache</p><p> duplex auto</p><p> speed auto</p><p> pppoe enable</p><p> pppoe-client dial-pool-number 1</p><p>!</p><p>interface Dialer1</p><p> description DSL WAN Dialer$FW_OUTSIDE$</p><p> ip address negotiated</p><p> no ip unreachables</p><p> ip nat outside</p><p> ip virtual-reassembly</p><p> encapsulation ppp</p><p> no ip mroute-cache</p><p> dialer pool 1</p><p> dialer-group 1</p><p> no cdp enable</p><p> ppp authentication pap callin</p><p> ppp pap sent-username <a href="mailto:[email protected]">[email protected]</a> password 0 SeCrEt</p><p></p><p>dialer-list 1 protocol ip permit</font>


Hope that helps.

jamesgonzo Thu, 04/23/2009 - 09:00
User Badges:

Thanks, what router do you have? I think I have the wrong one, I have an 877 which has an ATM port and not and Ethernet like yours.

Collin Clark Thu, 04/23/2009 - 10:30
User Badges:
  • Purple, 4500 points or more

That's from an 871. Here's one from an 877.


interface ATM0

no ip address

no atm ilmi-keepalive

pvc 0/35

pppoe-client dial-pool-number 1

!

dsl operating-mode auto

!


interface Dialer0

description Virtual Public Interface

ip address 75.50.95.73 255.255.255.248

ip access-group outside_in in

ip mtu 1452

ip flow ingress

ip inspect STATEFUL_FW out

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication pap callin

ppp chap hostname [email protected]

ppp chap password 0 SeCrEtPaSsWd

ppp pap sent-username [email protected] password 0 SeCrEtPaSsWd

!


ip route 0.0.0.0 0.0.0.0 Dialer0 permanent


As you stated before, you'll have to change the ATM pvc.

whiteford Thu, 04/23/2009 - 13:09
User Badges:

Great, apart from changing the PVC I notice the only other part I have to add is the ppoe setting under the ATM?


What are the differences between the ppoe and ppoa as thought it was just the port on the back, I immediately assumed as it was ethernet I would need an 871!

jamesgonzo Fri, 05/01/2009 - 01:39
User Badges:

Hi Collin,


Just one last thing, does this look ok on my 877 before I ship it off:

interface ATM0

no ip address

no ip mroute-cache

atm vc-per-vp 64

no atm ilmi-keepalive

pvc 8/35

pppoe-client dial-pool-number 1

!

dsl operating-mode auto



It was originally a PPOA router, so should I remove "atm vc-per-vp 64"?


interface Dialer1

ip address negotiated

ip access-group inbound in

encapsulation ppp

ip route-cache flow

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication chap pap callin

ppp chap hostname eircom

ppp chap password 0 broadband

ppp pap sent-username broadband password 0 broadband

crypto map Crypto_Map



Thanks


Collin Clark Fri, 05/01/2009 - 05:26
User Badges:
  • Purple, 4500 points or more

It won't hurt anything being in there. Make sure you create the dialer pool as well (it's not posted). Is the connection really ppp?

jamesgonzo Fri, 05/01/2009 - 05:31
User Badges:

I can see the dialer pool under my dialer 1 interface, or should this be somewhere else?


Are the DSL lines normally CHAP, is my config just using either PPP or CHAP?

Actions

This Discussion