Having IPX routing issues on my HQ core L3 switch

Unanswered Question
Apr 22nd, 2009

I have six remote sites that still use netware. With recent changes to my internal network, I have had to use GRE tunnels to route IPX traffic from my remote sites to my HQ Core L3 switch. I am able to IPX ping from remote site to remote site via the HQ core switch, but I can NOT ping from a remote site to my netware device at HQ, whcih all reside on internal VLANs.

All network nodes are being routed correctly and they can all see all of the netware nodes at each site.

I am hoping there are still some IPX experts here that can point me in the right direction so that I can get my remote sites to see my netware devices within my internal VLANs. Here are some sample configs. Please let me know what I need to do to get this to work. Thanks!

Remote site router config:

GRE tunnel going to HQ core switch -

interface Tunnel0

no ip address

ipx network 80481802

tunnel source FastEthernet0/0

tunnel destination 198.246.*.*

interface FastEthernet0/0 <<-- Internal network

ip address 10.18.*.* 255.255.255.0

ip route-cache flow

speed 100

full-duplex

ipx encapsulation SAP

ipx network 81880221

no keepalive

ipx routing 001e.f70d.50e2

HQ Core L3 4506R Switch:

ipx routing 0015.fa52.c540

interface Tunnel4

description IDCANY IPX

no ip address

ipx network 80481802

tunnel source Vlan2

tunnel destination 10.18.*.*

interface Vlan2

description CorpStatics

ip address 198.246.*.* 255.255.255.0

ipx encapsulation SAP

ipx network C2E1A69F

standby 1 ip 198.246.*.*

standby 1 preempt

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
mlund Thu, 04/23/2009 - 03:07

Hi Erik

It's a long way since I was working with ipx.

I remember however that you can use

ipx helper-address .ffff.ffff.ffff

to forward ipx broadcasts, also

ipx type-20-propagation

to forward netbios over ipx.

It also come into my mind that ipx ping is not always working, so if you got a ipx-ping response, that's good. But if you don't get a response you can't be sure. Can't remember the reason for that.

This maybe wasn't so helpful, we can only hope there still are any experts out there that can jump in and point out the exact way to move forward ;-)

Regards

Mikael

Actions

This Discussion