Troubleshooting XCODER CUCM6.1

Unanswered Question
Apr 23rd, 2009
User Badges:

Hi NetPro,


My 2811 IOS XCODER has been working for months. Recently it stops working after I added a new PVDM2-64 into the 2811 board. Calls between g729 and g711 are ring but cannot get established. In CUCM the XCODER still shows registered. The same router is also providing CFB, which is still working.

-------------

sh dspf ds al

SLOT DSP VERSION STATUS CHNL USE TYPE RSC_ID BRIDGE_ID PKTS_TXED PKTS_RXED


0 3 4.4.24 UP N/A FREE xcode 1 - - -

0 3 4.4.24 UP N/A FREE xcode 1 - - -

0 3 4.4.24 UP N/A FREE xcode 1 - - -

0 3 4.4.24 UP N/A FREE xcode 1 - - -

0 3 4.4.24 UP N/A FREE xcode 1 - - -

0 3 4.4.24 UP N/A FREE xcode 1 - - -

0 4 4.4.24 UP N/A FREE xcode 1 - - -

0 4 4.4.24 UP N/A FREE xcode 1 - - -

0 4 4.4.24 UP N/A FREE xcode 1 - - -

0 4 4.4.24 UP N/A FREE xcode 1 - - -

0 4 4.4.24 UP N/A FREE xcode 1 - - -

0 4 4.4.24 UP N/A FREE xcode 1 - - -

0 5 4.4.24 UP N/A FREE xcode 1 - - -

0 5 4.4.24 UP N/A FREE xcode 1 - - -

0 5 4.4.24 UP N/A FREE xcode 1 - - -

0 5 4.4.24 UP N/A FREE xcode 1 - - -

0 8 1.1.1 UP N/A FREE conf 2 - - -

0 8 1.1.1 UP N/A FREE conf 2 - - -


Total number of DSPFARM DSP channel(s) 18

-------------------


Everytime I disable/enable the xcode profile in the router, I can see critical messages come up in RTMT log.


I have tried taking out the new PVDM. No luck.


What can I do next?


Any advice is appreciated.


Larry


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.5 (2 ratings)
Loading.
david-lima Thu, 04/23/2009 - 13:10
User Badges:
  • Bronze, 100 points or more

Hi Larry, did you try to shut/no shut the xcodec profile, if it not works, try to re-configure and register a new xcodec profile in your router and CCM.

Hope this little comment help you,

All the best

David.

Chuan Liu Thu, 04/23/2009 - 14:13
User Badges:

Hi David,


Thanks for your reponse.

I have done that a few times with different new profiles and new register names. I even took out the new PVDM and use the previously working configuration. Every time XCODER was shown registered in CUCM. No luck.



Jaime Valencia Thu, 04/23/2009 - 14:36
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    2011

so if you issue a sh dspfarm all, the Xcode shows registered and ready to work?

MRG and MRGLs correct? device pool MRGL?


next step might be a cucm trace to find exactly what's going on there


HTH


java


if this helps, please rate

Chuan Liu Thu, 04/23/2009 - 14:42
User Badges:

Hi Java,


How can do I a cucm trace? Can you refer me to a doc?


Thanks.

Chuan Liu Thu, 04/23/2009 - 14:53
User Badges:

Hi Java,


What services are for DSP traces?


Thanks.

Jaime Valencia Thu, 04/23/2009 - 14:58
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    2011

CCM, just enable default fields and follow the doc


HTH


java


if this helps, please rate

Chuan Liu Thu, 04/23/2009 - 15:03
User Badges:

Hi Java,


With default setting, I can see the Critical message saying the number of media resources increased or decreased every time I 'shut/unshut' the profile on the router. No more detailed information is given.


Thanks.

Larry

Jaime Valencia Thu, 04/23/2009 - 20:50
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    2011

with the default settings following step by step the doc you will get all the info, make sure you did as instructed in the doc.


HTH


java


if this helps, please rate

khyber117 Sun, 05/10/2009 - 17:30
User Badges:

Hi Java,


With the help of the log files, we nailed the problem down to phone firmware. All working fine after a fireware upgrade.


Thanks.

Actions

This Discussion