SRST MOH From FLASH..Done Evrything I know..Yet....

Unanswered Question
Apr 24th, 2009

Hi,

I am trying to implement srst MOH from flash for my customer. I have configured evrything as I have done in the past but this time no joy.

I have done the ff:

1. configured loopback interface

2. enable ip pim sparse-dense mode on loopback interface, gig0/0 and gig 0/1 interface

3. enable Multicast MOH on audio source and MRGL

4. Configured G711 for multicast MOH

5. configured Multicast MOH on srst router and loaded MOH to flash

attached is the relevant config

2. When I do a show ccm-manager music-on-hold

I get this

SWIPCR01#show ccm

SWIPCR01#show ccm-manager mus

SWIPCR01#show ccm-manager music-on-hold

Current active multicast sessions : 0

SWIPCR01#

show call active voice | include RemoteMedia

I get this...

SWIPCR01#

SWIPCR01#show call active voice | include RemoteMedia

RemoteMediaIPAddress=0.0.0.0

RemoteMediaPort=0

SWIPCR01#

SWIPCR01#

A show ephone summary displays

SWIPCR01#show ephone summa

SWIPCR01#show ephone summary

hairpin_block:

Max 0, Registered 0, Unregistered 0, Deceased 0 High Water Mark 0, Sockets 0

ephone_send_packet process switched 0

Max Conferences 8 with 0 active (8 allowed)

Skinny Music On Hold Status

Active MOH clients 0 (max 320), Media Clients 0, B-ACD Clients 0

File beautifultango.ulaw.wav type WAVE Media_Payload_G711Ulaw64k 160 bytes

Moh multicast on 239.1.1.1 port 16384 via 172.26.208.1

via 172.26.216.254

via 172.26.208.121

via 172.26.208.117

A debug ephone moh shows this

Apr 24 10:33:09.641: MoH route If Loopback1 46 172.26.208.1 via 172.26.208.1

Apr 24 10:33:09.641: MoH route If GigabitEthernet0/0 ETHERNET 172.26.216.254 via 172.26.208.118

Apr 24 10:33:09.641: MoH route If GigabitEthernet0/1 ETHERNET 172.26.208.121 via ARP

Apr 24 10:33:09.641: MoH route If GigabitEthernet0/0 ETHERNET 172.26.208.117 via ARP

SWIPCR01#

Apr 24 10:33:14.757: MoH route If Loopback1 46 172.26.208.1 via 172.26.208.1

Apr 24 10:33:14.757: MoH route If GigabitEthernet0/0 ETHERNET 172.26.216.254 via 172.26.208.118

Apr 24 10:33:14.757: MoH route If GigabitEthernet0/1 ETHERNET 172.26.208.121 via ARP

Apr 24 10:33:14.757: MoH route If GigabitEthernet0/0 ETHERNET 172.26.208.117 via ARP

SWIPCR01#

from the above, it is obvious that Multicast is not working. Why I do not know...

I looked at CCM trace and I can see the follwoing: n(CCM trace attached)

From the trace , I can see audio source id of 1 been selected which is correct...

04/24/2009 10:28:17.246 CCM|MohDControl - handleMohSuccess - Call Id = 43114191 AudioSourceID = 1 MuticastFlag =

However, I can see CCM telling IP phones to listen to multicast on Ip=16843247, port 16384.

The port is correct, but im not sure of the IP..it should be 239.1.1.1

04/24/2009 10:28:17.246 CCM|MohDControl - handleMohSuccess - Sent out Allocate MOH Response CallId=43114191, TransferMode=9, Ip=16843247, Port=16384, CapCount=1, AudioSourceID = 1 MuticastFlag =

Please guys what do you think.

In this setup, my router does not have an interface in the phone subnet. I have enabled ip igmp snooping on the switches with no luck. I even enabled ip multicast routing on the router with no luck.

CCM is located across the WAN over an MPLS circuit hence, we cant configure multicast routing.

What can I do..

I have this problem too.
1 vote
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Ayodeji oladipo... Fri, 04/24/2009 - 05:59

Guys, any ideas?

When I did a show ip mroute count, this is what I get

SWIPCR01#

SWIPCR01#sh ip mroute count

IP Multicast Statistics

2 routes using 760 bytes of memory

1 groups, 1.00 average sources per group

Forwarding Counts: Pkt Count/Pkts(neg(-) = Drops) per second/Avg Pkt Size/Kilobits per second

Other counts: Total/RPF failed/Other drops(OIF-null, rate-limit etc)

Group: 224.0.1.41, Source count: 1, Packets forwarded: 0, Packets received: 972

Source: 172.26.208.1/32, Forwarding: 0/0/0/0, Other: 972/0/972

Should the group not be displaying 239.1.1.1 ?

olamothe Fri, 04/24/2009 - 06:58

Hi.

what happen if you try to force the IP multicast traffic with the

"ip igmp static-group 239.1.1.1" command under both g0/0 and g0/1 interfaces ?

Are the data multicasted (sh ip mroute command) ?

Hope this help...

iptuser55 Fri, 04/24/2009 - 09:06

Do you not need to create the MOH in the CCM as the same as the local SRST source The phones know about the MOH address from their TFTP download only?

Ayodeji oladipo... Fri, 04/24/2009 - 21:22

Multicast MOH has been configured on CCM with the multicast IP address and increment by IP...I am not sure I understand waht you are asking

vpreenja Sun, 04/26/2009 - 01:59

Enable multicast in audio source, server, MRG. Set hop count to 1...

Pls check the configuration for your scenerio from the following checklists:

A. Unicast G711 everywhere

1. Create region for MoH. G711 with all other regions.

2. Do not enable multicast in audio source, server, MRG

3. Enable only G711 in service parameter (Default)

B. G711 multicast everywhere

1. Create region for MoH. G711 with all other regions.

2. Enable multicast in audio source, server, MRG. Set hop count to 5.

3. Enable only G711 in service parameter (Default)

4. Enable multicast in infrastructure (igmp snooping in switches, pim sparse-dense in routers)

C. G711 multicast everywhere, remote site uses MoH from local SRST flash

1. Create region for MoH. G711 with all other regions.

2. Enable multicast in audio source, server, MRG. Set hop count to 1.

3. Enable only G711 in service parameter (Default)

4. Enable multicast in HQ and Remote LAN infrastructure (igmp snooping in switches, pim sparse-dense in routers), Disable multicast in WAN infrastructure.

5. Enable SRST MOH feature from flash.

6. Enable loopback interface in SRST router for PSTN users to hear MoH.

D. G711 multicast at HQ, G711 unicast at Remote

1. Create region for MoH. G711 with all other regions.

2. Enable multicast in audio source, server, MRG. Set hop count to 1.

3. Enable only G711 in service parameter (Default)

4. Enable multicast in HQ and Remote LAN infrastructure (igmp snooping in switches, pim sparse-dense in routers), Disable multicast in WAN infrastructure.

5. Create two MRG, one with multicast enabled for HQ and one with no mulitcast for BR1.

E. G711 unicast at HQ site, G729 unicast at remote

1. Enable Service parameter for G711 and G729

2. Use the HQ device pool for MOH server (assuming HQ device pool uses g729 for remote)

3. Do not enable multicast

F. G711 multicast at HQ, g729 multicast at remote

1. Enable Service parameter for G711 and G729

2. Use the HQ device pool for MOH server (assuming HQ device pool uses g729 for remote)

3. Enable multicast in audio source, server, MRG

4. Enable multicast in infrastructure

G. g729 unicast at remote using transcode

1. Enable only G711 in service parameter

2. Put MoH server in HQ device pool (assuming HQ uses G729 for remote)

3. Add a transcoder to MRGL of MoH server

I. HQ uses G711 multicast, remote uses G729 unicast, all PSTN uses hear tone on hold

1. Use HQ device pool for MoH server

2. Enable multicast on Audio source and server.

3. Create 2 MRG, one with multicast, one without multicast

4. Enable g711 and g729 in the service parameter

5. Create a third MRG and MRGL with no MOH and apply that directly to gateways

Ayodeji oladipo... Sun, 04/26/2009 - 07:57

Hi,

Thanks for this. I have done everything here. My case is SRTS Multicast MOH from flash. I enabled ip igmp snoopin on the switches that the Phones are connected to.

CCM is placed in a remote location across an MPLS network (clustering over WAN setup)

Do I need to enable ip igmp snooping on the switches that CCM is connected to also?

Because I have enabled igmp snooping on switches where IP phones are connected to and pim sparse dense mode on routers, yet It has not worked.

vpreenja Sun, 04/26/2009 - 08:59

No I think u only need to enable igmp snooping on the switch where phones are connected as call manager is not reveiving that multicast traffic anyways since you have not enabled multicasting on the rouyer connecting Call manager and the SRST site ( since its not required as u only need to play MOH from the router flash for remote side phones only).

Moreover dead air seems like these is some issue with the file taht u are trying to play from the flash. pls check that file or try using some other file..

Moreover also make sure that multicast stream is successfully reaching from the router to the phones.

Make sure that multicasting is enabled on all the L3 devices between the router and phones.

Futher try taking the help from some switching Engineer to get your multicasting checked.

olamothe Sun, 04/26/2009 - 22:25

I agree with you. It may be a problem with the audio file. Did you try with another one ?

With that file, did you try the static-group command under the gigabit interfaces ? Even if there are some issues with multicast routing, with this command, you should see the entry within the mroute table... If you don't see, I would think of internal problem with the multicast source, and in your case, have you ever try with a default file (provided by Cisco) ?

Ayodeji oladipo... Sun, 04/26/2009 - 08:39

Hi,

My problem is that I hear "dead air" I am sure this is a multicast routing issue..How do I troubleshoot multicast routing issues.

In a scenario like mine where I have SRST catalyst 3750 switches (With IP phones connecting to them)>gateway>MPLS WAN>WAN Router>CORE SW>CCM

Do I need to enable igmp snooping on all the switches including the switch CCM is connected to?

chadlincoln Sun, 04/26/2009 - 17:46

Do you see the PIM neighbors when you put in this command?

sh ip pim neighbor

Ayodeji oladipo... Tue, 04/28/2009 - 04:24

ALL,

I thought I should give a feedback on the resolution to this problem.

Here are the things which I did to resolve the issues

1. ADD a MRGL with a multicast MOH resource to the SRST gateway. I had this configured on the phones but not on the gateway

2. Configured ip pim sparse-dense mode on the switch ports that connect to the router

3. Configure "ip multicast-routing distributed" on the switches

Thanks for all your help.

Actions

This Discussion