Alert Messages Related to Vlan

Unanswered Question
Apr 24th, 2009

Hello Freinds,

We have two parallel link with same Vlan allowed between Cisco 4507 L3 Switches. and recently we have configured Vlan Priority based load balancing on both the links. i.e some Vlan are using first link as primary path and rest on Vlans using second link as primary path.

After that we are getting some messages on our syslog server. Please find the same.

%C4K_EBM-3-CANTALLOCATEVLANHOSTENTRY: (Suppressed 2294 times)No vlan host table memory to add entry for addrFE:00:41:48:00:50

%C4K_EBM-3-CANTALLOCATEVLANHOSTENTRY: (Suppressed 2426 times)No vlan host table memory to add entry for addrFE:04:29:1C:00:94

%C4K_EBM-3-CANTALLOCATEVLANHOSTENTRY: (Suppressed 2416 times)No vlan host table memory to add entry for addr00:1E:DF:13:1B:29

%C4K_EBM-3-CANTALLOCATEVLANHOSTENTRY: (Suppressed 2375 times)No vlan host table memory to add entry for addr00:0C:76:5E:C7:95

%C4K_EBM-3-CANTALLOCATEVLANHOSTENTRY: (Suppressed 1838 times)No vlan host table memory to add entry for addr00:13:49:1E:A8:DE

%C4K_EBM-3-CANTALLOCATEVLANHOSTENTRY: (Suppressed 2228 times)No vlan host table memory to add entry for addrFE:00:31:30:00:91

%C4K_EBM-3-CANTALLOCATEVLANHOSTENTRY: (Suppressed 2184 times)No vlan host table memory to add entry for addrFE:00:59:04:01:1D

%C4K_EBM-3-CANTALLOCATEVLANHOSTENTRY: (Suppressed 1910 times)No vlan host table memory to add entry for addr00:1E:40:50:B9:C8

While we trying to find out or trace the MAC addaress on switch which are reflecting in alert messages ..we are not getting any clue.

Cisco_Sw1#sh ip arp FE:00:41:48:00:50

Cisco_Sw1#sh ip arp 00:1E:40:50:B9:C8

Cisco_Sw1#

Can anyone please help me to conclude what this alert messages stands for and what need to done to stop this messages .

Regards

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
lamav Fri, 04/24/2009 - 08:07

Hi:

This indicates that the switch is having a memory allocation issue. There just isnt enough memory to support additional host addresses.

Is the configuration of this switch huge? Or have you created a layer 2 loop by allowing the same vlan across parallel layer 2 trunks?

HTH

Victor

cisco.net Fri, 04/24/2009 - 08:16

Thanks Victor for prompt reply.

Please see the configs of End "1" Switch.

interface GigabitEthernet1/2

description **1st Giga Link to Switch_2 Corresponding port Gigi1/2**

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 2,3,4,5,6,7,8,9

switchport mode trunk

switchport nonegotiate

speed nonegotiate

spanning-tree vlan 2,3,4,5 port-priority 64

end

interface GigabitEthernet1/4

description ** 2nd Giga Link to Switch_2 Corresponding port Gigi1/4**

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 2,3,4,5,6,7,8,9

switchport mode trunk

switchport nonegotiate

speed nonegotiate

spanning-tree vlan 6,7,8,9 port-priority 64

end

Same configs are at another end I & II links accourdingly.

Please suggest what need to done to control the alerts.

Regards

lamav Fri, 04/24/2009 - 09:14

Hi:

Im not sure I know what you're trying to achieve by manipulating the port priority. Can you explain? Did you mean to manipulate the bridge priority for each vlan so as to rig the root bridge election per vlan?

It really doesn't matter anyway, because your redundant link is being blocked by STP, as it should be.

If you want to use both trunks to pass traffic, you would have to create a port channel. This is a logical binding of both physical links to create one logical link that the switch will see. Only one link, therefore, STP will not block any ports and you can use the bandwidth of both links.

Switch_1#sh spanning-tree vlan 2

VLAN0002

Spanning tree enabled protocol ieee

Root ID Priority 32770

Address 000d.bc6e.9300

Cost 12

Port 65 (Port-channel1)

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32770 (priority 32768 sys-id-ext 2)

Address 000e.8364.6d80

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Aging Time 15

Interface Role Sts Cost Prio.Nbr Type

---------------- ---- --- --------- -------- --------------------------------

Po1 Root FWD 12 128.65 P2p

Switch_1#

Switch_1#

Switch_1#

Switch_1#

Switch_1#sh spanning-tree vlan 3

VLAN0003

Spanning tree enabled protocol ieee

Root ID Priority 32771

Address 000d.bc6e.9300

Cost 12

Port 65 (Port-channel1)

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32771 (priority 32768 sys-id-ext 3)

Address 000e.8364.6d80

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Aging Time 300

Interface Role Sts Cost Prio.Nbr Type

---------------- ---- --- --------- -------- --------------------------------

Po1 Root FWD 12 128.65 P2p

Switch_1#

Switch_1#

Switch_1#

Switch_1#

Switch_1#sh spanning-tree vlan 4

VLAN0004

Spanning tree enabled protocol ieee

Root ID Priority 32772

Address 000d.bc6e.9300

Cost 12

Port 65 (Port-channel1)

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32772 (priority 32768 sys-id-ext 4)

Address 000e.8364.6d80

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Aging Time 300

Interface Role Sts Cost Prio.Nbr Type

---------------- ---- --- --------- -------- --------------------------------

Po1 Root FWD 12 128.65 P2p

Notice how spanning tree sees one interface and it is a logical one - Po1 (port channel 1). Now the port channel interface will be in the forwarding state and no physical ports will be blocked.

I cannot seem to replicate the problem on your switches. Can you post the output of the device log?

Victor

cisco.net Fri, 04/24/2009 - 21:26

Hii Victor,

Agreed, But before using this Vlan priority based feature, before 6-7 days We were only using port channel on these links ..but due to some limitations from transmission/transport end , traffic on first link was not getting shifted automatically on second bundled link.

To overcome this problem we have shifted the port channel on Vlan based priority.

Can you please suggest me what changes should i do on the existing vlan based load balancing configs to stop the error messages.

Regards

cisco.net Wed, 04/29/2009 - 22:55

Dear Team,

One more observation noted, Above message/alerts are only coming when Unicast MAC address limit is full i.e like this.

Cisco_SW1#sh mac-address-table count

MAC Entries for all vlans:

Dynamic Unicast Address Count: 32740

Static Unicast Address (User-defined) Count: 0

Static Unicast Address (System-defined) Count: 28

Total Unicast MAC Addresses In Use: 32768

Total Unicast MAC Addresses Available: 32768

Multicast MAC Address Count: 113

Total Multicast MAC Addresses Available: 16384

Cisco_SW1#

please suggest...

regards

cisco.net Sat, 05/02/2009 - 22:39

hello freinds.

Requesting all to pls share your views as per given logs for MAC address table.

regards

johnlloyd_13 Sun, 05/03/2009 - 06:36

kindly post your show version command and see if there's sufficient memory.

according to Cisco.com's handy error message decoder(http://www.cisco.com/pcgi-bin/Support/Errordecoder/index.cgi):

1. %C4K_EBM-3-CANTALLOCATEVLANHOSTENTRY: No vlan host table memory to add entry for addr %ea

There is insufficient memory to support additional host addresses.

Recommended Action: Install additional memory.

Related documents- No specific documents apply to this error message.

cisco.net Sun, 05/03/2009 - 23:59

Hello,

please fine "show ver" output (for memory)

cisco WS-C4507R (MPC8245) processor (revision 8) with 524288K bytes of memory.

Processor board ID FOX094002UF

MPC8245 CPU at 400Mhz, Supervisor V

Last reset from Redundancy Reset

31 Virtual Ethernet interfaces

148 Gigabit Ethernet interfaces

511K bytes of non-volatile configuration memory.

Configuration register is 0x2101

Regards

Actions

This Discussion