router connection problem

Unanswered Question
Apr 24th, 2009

Hi, all,

I have a small experimental network, using one Cisco7204VXR(NPE400) router and one Cisco2950switch. The router has one FE port, so I created several virtual FE on it and connected to the switch.. The network is isolated from any other LAN/WAN.

interface FastEthernet1/0


no ip address

no ip proxy-arp

duplex full

no cdp enable


interface FastEthernet1/0.2

description VLAN2_141.142.1.0_outside_net

encapsulation dot1Q 2

ip address


interface FastEthernet1/0.3

description VLAN3_192.168.0.0_inside_net

encapsulation dot1Q 3

ip address

As described in the config, subnet is mimicking outside server-two server machines are sitting there with IP and; and is mimicking inside client and several client machines are connected through switch.

When I test the connection performance by using apache benchmark from client to server, e.g., from client I send “ab -c 100 -n 1000”, the result is very bad:


Percentage of the requests served within a certain time (ms)

50% 4

66% 218

75% 411

80% 452

90% 873

95% 1492

98% 7356

99% 20230

100% 21835 (longest request) (<== sometimes, this can be several minutes)


and sometimes, the test even failed:

Benchmarking (be patient)

Completed 100 requests

Completed 200 requests

Completed 300 requests

Completed 400 requests

Completed 500 requests

Completed 600 requests

Completed 700 requests

Completed 800 requests

Completed 900 requests

apr_poll: The timeout specified has expired (70007) <=== failed to be finished

Total of 950 requests completed


I'm assuming the problem doesn't come from the apache server, because if I tried the same test from (in this case, the connection doesn't go through the router, instead, it only go through the switch), the result is reasonable (served http requests >1.5K/second)

A detailed configuration of router is attached to this post.

Can anyone through some lights on debugging the problem?



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (3 ratings)
mlund Sun, 04/26/2009 - 23:46


I can't see any problem with config, except maybe for the "full duplex".

You have to verify that also the switchport is in full duplex mode.

Otherwise it will generate a lot of errors, and a bad throughput.

Beside of that I would recomend You to change the subnetmask of net to instead, too see if that is the problem.

I have seen ip-stacks having problem with supernetts.


insert7992 Tue, 04/28/2009 - 19:11

Thanks a lot for your reply, Mikael.

I checked the switch config, every port is running on "full duplex" mode; and I also checked NIC of each involved computer, all of them are running on "full duplex" mode.

You are right, I read from some doc said "bigger" subnet may sometimes cause trouble. I tried to revise FA1/0.3 to "", but the problem remains the same.

Any other thoughts? I've been working on this problem for several weeks, it really cause serious headache. I would appreciate any help.

Thanks in advance.


Richard Burts Wed, 04/29/2009 - 03:29


Perhaps it would be helpful if you would post the output of show interface from the router. It might also be helpful if you would post the config of the switch.



insert7992 Wed, 04/29/2009 - 18:06

Thanks for your help, Rick.

I attached my switch configuration and "show int" result for both router and switch to this post.

The input/output rate is unreasonably low--I'm really running out of idea what's going on.

Thanks again.


Richard Burts Thu, 04/30/2009 - 09:52


I have looked at the additional information that you posted. I do not see any issue in it that would explain the performance issue.

I am wondering since it is a 7204 router running some version of 12.2 code if there could be some issue or some inefficiency in its implementation of the router on a stick which receives input and sends the output on VLANs of the same interface.



insert7992 Thu, 04/30/2009 - 14:15

Hi Rick,

Thanks for your help.

Would you please tell me a little bit more about your suspicion? How can I detect that the problem does come from router hardware/software? Is there a command set I can use to verify your guess?

And by the way, I kept tracing the Router cpu usage by using "show processes cpu history", the result show that usage were always very low (1%~3%) for all the time.

Thanks again.


Richard Burts Fri, 05/01/2009 - 17:46


Unfortunately I do not know a command or any good way to reliably examine the router and tell whether there is some inefficiency in the software. I can only say that for 7204 that 12.2 is pretty old code and that typically performance enhancements are one of the things put into newer code.




This Discussion