Routing Problem

Unanswered Question
Apr 26th, 2009
User Badges:

there is intervlan routing through OSPF and all the vlans are able to communicate. but I am not able to ping one IP from my PC where as i am able to ping the same IP from MSFC. I am able to ping the VLAN IP and Standby IP of that VLAN from my PC. Please help me to resolve this issue.



interface Vlan114

ip address 172.20.19.74 255.255.255.248

no ip redirects

standby ip 172.20.19.73

standby priority 150

standby preempt

end



OSPF Config:


router ospf 1

router-id 172.21.1.10

log-adjacency-changes

area 10 filter-list prefix hicap in

redistribute connected subnets

redistribute static subnets route-map OSPF-ROUTE

passive-interface default

no passive-interface Vlan1

no passive-interface Vlan2

no passive-interface Vlan17

no passive-interface Vlan112

no passive-interface Vlan113

no passive-interface Vlan114

network 10.0.0.0 0.0.0.255 area 0

network 99.0.0.0 0.0.0.255 area 0

network 100.0.0.0 0.0.0.255 area 0

network 110.0.0.0 0.0.0.255 area 0

network 172.16.0.0 0.0.255.255 area 0

network 172.17.0.0 0.0.7.255 area 0

network 172.20.1.0 0.0.0.255 area 0

network 172.20.2.0 0.0.0.255 area 0

network 172.20.11.0 0.0.0.255 area 0

network 172.20.19.32 0.0.0.31 area 0

network 172.20.19.64 0.0.0.7 area 0

network 172.20.19.72 0.0.0.7 area 0

network 172.20.20.0 0.0.0.255 area 0

network 172.20.25.0 0.0.0.255 area 0

network 172.20.60.0 0.0.0.255 area 0

network 172.20.65.0 0.0.0.255 area 0

network 172.20.115.0 0.0.0.255 area 0

network 172.30.1.0 0.0.0.255 area 0

network 172.100.100.0 0.0.0.255 area 10

network 192.151.106.0 0.0.0.255 area 0

network 192.168.12.0 0.0.0.255 area 10




Ip Which i am not able to ping from other VLANs


172.20.19.76



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Giuseppe Larosa Sun, 04/26/2009 - 03:32
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Mohammed,

I would verify the default gateway settings of host 172.20.19.76.


what if from switch/MSFC you use an extended ping with source in the vlan where your PC is connected ?


there is no ACL applied to SVI vlan 114.


verify configuration of the SVI for your PC too.

The most likely cause is a missing/wrong default gateway on host 172.20.19.76.


Hope to help

Giuseppe


engineer_msu Sun, 04/26/2009 - 04:23
User Badges:

attached is the configuration of the Infinity Wireless AP.


The Subnet Mask is correct. its 255.255.255.248


There is no ACL


When i am giving extended ping with source VLAN as my PC VLAN, its not pinging.

Richard Burts Sun, 04/26/2009 - 11:36
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Saleemuddin


The information that you posted is helpful. Here is the default route from the config:

#Routing parameters

route add 0.0.0.0/0 192.168.1.1

how is it going to know how to get to 192.168.1.1?


I believe that this explains the issue: the device can not talk to any address that is not in the local subnet because its default route is incorrect.


HTH


Rick


Marwan ALshawi Sun, 04/26/2009 - 23:43
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Best Publication, December 2015

in your AP you need a route in addition to the default route

which should be for the vlan 20

now based on ur pattched AP config

you have 0.0.0.0 which mean all sent to 192 now the echo comes to the AP and it has no idea where to send the replay becuase sourced from vlan 20 then will send it to 192 link which will not work

u need in addition to the default route additional route for every subnet you have it internal in you switch


this is aproved also when you do extended ping


try to get somthing like this in ur AP


route 172.20.20.0 255.255.255.0 172.20.19.74

this will solve your issue


good luck


engineer_msu Mon, 04/27/2009 - 04:46
User Badges:

Dear,


I have connected a machine on LAN, assigned it IP 172.20.19.77. I am able to ping all the VLANS from this PC and again from other VLANS i am not able to ping this PC.



thotsaphon Mon, 04/27/2009 - 05:01
User Badges:
  • Gold, 750 points or more

Saleemuddin,

I want to know which gateway ip address you configured for PC-172.20.19.77.

It should be "172.20.19.73". Using HSRP Right?


Hopes this would not be a personal firewall problem. (grin)

Toshi

engineer_msu Wed, 04/29/2009 - 03:53
User Badges:

Dear,

Thanks a lot. The issue was personal firewall for PC and when i put the route in the AP it works. Atctually its a wireless router from Infinet, hence it required routing to configured.

Thanks for helping me to resolve the issue.

Marwan ALshawi Wed, 04/29/2009 - 14:50
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Best Publication, December 2015

thats sounds good


pls rate the helpful post

Actions

This Discussion