Vlan Communication

Unanswered Question
Apr 26th, 2009

We have two switches Switch "A" is cisco 4510 switch and Switch "B" is 3550 switch. We are trying to make communications between two different Vlans IPs.

for eg :- We have created Vlan 850 on Switch"A" configured with IP and at Other Switch (Switc"B") IP is configured on Vlan 1. We want that IP of both different Vlan will be reachable from both ends / switches. PLease suggest.


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
mahmoodmkl Sun, 04/26/2009 - 23:05


Y dnot u configure u r intervlan routing on 4510..?

Configure ur 3550 as a vtp client and 4510 as a vtp server.Have a trunk link between these switches.

And on 4510 create the vlan u require.

conf t

switch(config)vlan 10 name test

switch(config)vlan 850 name sales

switch(config)interface vlan 10

ip address

no shut


interface vlan 850

ip address

no shut



cisco.net Sun, 04/26/2009 - 23:34

Hii Mahmood thanks,

As you mentioning. We are not using Vlan 10. We only gave IP to default Vlan (Vlan1) on 3550 switch.

And actually Switch "B" is already using for our existing core network. So we can't do any major changes on the same.

4510 is new switch which we are now adding in existing network.

Giuseppe Larosa Mon, 04/27/2009 - 00:11

Hello Jimmy,

the two switches must have a common subnet.

you can build a "vlan converter" by using an additional link that you put in access mode


int g4/3


switchport mode access

switchport access vlan 850

no cdp enable

no shut

int vlan 850

ip address

SWB: already in production

int fx/y


switchport mode access

switchport access vlan 1

no cdp enable

no shut

Be aware that this joins two broadcast domains vlan1 and vlan850.

int vlan1

ip address x.x.x.y

ip address secondary

with the secondary option you can adapt to the ip subnet in vlan850 if different from production.

(this step may be needed or not depending on what ip address you have assigned to the new switch SWA if it is compatible with SWB management subnet you don't need this step)

However, the best solution is:

provision of an ip address in management vlan (1 is not recommended but I guess you are using it) for the new switch

creation of SVI vlan1 with that ip address

setup of a trunk link between SWA and SWB.

This is a clean solution, the one above is suggested only for short time or for attemtping to get access to a switch.

Hope to help


cisco.net Mon, 04/27/2009 - 07:38

Hello Giuseppe,

As of now i have created L3 port i.e no switchport on Switch A(with a IP address from pool configured on Vlan1 of Switch B) Gig port which is connected to Switch B.


Switch A(New Switch on New IP Pool) :--

Int Vlan 850

ip addrea


interface gi4/3

no switchport

ip address


On Switch B (in this only default Vlan i.e Vlan 1 is present)

int vlan1

ip address

interface fa0/2

switch mode access


After doing this our requirement fulfilled(reachablity to servers which are connected from Switch B on Old/existing IP pools is happening).

Please suggest if anything wrong or limitations in the scenrio..Hope for the best output....

Will back to you if any further assistance.



This Discussion