Config Archive failed

Unanswered Question
Apr 27th, 2009


From 1 of the switch Model 2960-24-TCL

i get a following error,

*** Device Details for ***

Protocol ==> TFTP

Selected Protocols with order ==> Telnet,TFTP,SSH,RCP,HTTPS

Execution Result:


TELNET: Failed to establish TELNET connection to - Cause: Authentication failed on device 3 times.

CM0060 PRIMARY RUNNING Config fetch SUCCESS for, version number 8 archived.


CM0151 VLAN RUNNING Config fetch failed for Cause: TELNET: Failed to establish TELNET connection to - Cause: Authentication failed on device 3 times.

VLAN Config fetch is not supported using TFTP.

Failed to detect SSH version running on the device.

VLAN Config fetch is not supported using RCP.

Action: Check if protocol is supported by device and required device package is installed. Check device credentials. Increase timeout value, if required.

I tried login through the user which is configured for LMS with priviledge 15 am able to login,amm able to archive startup and running config but not the vlan config fetch,

I tried using tftp server on my latop and i was able to download the vlan.dat file from switch to file but no succeeded in downloading from switch to LMS server it give me this error.

TFTP: error code 2 received - 16739

%Error opening tftp://X.X.10.1/vlan.dat (Permission denied)


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Joe Clarke Mon, 04/27/2009 - 09:23

You need to create an empty vlan.dat file in the tftpboot directory before you can copy it from the device. This kind of security is typical for TFTP.

However, your problem appears to be the credentials in DCR for this device. This error is typically never wrong. I recommend you start a sniffer trace filtering on telnet traffic to this device, then perform a new Sync Archive. When it fails, look at the sniffer trace to see the error RME encounters (and what credentials it is using to log in to the device).

lambay2000 Tue, 04/28/2009 - 11:21

Hi Clarke,

I downloaded wireshark

Attaching the two files:

1st file is which i started syn archive and wireshark was on,i dont see any telnet traffic,

2nd file is which i did the telnet from LMS server from start>run>telnet

My LMS server IP is AND

Switch IP is

I dont understand in the 1st file only the SNMP protocol is seen communicating between the switch and the LMS server,

2nd file shows me the telnet traffic when i triggered from windows command prompt.

I do did while creating empty vlan.dat file in tftpboot folder in CSCOPX,but no such output.

Joe pls review the files and let me know what u r understanding from these capture output.

Any other workaround or Am doing any mistake

Joe Clarke Tue, 04/28/2009 - 11:32

I see no evidence of a sync archive job in this packet capture. This looks to be DFM polling the device. How did you do the sync archive?

lambay2000 Tue, 04/28/2009 - 11:36

Hi Clarke ,

I just went to Device Center>>Syn Archive.

Thats it,

lambay2000 Wed, 04/29/2009 - 10:02

Hi Joe,

Awaiting for ur reply,I tried by RME also it is one and the same.


Joe Clarke Wed, 04/29/2009 - 10:12

This should work. You can also go to RME > Config Mgmt > Archive Mgmt > Sync Archive. If you are still not seeing any telnet traffic in the sniffer trace, then I suggest you open a TAC service request so live troubleshooting can be done.

lambay2000 Wed, 04/29/2009 - 11:24


But by telnet it pulling my running and startup config then why not vlan.dat,though i created a dummy vlan.dat in tftpboot folder in LMS but still the same error for tftp.

Joe Clarke Wed, 04/29/2009 - 17:01

If you're still seeing the permission denied error, you haven't granted full control to everyone for your empty vlan.dat file. But if that's the only problem, then LMS should be working. That is why the sniffer trace is important. But if you can't collect it, then contact TAC so they can do live troubleshooting.


This Discussion