presence the phone and mobile field entries not coming from LDAP

Answered Question
Apr 27th, 2009

I tested by changing name and all...working fine changes happening

But the phone field is not coming at all

ANY IDEA????

Attachment: 
I have this problem too.
0 votes
Correct Answer by htluo about 7 years 8 months ago

You forgot to check the option "recursive search". Check it, save it. exit/re-launch CUPC.

Michael

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (6 ratings)
Loading.
Tommer Catlin Mon, 04/27/2009 - 09:24

Did you try to make the connection using the 3268 LDAP port to the Global Catalog Server as well?

Sometimes 389 does not work

I just looked at your jpg, it will not show there, it will only show on the actual CUPC client when it does the call into LDAP. The presence viewer I think will not show all the information you are expecting it to.

Eldho E Kuriakose Mon, 05/04/2009 - 03:12

still I am not getting

The problem is

From ldap, the mobile no: is getting to callmanager but in presence, the mobile field is empty.So I cant make doubleclick and call from personal communicator

when anything I cahged in Ldap its get reflecting in presence datatbase also.But mobile no: is not coming

Please Help

htluo Mon, 05/04/2009 - 19:59

I'm sorry if I misunderstood you. But it looks like there's some confusion here.

Confusions and mistakes are usually caused by false assumptions.

CUPC gets LDAP attributes from LDAP directly. CUPC does not retrieve those attributes from CUPS.

If you're troubleshooting double-click on CUPC, the CUPS presence viewer doesn't help at all.

When you double-click a contact in CUPC, CUPC dials the number in "BusinessPhoneNumber". By default "BusinessPhoneNumber" is mapped to "telephoneNumber" in Active Directory.

If you cannot double-click a contact to dial, that's because "BusinessPhoneNumber" was blank.

Michael

http://htluo.blogspot.com

Eldho E Kuriakose Tue, 05/05/2009 - 02:21

the telephone no: is entered in ldap and it is coming to callmanager

In cupc the health status is also showing green with comm to ldap

If you cannot double-click a contact to dial, that's because "BusinessPhoneNumber" was blank.

ans: right the business ph no: is blank but telephone no: I already added in ldap(microsoft dc)

Is there any reason for the no: is not coming....

please help

Dennis Mink Tue, 05/05/2009 - 04:14

I have just checked the settings I use on our CUPS, where we do have mobile numbers dial-able from CUPC.

you could try to fill in the relevant LDAP attribute mappings on CUPS (application-->CUPC, this will allow you to fill in all attributes). press the help "about this page" to see what attributes you should fill in.

also, the AD server you are adding the mobile numbers, is this the same as you are pointing CUPS to? if you run multiple DC in a domain, it takes a bit of time to propagate

htluo Tue, 05/05/2009 - 07:21

If the telephone number populated in CUCM but not CUPS, restart the "Cisco UP SyncAgent" service on CUPS.

Michael

Eldho E Kuriakose Tue, 05/05/2009 - 11:01

I tried that one also ...still the place a call is not active...

My ldap helth status is attached herewith

If anyone interested i can give contol to presence through teamweaver...

Attachment: 
htluo Tue, 05/05/2009 - 11:38

I'd recommend you open a TAC case between 1pm and 4pm CDT (GMT-5) and ask for Michael Luo. :)

Eldho E Kuriakose Tue, 05/05/2009 - 11:40

i dont havw privileges....

now i am trying to upgrade cupc to ver 7

can u use teamweaver to help me

htluo Tue, 05/05/2009 - 13:44

Could you post some screenshots?

1) CUPS Admin > Application > Cisco Unified Personal Communicator > Settings.

2) ADUC (Active Directory Users and Computers) > The user you tried to call from CUPC > General tab.

3) CUPC > right-click on the contact you tried to call > Show contact details.

Michael

htluo Wed, 05/06/2009 - 05:53

Some quick questions:

1) How did you add 'eldho' to your CUPC contact list? Give me detail steps.

2) If you search 'eldho' at the CUPC search box (at the bottom of the CUPC), would you get any result?

3) Give me a screenshot of CUPS Admin > Application > Cisco Unified Personal Communicator > LDAP Profile > (click on the profile you're using). I'd like to see if "recursive search" or "Anonymous Bind" was checked or not.

Thanks!

Michael

Eldho E Kuriakose Wed, 05/06/2009 - 06:03

1, I added from user options webpage of presence

2, no nothing

3, first it was cheched...I removed it now and now also same result\

I can give you control on teamweaver

id: 226 027 396

pas: 1234

pls help

htluo Wed, 05/06/2009 - 06:29

1) If you add the contact via user option page, there won't be any phone number associated with that contact. This is by design.

2) If you cannot search the user from CUPC search box, that means the LDAP profile was not configured properly (even though it shows green).

3) The recommended way to add contact is to search the contact in CUPC search box. Then right-click on the search result and add it to contact list.

Michael

Eldho E Kuriakose Wed, 05/06/2009 - 06:36

this is the ldap profile page

the same user name is lab and pawword is correct which is same as in ccm

please correct if there anything wrong

I got ur point.So somehow i have to get the search option..rhen it will work fine right?

Attachment: 
Correct Answer
htluo Wed, 05/06/2009 - 07:14

You forgot to check the option "recursive search". Check it, save it. exit/re-launch CUPC.

Michael

abcronin Tue, 07/12/2011 - 16:06

Hi Michael

We are having the same issue with the latest version of CUPS and CUPC (8.5.2), are you aware of any caveats with this?

Issue=  no alternate numbers coming into the CUPC for added contacts from AD,  the users have Mobile, Home, Business 1 and Business 2 set, Pager etc  but nothing is shown on the users details.

You do have a drop down selection for other numbers but they are all have a suffix of '2'.

worth logging a TAC case you think?

Thanks

Andy

c.hennrich Wed, 11/30/2011 - 02:02

Hi,

did you fix that problem? I'm using global catalog in a multi domain setup.

I can see the business/telephone number but unfortunately not the mobile phone number. The mobile number is in the AD and also mapped in CUPS, but the CUPC is not getting it.

Any advise?

Thank you!

abcronin Thu, 12/01/2011 - 21:19

Not sure if the issue in question is resolved with that install but I have just done one with CUPS 8.5(4) and CUPC 8.5.4, it works fine and brings over the other numbers including Mobile.

Actions

This Discussion