Question about EIGRP summary-address advertisements

Unanswered Question
Apr 27th, 2009
User Badges:

I have a router running EIGRP, with a summary address configured on one interface, using the "ip summary-address eigrp" command. This creates a route to null0 in the local routing table, for that summary address, like this:


D 10.10.0.0/16 is a summary, 3d21h, Null0


The summary works the way I want it to, and all's good so far, but...


I'll be adding a new EIGRP neighbor for this router to peer with. My requirement is that the new neighbor receive the advertisements from this router for the *specific* routes in that summary network, but *cannot* receive the summary advertisement itself. The new neighbor will not be hanging off the interface with the summary address configured; it will be on a different interface.


My questions are these:


1) In a default configuration (with no special filtering set up), would the new neighbor receive an EIGRP advertisement for the summary route? I would guess that it would, since it appears in the table of the existing router as an EIGRP route.


2) If the answer to the first question is yes, how can I filter the summary route from the outbound advertisements, while still allowing all the smaller routes from that network through? A prefix-list would be ideal for this (and is how I handle the issue when redistributing between protocols)--but as far as I can tell, I can't apply a prefix-list to simple advertisements between routers speaking the same protocol. If I use a distribute-list with a regular ACL, I'm not sure how I can prevent the summary route, say 10.10.0.0/16, but still allow, for instance, the smaller network 10.10.0.0/24 to be advertised.


Any thoughts?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
rkartch Mon, 04/27/2009 - 08:22
User Badges:

Well, I may have just answered my own question... When I first asked the question, I was foolishly reading the documentation on options for filtering outbound advertisements, and the doc (configuration guide for 12.4T) only showed the option of using an ACL with the distribute-list. However, I just went into my router and did a "distribute-list ?" under EIGRP configuration just to see whether any additional options showed up, and it looks like I can use a prefix-list after all:


Router(config-router)#distribute-list ?

<1-199> IP access list number

<1300-2699> IP expanded access list number

WORD Access-list name

gateway Filtering incoming updates based on gateway

prefix Filter prefixes in routing updates

route-map Filter prefixes based on the route-map


So... never mind. Guess I'll stop reading the documentation from now on!


(I'm still curious about whether the router will try to advertise the summary to the new neighbor, but I guess as long as I can block it with a prefix-list it doesn't really matter.)

Giuseppe Larosa Mon, 04/27/2009 - 08:37
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Rachel,


>> The new neighbor will not be hanging off the interface with the summary address configured; it will be on a different interface.


and so the new EIGRP will not see the summary route that is only sent out the interface where it is configured


per interface control of summarization means so.


Hope to help

Giuseppe


lamav Mon, 04/27/2009 - 10:12
User Badges:
  • Blue, 1500 points or more

Hi:


The summary address will only be advertised to the router that receives it directly from the interface.


See below.


Switch 1 has eigrp neighbors to switch2 and a router. Switch 2 gets summary route. Router does not.


HTH


VICTOR



Switch_2#sh ip ro

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route


Gateway of last resort is not set


1.0.0.0/32 is subnetted, 2 subnets

R 1.1.1.1 [120/1] via 22.22.22.1, 00:00:14, FastEthernet0/20

C 1.1.1.2 is directly connected, Loopback0

50.0.0.0/30 is subnetted, 1 subnets

D 50.50.50.0 [90/30720] via 22.22.22.1, 00:00:06, FastEthernet0/20

5.0.0.0/32 is subnetted, 1 subnets

R 5.5.5.5 [120/10] via 22.22.22.1, 00:00:14, FastEthernet0/20

6.0.0.0/32 is subnetted, 1 subnets

R 6.6.6.6 [120/10] via 22.22.22.1, 00:00:14, FastEthernet0/20

22.0.0.0/30 is subnetted, 1 subnets

C 22.22.22.0 is directly connected, FastEthernet0/20

7.0.0.0/32 is subnetted, 1 subnets

R 7.7.7.7 [120/10] via 22.22.22.1, 00:00:15, FastEthernet0/20

8.0.0.0/32 is subnetted, 1 subnets

R 8.8.8.8 [120/10] via 22.22.22.1, 00:00:15, FastEthernet0/20

10.0.0.0/22 is subnetted, 1 subnets

D 10.80.0.0 [90/156160] via 22.22.22.1, 00:00:07, FastEthernet0/20

Switch_2#

Switch_2#

Switch_2#

Switch_2#sh ip ro 10.80.2.0

Routing entry for 10.80.0.0/22

Known via "eigrp 10", distance 90, metric 156160, type internal

Redistributing via eigrp 10

Last update from 22.22.22.1 on FastEthernet0/20, 00:00:19 ago

Routing Descriptor Blocks:

* 22.22.22.1, from 22.22.22.1, 00:00:19 ago, via FastEthernet0/20

Route metric is 156160, traffic share count is 1

Total delay is 5100 microseconds, minimum bandwidth is 100000 Kbit

Reliability 255/255, minimum MTU 1500 bytes

Loading 1/255, Hops 1


====================================================================================================================

SWITCH#1


!

interface Loopback10

ip address 10.80.1.1 255.255.255.0

!

interface Loopback11

ip address 10.80.2.1 255.255.255.0

!

interface Loopback12

ip address 10.80.3.1 255.255.255.0

!




Switch_1#sh run | be router eigr

router eigrp 10

network 10.80.1.1 0.0.0.0

network 10.80.2.1 0.0.0.0

network 10.80.3.1 0.0.0.0

network 22.22.22.1 0.0.0.0

network 50.50.50.1 0.0.0.0

no auto-summary



!

interface FastEthernet0/20 <-------------------FACES SWITCH#2. SENDING SUMMARY ROUTE TO SWITCH #2.

no switchport

ip address 22.22.22.1 255.255.255.252

ip summary-address eigrp 10 10.80.0.0 255.255.252.0 5

end



====================================================================================================================



lamav Mon, 04/27/2009 - 10:13
User Badges:
  • Blue, 1500 points or more

This is a first...ran out of characters.


See routers routing table.




Router#sh ip ro

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route


Gateway of last resort is not set


1.0.0.0/32 is subnetted, 2 subnets

O E1 1.1.1.1 [110/21] via 50.50.50.1, 00:20:44, FastEthernet0/0

O E1 1.1.1.2 [110/21] via 50.50.50.1, 00:03:03, FastEthernet0/0

50.0.0.0/30 is subnetted, 1 subnets

C 50.50.50.0 is directly connected, FastEthernet0/0

5.0.0.0/32 is subnetted, 1 subnets

C 5.5.5.5 is directly connected, Loopback1

6.0.0.0/32 is subnetted, 1 subnets

C 6.6.6.6 is directly connected, Loopback2

22.0.0.0/30 is subnetted, 1 subnets

D 22.22.22.0 [90/30720] via 50.50.50.1, 00:03:32, FastEthernet0/0

7.0.0.0/32 is subnetted, 1 subnets

C 7.7.7.7 is directly connected, Loopback3

8.0.0.0/32 is subnetted, 1 subnets

C 8.8.8.8 is directly connected, Loopback4

10.0.0.0/24 is subnetted, 3 subnets

D 10.80.2.0 [90/156160] via 50.50.50.1, 00:07:11, FastEthernet0/0

D 10.80.3.0 [90/156160] via 50.50.50.1, 00:07:11, FastEthernet0/0

D 10.80.1.0 [90/156160] via 50.50.50.1, 00:07:11, FastEthernet0/0

Router#

Router#

carl_townshend Tue, 04/28/2009 - 07:41
User Badges:

How come the router does not learn these summary addresses ?, it it because it is directly connected to the same switch but with no summary set on the interface ?

Actions

This Discussion