Phone stuck in Configuring IP

Unanswered Question
Apr 27th, 2009
User Badges:

Hello folks


I just reset a phone and is stuck in configuring ip, under enterprise parameters we have the ip address of the publisher to remove the DNS dependency, the phone is configured in ccm


what else should I check?

thanks

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
chadlincoln Mon, 04/27/2009 - 14:53
User Badges:
  • Bronze, 100 points or more

Sounds like it is a DHCP problem. What is your DHCP server? Is it configured properly? Is it in the right VLAN?


IOS dhcp:


ip dhcp excluded-address 192.168.1.1 192.168.1.10


ip dhcp pool VOICE

network 192.168.1.0 255.255.255.0

default-gateway 192.168.1.1

option 150 ip 192.168.1.5



This configuration will:

Not hand out IP's in the range of 192.168.1.1 - 192.168.1.10

The pool will hand out in the 192.168.1.0 255.255.255.0 network.

The option 150 ip "address of your call manager" is what the phone uses to get it's config file.


Make sure there is no typo on the address or mask.

Make sure the pool is in the same subnet that of the voice vlan assigned to the switch port the phone is plugged in to.

Check the vlan configuration on the switch.

cris_jimenez Mon, 04/27/2009 - 14:57
User Badges:

that's correct the publisher is leasing the ip addresses and we have the default router, option 150 and the network range from .30 to. 250 and we only have 40 phones



chadlincoln Mon, 04/27/2009 - 15:19
User Badges:
  • Bronze, 100 points or more

Can you plug the phone that doesn't get an IP into the cable of a phone that is working. That will narrow it down to either a phone issue or a network issue. Also, check the network settings and make sure the phone is set up to get an address via DHCP and that it doesn't have a static IP configured on it.

vmilanov Tue, 04/28/2009 - 13:27
User Badges:

Hi,


Check the presence of the voice vlan all along the way(in case of multiple switches) from the phone port on the access switch to the router(DHCP Server). If it is ok, either enable CDP and issue the 'switchport voice vlan [voice-vlan-id]' on that port (applicable to cisco switches only), or if it is not a cisco switch, or you don't wish to enable cdp, set the 'Admin VLAN' network setting on the phone to the voice vlan ID. To set it, first unlock the phone with '**#' while in network settings menu.



HTH.


Regards,

Vasil

cris_jimenez Tue, 04/28/2009 - 13:32
User Badges:

thank you very much it was a network issue

the problem has been resolved

alfredtalke Wed, 05/27/2009 - 00:51
User Badges:

Hello!


We have also the same problem.

It is a Polycon 7937G phone.

The phone did not identifie the configured Voice VLAN on our CISCO Sitch 2950. CDP is enabeld on the phone. If we connect a 7949 it is working.


Any ideas?


Dominik

Paolo Bevilacqua Wed, 05/27/2009 - 00:56
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Configure access vlan same as voice vlan. Check that it boots, upgrade firmware to latest.

After that, configure back voice vlan.


Actions

This Discussion