ssh on router

Answered Question
Apr 27th, 2009
User Badges:

Hi all,

We have configured ssh on router and its working but, as telnet was used earlier We need to disable Telnet now unable to find the right solution. Do we need to disable line vty or ???

Please assist,

RB

Correct Answer by thotsaphon about 8 years 3 days ago

Raj,

Sorry , I missed reading your question.


Router(config)# line vty 0 15

Router(config)# transport input ssh


This would be fine. Not sure which version of IOS you are using.


HTH,

Toshi

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
rkcontrol Mon, 04/27/2009 - 23:06
User Badges:

Hi,

This is my current config on line vty. still I can use both SSh and telnet.


line vty 0 4

exec-timeout 7 0

password 7 030752180500

transport preferred ssh

transport input none


Thanks for ur reply,

Rupesh Kashyap Mon, 04/27/2009 - 23:35
User Badges:

Do one thing, just add


Transport input ssh

Transport output ssh


I have tested, telnet is blocked.

rkcontrol Tue, 04/28/2009 - 21:33
User Badges:

Dear Rupesh,


I appreciate ur help on the subject, but unfortunately I am unable to get the solution as suggested, is there anything else beside line vty 0 4 config. I have tried both eg below. Still I can use both SSH and Telnet and are aunthenticated by ACS. Do suggest some other option.


line vty 0 4

exec-timeout 7 0

password 7 030752180500

transport preferred none

transport input ssh

transport output ssh


line vty 0 4

exec-timeout 7 0

password 7 030752180500

transport preferred ssh

transport input ssh

transport output ssh


Thanks,

rkcontrol Tue, 04/28/2009 - 22:06
User Badges:

Hi Toshi,

Infact I have referred the same doc from cisco.com and configured as mention. SSH is working fine but I need to disable telnet.


R01#sh ip ssh

SSH Enabled - version 1.99

Authentication timeout: 60 secs; Authentication retries: 3


Any other option,


Thanks,

Correct Answer
thotsaphon Tue, 04/28/2009 - 22:25
User Badges:
  • Gold, 750 points or more

Raj,

Sorry , I missed reading your question.


Router(config)# line vty 0 15

Router(config)# transport input ssh


This would be fine. Not sure which version of IOS you are using.


HTH,

Toshi

Actions

This Discussion