Attachment Stripping

Unanswered Question
Apr 28th, 2009
User Badges:

Hi

We strip attachments using the "Strip Attachment by File Info" filter and use the Replace message field to add in the details of the file using the $dropped_filename variable. The issue I have is that this doesnt insert this text into the body of the original email but adds a txt file with the Replacement Message in it.
In an ideal world I would like the message inserted into the email using the $dropped_filename variable and no txt attachment in the email.

I have tried using the "Strip Attachment by File Info" with no Replacement message and inserting a footer instead, but there are two issues here. The $dropped_filename variable doesn't work in the footer and there is still a txt file in the email with a default message.

Any suggestions would be welcome?

Cheers

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
shannon.hagan Tue, 04/28/2009 - 16:01
User Badges:

If you use Add-Footer("yourdisclaimer") where yourdisclaimer is a message disclaimer. This will show it inline and not as an attachment. If you are using 6.5.1; however, dropped_filenames is not getting populated properly (bug id: 46586) - it used to. I would recommend that you get added to the bug id.

pommie_ironport Thu, 04/30/2009 - 00:57
User Badges:

Thanks for the reply, I wasn't too clear earlier. I am using "Add-Footer" and this puts the text in the email fine but the dropped_filenames variable doesn't work with this and if you leave the Replacement message field empty in the "Strip Attachment by File Info" it still attaches a txt file with a default message in it.

Ideally I would like to get rid of the txt attachment and insert a more meaningful message in the email that includes the dropped_filenames variable.

adam.barker Thu, 04/30/2009 - 07:13
User Badges:

I had the same issue...and there is an article about in in the knowledgebase.

Use the localeconfig command via CLI and accept Y for all options. It's to do with mismatches with encoding and running that command will force the footer into the body.

pommie_ironport Mon, 05/04/2009 - 00:47
User Badges:

Thanks for the reply. Again maybe i wasnt clear. I am at the moment adding a footer which inserts text in to the email OK. So I dont need to run the localeconfig as this works fine.

My issue is that I want to provide users with clear information and use the $dropped_filenames variable and have the text in the email NOT in a TXT attachment.

If I use the "Add-footer" the $dropped_filenames variable doesn't work. If I use the replacement message field in the "Strip Attachment by File Info" filter the right information is there but in a txt attachment.

Actions

This Discussion