ATA 186 behaving unreliably with Toshiba DP120F fax machines

Unanswered Question
Apr 28th, 2009
User Badges:

I have problems with Toshiba DP120 F fax machines receiving faxes via an ATA 186 and an H323 gateway. The gateway is configured with "Modem passthrough nse g711ulaw" and the ATA has the audiomode 0x00150015 and connectmode parameter 0x90000400. Has anyone else had problems with these devices in fax passthrough mode and solved the problem? The strange thing is that some of them seem to work fine and others do not - is there a known software issue with the device?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 2.5 (2 ratings)
Loading.
PETER NEGUS Tue, 04/28/2009 - 02:02
User Badges:

I should add that the fax machines connect fine, but the problem ones fall over and abort the call after receiving one or two pages.

riazshams Tue, 04/28/2009 - 08:02
User Badges:

guys,


same problem i am also facing .. i have ATA 186 configured with CCME 7.1 .. some time fax working fine and some time not receiving neither sending ... ATAs are integrated with Toshiba and Sharp fax machine ... on both of them i am facing same problem !!!!

can any one tell how to troubleshoot it ??


Regards

ivarnhagen Tue, 04/28/2009 - 11:26
User Badges:

Hi,


also had fax problems on ATAs before. Try setting the send/recv rate on the fax to 9600 baud, and turn ECM off. This does the trick most of the time.


hth

riazshams Wed, 04/29/2009 - 09:08
User Badges:

hi ,


i tried to set 9600 baud on fax machine but no luck ... any other reason !!!!


Regards

chadlincoln Wed, 04/29/2009 - 09:20
User Badges:
  • Bronze, 100 points or more

Check for problems on the switchport interface connected to the ATA. Check for errors/collisions on all interfaces in the path between the two devices. So is this on-net faxing? Faxing from one ATA to another or from the PSTN to the ATA?

riazshams Fri, 05/01/2009 - 00:37
User Badges:

hi,


internal fax between ATA's are working fine .. but if some one send fax from PSTN or if i send fax to PSTN then i am facing problem .. some time fax are going some time not some time not going complete ... below is sh run of ccme ...


Building configuration...

!

boot-start-marker

boot system flash:c3845-adventerprisek9-mz.124-24.T.bin

boot-end-marker

!

!

!

no ip dhcp use vrf connected

ip dhcp excluded-address 172.100.1.1 172.100.1.20

!

ip dhcp pool voice

network 172.100.1.0 255.255.255.0

default-router 172.100.1.1

option 150 ip 172.100.1.2

!

!

no ip domain lookup

ip multicast-routing

no ipv6 cef

!

multilink bundle-name authenticated

!

!

!

!

isdn switch-type primary-4ess

!

voice-card 0

!

!

!

voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

supplementary-service h450.12

fax protocol cisco

h323

sip

registrar server expires max 3600 min 3600

!

!

!

voice class codec 1

codec preference 1 g711ulaw

!

!

!

voice translation-rule 1

rule 1 /^17380/ //

rule 2 /17380038/ /083/

!

voice translation-rule 300

rule 1 // /17380/

!

!

voice translation-profile PSTNIN

translate called 1

!

voice translation-profile PSTNOUT

translate calling 300

!

!

controller E1 0/2/0

framing NO-CRC4

pri-group timeslots 1-28

!

!

interface GigabitEthernet0/1

ip address 172.100.1.2 255.255.0.0

duplex auto

speed auto

media-type rj45

!

interface Serial0/2/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-4ess

isdn incoming-voice voice

isdn bchan-number-order ascending

no cdp enable

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 172.100.1.1

ip http path flash:

!


tftp-server flash:ATA030204SCCP090202A.zup

!

control-plane

!

!

!

voice-port 0/2/0:15

translation-profile incoming PSTNIN

translation-profile outgoing PSTNOUT

!

!

mgcp fax t38 ecm

!

!

dial-peer voice 21 pots

destination-pattern 9[1-9].......

direct-inward-dial

port 0/2/0:15

forward-digits 8

!

dial-peer voice 100 voip

no modem passthrough

incoming called-number ...

dtmf-relay h245-alphanumeric h245-signal

codec g711ulaw

fax rate disable

fax protocol pass-through g711ulaw

no vad

!

!

telephony-service

max-ephones 240

max-dn 720

ip source-address 172.100.1.2 port 2000

auto assign 1 to 8

system message Your current options

load ata ATA030204SCCP090202A

time-zone 22

time-format 24

max-conferences 12 gain -6

call-forward pattern 1...

call-forward pattern 3...

call-forward pattern 4...

moh moh.wav

multicast moh 239.10.16.4 port 2000

web admin system name cisco password cisco

dn-webedit

time-webedit

transfer-system full-consult

transfer-pattern 3...

transfer-pattern 1...

transfer-pattern 4...

secondary-dialtone 9

create cnf-files version-stamp 7960 Apr 30 2009 08:36:02

!

!

ephone-template 1

softkeys idle Redial Newcall Cfwdall Dnd

!

!

ephone-template 2

softkeys idle Redial Newcall Dnd

!

ephone-dn 68

number 5

call-forward all 000

!

!

ephone-dn 69

number 100 secondary 17380100

label ATA

!

!

ephone-dn 70

number 110 secondary 17380110

label ATA

!

!

ephone-dn 71

number 029 seconday 17380029

label ATA

!

!

ephone-dn 72

number 043 secondary 17380043

label ATA

!

!

ephone-dn 73

number 122 secondary 17380122

label ATA

!

!

ephone-dn 74

number 129 secondary 17380129

label ATA

!

ephone 69

mac-address 0024.C40D.BF24

max-calls-per-button 2

type ata

button 1:69

!

ephone 70

mac-address 24C4.0DBF.2401

max-calls-per-button 2

type ata

button 1:70

!

ephone 71

mac-address 0024.C40D.BD6C

button 1:71

!

ephone 72

mac-address 24C4.0DBD.6C01

max-calls-per-button 2

type ata

!

ephone 73

mac-address 0024.C40D.C027

max-calls-per-button 2

type ata

button 1:73

!

!

!

ephone 74

mac-address 24C4.0DC0.2701

max-calls-per-button 2

type ata

button 1:74

!

Please reply urgently if there is any mistake in dial-peers !!!


Regards

riazshams Fri, 05/01/2009 - 01:16
User Badges:

one thing i forget to tell in above post, that i have tested out the analog line by replacing it from ATA to directly in FAx machine .. its working fine ... so it means there isnt any problem into analog line ...


i guess problem is in dial-peer of sending and receiving fax ... .

can any one tell via have alook on above config that where is the mistake ...


plz reply urgently and thanks in advance

chadlincoln Fri, 05/01/2009 - 05:36
User Badges:
  • Bronze, 100 points or more

Try putting this under your dial-peer voice 100 voip:


modem passthrough nse codec g711ulaw

dtmf-relay rtp-nte h245-alphanumeric

fax rate disable


Please rate if this helps.

riazshams Sat, 05/02/2009 - 13:39
User Badges:

Gents,


I have got resolved ATA working fine without configuring dial-peer and special commands for Fax or ATA's ...

actually i had uploaded the firmware of ATA into flash but after uploading i didnt reboot the system !!!! so yesterday i just reboot my system and all things started to work perfectly !!!!


thanks for all of guys for help and suggestion .. if some one wants tell me i can share the running config ....


Thanks

paolo bevilacqua Sat, 05/02/2009 - 13:49
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Check you E1 controller, you may also having slips, for which you need network-clock-participate and network-clock-select. The usual symptom is inability to send or recieve faxes made of many pages.


Actions

This Discussion