Troubleshooting static routes

Unanswered Question
Apr 28th, 2009
User Badges:

This should be a fairly straight forward question to answer, but I can't seem to come up with a good answer. I have the following in my config:


vlan 181

name 106_Static_Routes


interface GigabitEthernet9/2

description 101, Gig2/6/1

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 181,800-999

switchport mode trunk

no ip address

no snmp trap link-status

spanning-tree portfast disable


interface Vlan181

description To 101, Gig2/6/1

ip address 172.20.20.29 255.255.255.252

no ip redirects

no ip proxy-arp

ip pim sparse-mode


ip route 192.168.52.0 255.255.255.0 172.20.20.30

ip route 192.168.122.0 255.255.255.0 172.20.20.30

ip route 192.168.173.0 255.255.255.0 172.20.20.30

ip route 192.168.174.0 255.255.254.0 172.20.20.30


router eigrp 9

redistribute static metric 1000000 10 255 1 1500

passive-interface default

no passive-interface Serial1/1/0

no passive-interface Serial1/1/1

no passive-interface Serial1/1/2

no passive-interface GigabitEthernet5/1

no passive-interface GigabitEthernet5/2

no passive-interface GigabitEthernet6/1

no passive-interface GigabitEthernet7/5

no passive-interface GigabitEthernet7/6

no passive-interface GigabitEthernet7/7

no passive-interface GigabitEthernet8/23

no passive-interface GigabitEthernet9/22

network 10.18.0.0 0.0.127.255

network 172.20.0.0 0.0.127.255

no auto-summary


The problem is when interface g9/2 goes down, the static routes stay in the routing table and it blackholes traffic. I've tried clearing the routing table, but it stays.


I am running the following image:

s72033-ipservicesk9_wan-mz.122-18.SXF6.bin


Show inventory:

NAME: "5", DESCR: "WS-SUP720-3B 2 ports Supervisor Engine 720 Rev. 4.4"

PID: WS-SUP720-3B , VID: , SN:


NAME: "msfc sub-module of 5", DESCR: "WS-SUP720 MSFC3 Daughterboard Rev. 2.3"

PID: WS-SUP720 , VID: , SN:


NAME: "switching engine sub-module of 5", DESCR: "WS-F6K-PFC3B Policy Feature Card 3 Rev. 2.1"

PID: WS-F6K-PFC3B , VID: , SN:


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
John Blakley Tue, 04/28/2009 - 07:41
User Badges:
  • Purple, 4500 points or more

Are you trying to have a failover in case an interface goes down?


HTH,

John

thomaslthorne Tue, 04/28/2009 - 07:45
User Badges:

That will be our ultimate goal, but for now we are having the issue that the static route doesn't come out of the routing table when it is invalid. There are no other interfaces in the same subnet as the next hop IP, so we have to figure out why this is happening before we go any further towards any level of failover.

Edison Ortiz Tue, 04/28/2009 - 07:45
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

The problem is that Vlan181 remains up/up even when port G9/2 goes down. Make sure no other trunk or access port has Vlan181 in forwarding state.


Once you correct that problem, if G9/2 goes down (which should be the only switchport with Vlan 181 in forwarding state) then Vlan181 will go down hence removing the 172.20.20.28/30 connected route.


HTH,


__


Edison.

thomaslthorne Tue, 04/28/2009 - 07:48
User Badges:

That is the only port on the switch that VLAN 181 is allowed on. When we noticed that the static route was in the table, we also verified that int vlan181 was down down.



Edison Ortiz Tue, 04/28/2009 - 07:50
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

Can you post the show ip route while the switchport G9/2 is down?


Also, show ip cef 172.20.20.30 det and show mls cef 172.20.20.30 det will help.


__


Edison.

vineetsha Wed, 04/29/2009 - 05:48
User Badges:

Hi


The Gig port won't ever go down, neither the port nor the line protocol. (Except of-course someone pulls out the cable from the port)


So the static route won't ever get removed from the routing table. You will have to use keyword "track" with the static route. while configuring track you will have to configure rtr or ip sla (with appropriate timeout and frequeny values)depending upon ur IOS version.


Use the icmp echo option and the track will continuously monitor whether the other end /30 IP is reachable from your router or not. As soon as the other end becomes unreachable, the static route will get flushed out and what you desire shall happen.


URL:http://www.cisco.com/en/US/docs/ios/ipapp/command/reference/iap_s3.html


Just for your reference, a part of a config in one of my routers:


track 1 rtr 1 reachability

delay down 10 up 15


ip route 0.0.0.0 0.0.0.0 10.24.12.49 track 1

ip route 0.0.0.0 0.0.0.0 10.241.15.66 100


rtr 1

type echo protocol ipIcmpEcho 10.24.12.49 source-ipaddr 10.24.12.50

timeout 1500

frequency 5

rtr schedule 1 life forever start-time now


interface FastEthernet0/1.126

description *** 1 Mbps, Sify MPLS ***

bandwidth 1024

encapsulation dot1Q 126

ip address 10.24.12.50 255.255.255.252

no ip redirects

no ip unreachables

no ip proxy-arp

no ip mroute-cache

no cdp enable

crypto map XXXX





HTH


Vineet

Actions

This Discussion