QoS problems on 877W

Unanswered Question
Apr 29th, 2009
User Badges:

Can QoS be configured on the 877W router using the Fastethernet interface not the ATM0?


I have configured QoS on an 877W router but it's not effective, please advise as to where is the problem.


877W


!

ip access-list extended Gr1

permit ip any host 192.2.1.2

ip access-list extended Gr2

permit ip any host 192.2.1.3

ip access-list extended Gr3

permit ip any host 192.2.1.4

!

class-map match-any CusBusBulk

match access-group name Gr3

class-map match-any CusSysMgt

match access-group name Gr2

class-map match-any CusIntBusData

match access-group name Gr1

!

interface FastEthernet0

bandwidth 2000

service-policy output QoS

!

interface FastEthernet1

switchport access vlan 2

!

interface Vlan1

description Connection to Router 3825

bandwidth 2000

ip address 192.1.1.1 255.255.255.252

ip virtual-reassembly

!

interface Vlan2

description Home LAN

ip address 192.4.1.1 255.255.255.0

!

policy-map QoS

class CusIntBusData

bandwidth 64

police 64000 1000 1000 conform-action transmit exceed-action drop violate-action drop

class class-default

fair-queue

!

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
John Blakley Wed, 04/29/2009 - 05:42
User Badges:
  • Purple, 4500 points or more

If you're trying to control upload speed, this should work fine, but if you're trying to control download speed, you're going to have a hard time doing it. I'm assuming that you're running nat somewhere on this router (although I don't see it in the post). NAT happens before QoS methods take effect, and your returning traffic will reference your public ip address. It's hard to control your returning traffic.


HTH,

John

mailaglady2 Wed, 04/29/2009 - 06:37
User Badges:

No I am not running NAT, this is just a lab scenario. Yes I am trying to control the upload traffic, my problem here is my policing is not working so that automatically tells me my QoS is not effective. I have noticed in most of the documents that I read they use Fastethernet4 as their wan link and seemingly QoS works fine. But all the 877 that I have seen do not have F4, they only have F0 up to F3.

John Blakley Wed, 04/29/2009 - 06:49
User Badges:
  • Purple, 4500 points or more

Sorry....disregard my last post. (I thought I was answering someone else.)


If you're wanting to control traffic only on F0 (which your config suggests), you would need to have a device connected directly to F0. If you don't have anything connected directly to F0, then you can control traffic by putting your service policy on your vlan1 (if F0 is a member of that vlan).


Can you post "sh policy-map int fa0"?


HTH,

John

mailaglady2 Wed, 04/29/2009 - 10:39
User Badges:

Yes the other router is connected directly on the f0, they connected back to back.


My Vlan interface don't want to accept my service-policy, here is the output whenever I try to apply the service policy on the vlan interface


Router_877W(config-if)#service-policy output QoS

Configuration failed!


Router_877W#sh policy-map int f0

FastEthernet0


Service-policy output: QoS


Class-map: CusIntBusData (match-any)

0 packets, 0 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: access-group name Gr1

0 packets, 0 bytes

5 minute rate 0 bps

Queueing

Output Queue: Conversation 265

Bandwidth 64 (kbps)Max Threshold 64 (packets)

(pkts matched/bytes matched) 0/0

(depth/total drops/no-buffer drops) 0/0/0

police:

cir 64000 bps, bc 1000 bytes, be 1000 bytes

conformed 0 packets, 0 bytes; actions:

transmit

exceeded 0 packets, 0 bytes; actions:

drop

violated 0 packets, 0 bytes; actions:

drop

conformed 0 bps, exceed 0 bps, violate 0 bps


Class-map: class-default (match-any)

18958 packets, 1318632 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: any

Queueing

Flow Based Fair Queueing

Maximum Number of Hashed Queues 256

(total queued/total drops/no-buffer drops) 0/0/0

John Blakley Wed, 04/29/2009 - 11:12
User Badges:
  • Purple, 4500 points or more

Okay, since a device is connected directly to the port, try changing the direction of your service policy to input. See if that helps.


John

Actions

This Discussion