New to gatekeeper-controlled trunks

Unanswered Question
Apr 29th, 2009
User Badges:


I am setting up two sites; one is with CUCM, the other with CME. The CME site is able to register to a gatekeeper and so is CUCM. When a phone at the CME site dials an extension at the CUCM site, it works fine. When I place the extensions at the CUCM site in a partition, assign the gk-controlled trunk at the CUCM site a CSS for inbound calls with access to that partition it stops working (I get a message that the call can not be completed as dialed.) It acts as though the gk-controlled trunk does not have access to the extension.

If I just change the extension at the CUCM site by moving it to the default partition, it works fine and can be dialed. I've created new CSS and partitions, same problem. The phones with the CUCM site are assigned the same CSS as the gatekeeper but they seem to work fine when they dial each other. Is there anything I should be looking for on the gk-trunk?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
chadlincoln Wed, 04/29/2009 - 06:31
User Badges:
  • Bronze, 100 points or more

Did you reset the gatekeeper on the CM side after you changed the CSS? It looks like you're doing it right if the only change that breaks it is the CSS changes.

Chris Deren Wed, 04/29/2009 - 10:44
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,
  • Cisco Designated VIP,

    2017 IP Telephony, Contact Center, Unified Communications

Are you sure the call arrives on this trunk? Do you perhaps have another direct trunk to CM?

How are you directing the call to CM, I would imagin it's using tech-prefix, i.e. 1#, so make sure there is no other translation pattern for example involved in your call flow, search the dial plan for a string matching your tech-prefix.



ivanromanov Mon, 08/03/2009 - 12:29
User Badges:

Hello Shikamarunara,

Did you resolve your issue?

I am facing the same issue with my gatekeeper trunk.

I have tried this with the extensions from the range I do not use just in case some overlapping but with no lack. As soon as I put the extension(any of them) to the partition "none" then I can get to it via my gatekeeper trunk.

All other gateways are in the same css as the trunk and I have no problem with them!


ivanromanov Mon, 08/03/2009 - 12:56
User Badges:


I'll answer to my own question:) Yes this was driving me mad!

Did you check if you have any old testing configs in place???

From my previous testing I had h323 gateway configured (the same router as from which I tried to call) and for some reason from the gatekeeper the call was going to that h323 gateway configuration and not the trunk.

I still do not understand why this happed. But when I deleted that h323 then everything start working as expected.



This Discussion