Historical Reports login issue

Unanswered Question
Apr 29th, 2009

Hi

I've assigned Reporting privelleges to some users within UCCX version 7.0.

I installed ths Historical Reports plugin. When I launch Historical Reports and enter the username and password I get an error message:

Failed to login to database. Ask your administrator to check the database user id and password that is dynamically obtained from the Unified CCX server'

For the username I enter the CCM userid.

Does anybody know how this problem can be resolved?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
chadlincoln Wed, 04/29/2009 - 09:05

You posted this twice so I'm not sure which one you'll check, but here was my response in the other thread:

Log in to IPCC.

Click Tools, User management

Click the user who is trying to log in.

Confirm that their selected capabilities contains Reporting.

Please rate if this helped. Thanks.

siggiv Tue, 04/13/2010 - 00:54

Hi

I know this is an old post but I had the same problem and I the problem was I had changed the SQL Authentication to Mixed mode because of Wallboard testing. Change it to Windows only and it works.

Now I just have to find out what to do with my wallboard.

Aaron Harrison Tue, 04/13/2010 - 00:59

Hi

Mixed mode authentication is actually supported in 7.0 SR5; if you upgrade to that, check the release notes for details.

Regards

Aaron

Please rate helpful posts...

siggiv Tue, 04/13/2010 - 01:05

Thank you but I have 7.0(1)SR05_Build504 and I tried changing the hrcConfig file to "AUTH=1" but no luck.

Have your tried this your self ?

Aaron Harrison Tue, 04/13/2010 - 01:49

Hi

Yes, tried this in the lab, and have one customer running this quite happily.

The confusing bit is the hrcconfig.ini, as you suggest. There is a section like this:

DRIVER=SQL Server

SERVER=192.168.0.171\CRSSQL

DATABASE=db_cra

AUTH=1

NETWORK=dbmssocn

PORT=4433

UID=db_cra

;Use this key to specify alternative values to connect to Cisco CRA database instead of using the default values

DRIVER=

SERVER=

DATABASE=

PORT=

;AUTH specifies the authentication mode to use while connecting to the database.

;Use one of the following values:

;1 - Windows NT Authentication

;2 - Mixed Mode Authentication

AUTH=1

The release notes point out you should set AUTH=1. The first time I did this, I made the mistake of reading the descriptions in the ini file, and set it to 2 - no good.

The first section seems to update dynamically; you don't edit that.

It's the second AUTH= parameter that you need to set.

Then it worked fine for me...

Aaron

Actions

This Discussion