Historical Reports login issue

Unanswered Question
Apr 29th, 2009


I've assigned Reporting privelleges to some users within UCCX version 7.0.

I installed ths Historical Reports plugin. When I launch Historical Reports and enter the username and password I get an error message:

Failed to login to database. Ask your administrator to check the database user id and password that is dynamically obtained from the Unified CCX server'

For the username I enter the CCM userid.

Does anybody know how this problem can be resolved?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
chadlincoln Wed, 04/29/2009 - 09:03

Log in to IPCC.

Click Tools, User management

Click the user who is trying to log in.

Confirm that their selected capabilities contains Reporting.

Please rate if this helped. Thanks.

dc-csa-north Fri, 05/15/2009 - 03:36


Were you able to find any solution to this issue? I am also facing the same problem. My users inside Appadmin do have IVR and ICD Historical reporting checkboxes enabled and have given them reporting rights as well.

gsidhu Fri, 05/15/2009 - 08:35


Yes I was.

The error was occurs because I had set up the CCX SQL database is set up to use mixed mode authentication. (This was required for the Wallboard product installation.

To get around it, I edited the hrcConfig.ini file on the PC that had the Historical Reporting application installed.

This file is located in C:\Program Files\Cisco UCCX Historical Reports\.

Near the bottom there is an entry for AUTH, which is empty by default. Set the value to 1, save the file, then try logging in again.

If you still have problems set this valuue to 2.



This Discussion