Assistance with adding L3 Switch w/ new Voice Vlan to current environment

Answered Question
Apr 29th, 2009

Hi Guys,

I've taken over a network and have the following issue that I would like your advice on. I need to add a new POE switch with a new Voice Vlan to the existing EIGRP network. The problem is that we have a router which I do no have access to (great things about inherited networks). The network topology is as described:

New 3750 -- Layer 2 2950 -- 2811 Router

The 2811 Router has EIGRP configured:

router eigrp 200

no auto-summary

no eigrp log-neighbor-changes

network 10.1.1.0

network 10.1.2.0

network 10.1.3.0

The router's fa0/0 interface is connected to the 2950 switch on the 10.1.1.0 network.

My plan is that since I cannot access the 2811 router, I will add the 3750 as a Layer 3 device that will share the new voice Vlan 10.1.100.0.

What I did was create Vlan interfaces on the 3750 for both the 10.1.1.0 network and the 10.1.100.0 network.

I then created a dot1q trunk to the 2950 and only shared access to vlan 1 on that trunk (since the 2950 is in the most basic configuration and does not know about the new voice vlan).

On the 2950, I added the following configuration for the trunk:

interface FastEthernet0/24

description Trunk to 3750

switchport trunk allowed vlan 1

switchport mode trunk

On the 3750, here are the trunk port and eigrp configs:

interface FastEthernet0/48

description Trunk to 2950

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1

switchport mode trunk

router eigrp 200

no auto-summary

no eigrp log-neighbor-changes

network 10.1.1.0

network 10.1.100.0

When I added the switch to the network, I was able to access the 10.1.10 data network to the new switch, however, the EIGRP routes were not showing up in the 3750, and the new voice vlan could not be accessed from anywhere else on the network.

I have a feeling it may be the configuration of the trunk between the 3750 and the 2950.

Any advice or recommendations are appreciated.

Thank you friends.

I have this problem too.
0 votes
Correct Answer by Jon Marshall about 7 years 7 months ago

What feature set are you using on the 3750 ie. IP BASE, IP Services ??

If you do a "sh ip eigrp neigh" on the 3750 what do you get ?

Have you tried running a "debug eigrp packets" on the 3750 ?

Jon

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
lamav Wed, 04/29/2009 - 15:55

Hi:

What exactly are you trying to accomplish?

What is vlan 1? Is it 10.1.1.0?

You need to establish an eigrp neighbor relationship between the router and the 3750 to be able to exchange routing information.

Example:

3750

int vlan 1

ip address 10.1.1.1 255.255.255.252

router

int f0/0

ip address 10.1.1.2 255.255.255.252

tomtom001 Thu, 04/30/2009 - 03:51

Correct, Vlan 1 has a 10.1.1.0 address. I am able to communicate to the new switch via its data 10.1.1.0 vlan. It just seems that the L3 EIGRP info is not propogating the the 3750, and the Voice Vlan is not being advertised. I have a device on the voice vlan, so I know the SVI is up.

Correct Answer
Jon Marshall Thu, 04/30/2009 - 06:37

What feature set are you using on the 3750 ie. IP BASE, IP Services ??

If you do a "sh ip eigrp neigh" on the 3750 what do you get ?

Have you tried running a "debug eigrp packets" on the 3750 ?

Jon

tomtom001 Thu, 04/30/2009 - 10:30

Thank you for all your help guys. Just an update. It was found that there was another HP switch in between the 2950 and the 2811. The EIGRP packets were being dropped at that level, so we removed the HP and everything came up. Sorry for the firedrill.

lamav Thu, 04/30/2009 - 10:34

No problem...just gimme my 5 points and all will be forgotten :-)

Actions

This Discussion