7940G phone boots to message "Ethernet disconnected."

Unanswered Question
Apr 29th, 2009

I have a CCM version 4.1(3) environment. Two of our 7940G phones have developed the same issue. Upon boot-up, the phones display Universal Application Loader at the top of the screen with the following message, "Ethernet disconnected." The phones never get any further. From within CCM, the phones do not receive an IP address and are not registered. I have placed different phones on the same network drop without issue. The two problematic phones have been tested on different connections but the behavior does not change. Attempts to reset them back to factory default fail as well. I do not believe the phone's Ethernet port is bad because they are receiving power over the Ethernet as evidenced by the visable display.

Any thoughts or suggestions?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
chadlincoln Wed, 04/29/2009 - 17:13

You usually only see that when you plug in a power brick and don't have anything plugged into the ethernet port. If you plug a working phone into the same port, does it come up and register normally? If that's the case, the only thing you really can do is try to do the factory reset as you said you have. If that doesn't fix it, you may have to RMA the phone if possible. Keep us posted on what you find out.

Rate if this helps.

sbarfknecht Thu, 04/30/2009 - 06:33

Yes, if I plug a known good 7940 into the same drop with the same cable, the phone boots up correctly and registers. Looking at the possibility that the phone's main board may have failed.

antonyice1 Thu, 04/30/2009 - 00:08

I bet it is a physical layer problem.I get this error most of the time and I change the network cable between the IP phone and Patch panel (or to the switch incase if you don't have a patch panel) and it works.

Charles Hill Fri, 05/01/2009 - 19:03

I have seen this trouble on several occassions and the only resolution that i have found is rma. To troubleshoot I swap the phone in question with a working phone and the trouble follows the bad phone. If you find another resolution, please let us know. Thanks.

sbarfknecht Fri, 05/08/2009 - 09:01

I opened a TAC case for the phone and ended up with an RMA replacement. The phone had a failed circuit board. Thank you to all who responded.

gftvandevere Mon, 03/07/2011 - 09:04

I'll bet in the past 10 years I've replaced several hundred phones with this symptom. In spite of the tech bulletin stating this problem went away in 2004, it does not appear to have done so. I just completed another RMA today.

We replace the phone to verify that the port and cable are good. The error message always remains and they don't pass traffic to the connected PC.

We do a power cycle when we bring it in for testing, and when that doesn't resolve the issue we do a reset to factory default. When that inevitably doesn't resolve the issue, we RMA it, and to their immense credit, Cisco has never challenged a single request.

amchugh01 Thu, 06/18/2015 - 10:08


I inherited a rather old batch of Cisco gear and just ran into this very same problem. I had a Cisco 7942G phone, just bought, and plugged it into a network run that I just had fixed. The phone works fine when I plug it into my testing switch, a Catalyst 3560 PoE-48 but when I plugged it into the line where it should be staged, linked to a Catalyst 3560 24-PS, it gave me this exact error "Ethernet Disconnected". I tested the line with my Fluke LinkRunner and the circuit was perfect. I plugged in my Macbook at the staging area and everything worked perfectly. The phone would just not register at all. 

For me the fix was to login to the 3560 24-PS switch and look at the port that I had plugged it into. Fa0/24 was set to "no mdix auto". When I cleared the setting and saved the config, everything then worked perfectly. The phone registered and everything. 

As I said, I inherited a network that is mostly wreckage. It's getting better, slowly. Very slowly. :) HTH.



This Discussion