VPN behind ADSL modem???

Unanswered Question
Apr 30th, 2009
User Badges:

Hi experts,

I have ADSL internet connection with static IP. Behind the ADSL modem i have Cisco 871 with which i'm trying to make VPN tunnel with 3rd party organization. My ADSL wan interface has ip address x.x.x.40 and lan interface 192.168.1.1

My Cisco router has WAN ip 192.168.1.2 and default route:

ip route 0.0.0.0 0.0.0.0 int fa 4 192.168.1.1


VPN configuration is :


crypto isakmp policy 1

encr 3des

authentication pre-share

group 2

lifetime 3600

crypto isakmp key 6 fN?b?UCXW?uH-QKeqh7q#U6tMA%w2j address x.x.x.10 no-xauth

!

!

crypto ipsec transform-set sped-am esp-3des esp-sha-hmac

!


crypto map tunnel-map 10 ipsec-isakmp

set peer x.x.x.10

set transform-set sped-am

set pfs group2

match address 105

!

access-list 105 permit ip 192.168.101.64 0.0.0.15 host x.x.x.x

!

interface fa 4

crypto map tunnel-map

!


Becouse i have to connect to 3rd party organization, they recognized me by my real ip that is on the WAN interface on my ADSL modem. That's why i am doing this:


crypto map tunnel-map local-address loopback 0

int loopback 0

ip add x.x.x.40 255.255.255.0

!

But still I can't make VPN connection with the organization!

What else I have to do ?


pls help!

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Collin Clark Thu, 04/30/2009 - 07:10
User Badges:
  • Purple, 4500 points or more

NAT on your cable modem is breaking it. What you need to do is setup your cable modem to bridge. Then the public IP address is assigned to the router.


Hope this helps.

zenon_electronics Wed, 05/06/2009 - 22:02
User Badges:

Hi, thank you for your help!

I know if i setup the cable modem to work as bridge it will work, but I need some way to do it without to be in bridge mode (if it is possible)! The reason that i want to do this is because i don't really have permission to make any changes to the ADSL modem.

Thanks!

Actions

This Discussion