Router 7206 VXR

Unanswered Question
Apr 30th, 2009

Hi,

we are currently using the router 7206 VXR NPEG1 which is going to HIGH CPU Utllization at some times so now we planning to upgrade the existing router to NPEG2

this will make change in the handling CPU utlization or the same as the existing hardware

as per my understanding the packet handling capacity is double from the existing router

i have given the traffic flow in one of our interface

GigabitEthernet0/3 is up, line protocol is up

Internet address is xx.xx.xx.17/24

MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

reliability 255/255, txload 57/255, rxload 71/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Full-duplex, 1000Mb/s, media type is RJ45

output flow-control is XON, input flow-control is XON

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:00, output 00:00:00, output hang never

Last clearing of "show interface" counters 27w3d

Input queue: 0/75/15679/924143 (size/max/drops/flushes); Total output drops: 3

9315

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 280168000 bits/sec, 384472 packets/sec

5 minute output rate 223970000 bits/sec, 311684 packets/sec

1405404492 packets input, 3683894657 bytes, 670 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 10968 throttles

0 input errors, 0 CRC, 0 frame, 13275561 overrun, 0 ignored

0 watchdog, 55464 multicast, 0 pause input

0 input packets with dribble condition detected

3168067588 packets output, 3916374664 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 babbles, 0 late collision, 0 deferred

1 lost carrier, 0 no carrier, 0 pause output

0 output buffer failures, 0 output buffers swapped out

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joseph W. Doherty Thu, 04/30/2009 - 10:00

In theory, yes the G2 should provide 2x the forwarding performance of the G1. However, before jumping into a new faster processor, you might verify your existing configuration supports optimal performance and/or your high CPU is interrupt CPU.

vinoth.kumar Thu, 04/30/2009 - 15:08

Hi,

Thanks for your reply

you mean to say some configuration in our existing router is making CPU utlization high

we are using all 5 interface in the existing router asper the traffic flow analysis

1. including all 5 interface the traffic rate will be around 450 mb

which factor will increase the CPU utlization

please find small config

interface GigabitEthernet0/1

ip address 192.168.191.1 255.255.255.0

duplex auto

speed auto

media-type rj45

no negotiation auto

!

interface GigabitEthernet0/2

ip address 192.168.190.1 255.255.255.0

duplex auto

speed auto

media-type rj45

no negotiation auto

!

interface GigabitEthernet0/3

ip address xx.xx.xx.17 255.255.255.0

duplex auto

speed auto

media-type rj45

no negotiation auto

!

interface FastEthernet2/0

ip address xx.xx.35.17 255.255.255.0

no ip redirects

no ip proxy-arp

duplex auto

speed auto

no cdp enable

!

interface FastEthernet2/1

ip address xx.xx.xx.42 255.255.255.252

no ip redirects

no ip proxy-arp

duplex full

speed 100

no cdp enable

!

router bgp xxxxx

no synchronization

bgp log-neighbor-changes

network xx.xxx.0.0 mask 255.255.248.0

network xx.xx.xx.0

redistribute connected

neighbor xx.xx.xx.45 remote-as 41847

neighbor xx.xx.xx.45 description NEWER STEALTH 21032007

neighbor xx.xx.xx.45 shutdown

neighbor xx.xx.xx.45 next-hop-self

neighbor xx.xx.xx.45 send-community

neighbor xx.xx.xx.45 soft-reconfiguration inbound

neighbor xx.xx.xx.45 distribute-list 56 in

neighbor xx.xx.xx.45 prefix-list MY_ROUTES out

neighbor xx.xx.xx.45 route-map STEALTH-IN in

neighbor xx.xx.xx.45 route-map STEALTH-OUT out

neighbor xx.xx.xx.41 remote-as 8757

neighbor xx.xx.xx.41 description NEW STEALTH

neighbor xx.xx.xx.41 shutdown

neighbor xx.xx.xx.41 next-hop-self

neighbor xx.xx.xx.41 send-community

neighbor xx.xx.xx.41 soft-reconfiguration inbound

neighbor xx.xx.xx.41 distribute-list 56 in

neighbor xx.xx.xx.41 prefix-list MY_ROUTES out

neighbor xx.xx.xx.41 route-map STEALTH-IN in

neighbor xx.xx.xx.41 route-map STEALTH-OUT out

neighbor xx.xx.xx.252 remote-as 15830

neighbor xx.xx.xx.252 description NEW TELECITY

neighbor xx.xx.xx.252 next-hop-self

neighbor xx.xx.xx.252 send-community

neighbor xx.xx.xx.252 soft-reconfiguration inbound

neighbor xx.xx.xx.252 prefix-list MY_ROUTES out

neighbor xx.xx.xx.252 route-map TELECITY-IN in

neighbor xx.xx.xx.252 route-map TELECITY-OUT out

neighbor xx.xx.xx.251 remote-as 15830

neighbor xx.xx.xx.251 next-hop-self

neighbor xx.xx.xx.251 send-community

neighbor xx.xx.xx.251 soft-reconfiguration inbound

neighbor xx.xx.xx.251 prefix-list MY_ROUTES out

neighbor xx.xx.xx.251 route-map TELECITYBAK-IN in

neighbor xx.xx.xx.251 route-map TELECITYBAK-OUT out

no auto-summary

!

ip default-gateway xx.xx.xx.252

ip classless

ip route 10.39.0.0 255.255.0.0 192.168.190.2

!

!

!

ip prefix-list MY_ROUTES seq 5 permit xx.xx.0.0/21

ip prefix-list MY_ROUTES seq 10 permit xx.xx.141.0/24

!

vinoth.kumar Thu, 04/30/2009 - 20:09

hi,

i attached the show command details

#sh ip bgp summary

BGP router identifier xx.xx.xx.17, local AS number xxx404

BGP table version is 1442283, main routing table version 1442283

285671 network entries using 34280520 bytes of memory

571332 path entries using 29709264 bytes of memory

96870/48424 BGP path/bestpath attribute entries using 12011880 bytes of memor

88246 BGP AS-PATH entries using 2405928 bytes of memory

1 BGP community entries using 24 bytes of memory

0 BGP route-map cache entries using 0 bytes of memory

0 BGP filter-list cache entries using 0 bytes of memory

Bitfield cache entries: current 1 (at peak 2) using 32 bytes of memory

BGP using 78407648 total bytes of memory

285661 received paths for inbound soft reconfiguration

BGP activity xx8168/xx2493 prefixes, 1716814/1145482 paths, scan interval 60

s

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/Pfx

xxx.xx.170.45 4 xx847 0 0 0 0 0 never Idle (Adm

xxx.xx.129.41 4 xx757 0 0 0 0 0 never Idle (Adm

xxx.xx.34.252 4 xx830 155002 1392 1442296 0 0 03:26:42 xx5661

xxx.xx.35.251 4 xx830 0 0 0 0 0 never Active

#sh proc cpu

CPU utilization for five seconds: 49%/49%; one minute: 50%; five minutes: 49%

PID Runtime(ms) Invoked uSecs 5Sec 1Min 5Min TTY Process

Giuseppe Larosa Fri, 05/01/2009 - 00:58

Hello Vinoth,

to see what processes use more of cpu resources you can use

sh proc cpu sorted 1min

However, from what you have attached you can see that

CPU utilization for five seconds: 49%/49%; one minute: 50%; five minutes: 49%

all cpu usage at 5 seconds is caused by cpu interrupts (second number after / is 49 as the one before).

This is likely caused by packet forwarding activity.

You can verify if the most efficient forwarding method CEF is in use

see

http://www.cisco.com/en/US/products/hw/routers/ps359/products_tech_note09186a00801c2af0.shtml#inapprop_swpath

Be aware that there have been other threads of people that have reported that after having moved from NPE-G1 to NPE-G2 the cpu usage was reduced but less then how much expected.

More specifically port adapters look like to require more resources then built-in GE ports.

Hope to help

Giuseppe

Joseph W. Doherty Fri, 05/01/2009 - 03:48

Agree with Giuseppe. Both about high CPU most likely caused by packet forwarding, and G2 doesn't always seem to offer the performance boost expected (reason for my "in theory" within my original post).

However, now seeing that it looks like this router might have full Internet BGP routes, and considering your remark about "HIGH CPU Utllization at some times" in your OP, I'm wondering whether you're also seeing 100% spikes about once a minute that are not interrupt CPU, and/or input queue drops. If so, that's likely to be the BGP scanner.

vinoth.kumar Fri, 05/01/2009 - 04:34

Hi,

Thanks for your reply

Now we replaced the router to NPEG2 and also facing an same issue that cpu going high

# sh proc cpu sorted 1min

CPU utilization for five seconds: 92%/90%; one minute: 91%; five minutes: 90%

#sh interfaces

GigabitEthernet0/1 is up, line protocol is up

5 minute input rate 177982000 bits/sec, 247547 packets/sec

5 minute output rate 224304000 bits/sec, 303500 packets/sec

3276901558 packets input, 1599562081 bytes, 0 no buffer

Received 5804 broadcasts, 0 runts, 0 giants, 0 throttles

4 input errors, 0 CRC, 0 frame, 0 overrun, 4 ignored

0 watchdog, 10921 multicast, 0 pause input

0 input packets with dribble condition detected

4006620133 packets output, 3049708805 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

5 unknown protocol drops

39 unknown protocol drops

FastEthernet0/2 is administratively down, line protocol is down

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

0 packets input, 0 bytes

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog

0 input packets with dribble condition detected

0 packets output, 0 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

1 unknown protocol drops

7 unknown protocol drops

GigabitEthernet0/3 is up, line protocol is up

)

5 minute input rate 260050000 bits/sec, 357435 packets/sec

5 minute output rate 209131000 bits/sec, 293521 packets/sec

523524606 packets input, 2153785717 bytes, 182 no buffer

Received 19954 broadcasts, 0 runts, 0 giants, 0 throttles

7 input errors, 0 CRC, 0 frame, 0 overrun, 7 ignored

0 watchdog, 50 multicast, 0 pause input

0 input packets with dribble condition detected

3957494965 packets output, 3670444482 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

47 unknown protocol drops

474 unknown protocol drops

FastEthernet3/1 is up, line protocol is up

5 minute input rate 29593000 bits/sec, 45253 packets/sec

5 minute output rate 34373000 bits/sec, 53008 packets/sec

670566917 packets input, 2892638133 bytes

Received 2223 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog

0 input packets with dribble condition detected

798594375 packets output, 7697882 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

3 unknown protocol drops

23 unknown protocol drops

and also i have seen some unknown protocol drops what it means

Can i know how much packet traffic can handle by this router NPEG2 since we are facing an issue regulary

suggest us some solution

# sh version

Cisco IOS Software, 7200 Software (C7200P-SPSERVICESK9-M), Version 12.4(15)T8, R

ROM: System Bootstrap, Version 12.4(12.2r)T, RELEASE SOFTWARE (fc1)

BOOTLDR: Cisco IOS Software, 7200 Software (C7200P-K91P-M), Version 12.2(31)SB10

, RELEASE SOFTWARE (fc2)

Cisco 7206VXR (NPE-G2) processor (revision A) with 917504K/65536K bytes of memor

y.

Processor board ID 21268035

MPC7448 CPU at 1666Mhz, Implementation 0, Rev 2.2

6 slot VXR midplane, Version 2.0

3 FastEthernet interfaces

3 Gigabit Ethernet interfaces

2045K bytes of NVRAM.

250880K bytes of ATA PCMCIA card at slot 2 (Sector size 512 bytes).

65536K bytes of Flash internal SIMM (Sector size 512K).

Configuration register is 0x2102

Joseph W. Doherty Fri, 05/01/2009 - 16:34

"Now we replaced the router to NPEG2 and also facing an same issue that cpu going high "

Assuming the interrupt CPU is still most of the CPU consumed, and assuming you've checked against Cisco suggestions for high CPU usage and optimal configuration, then you just might still have more load than the G2 can carry. I.e. a faster platform is needed.

"and also i have seen some unknown protocol drops what it means "

Might be non-IP packets, but considering the very, very small count vs. your total traffic, might not be worth worrying about.

PS:

The only other "engine" that might offer you more performance with your 7206VXR, would be the discontinued NSE-1. Besides being discontined, it might only 256 MB.

vinoth.kumar Fri, 05/01/2009 - 23:32

Hi,

I seen that BGP scanner is taking high amount of CPU

CPU utilization for five seconds: 79%/75%; one minute: 76%; five minutes: 75%

PID Runtime(ms) Invoked uSecs 5Sec 1Min 5Min TTY Process

194 2895768 11181 258990 3.61% 0.53% 0.45% 0 BGP Scanner

74 8128 664655 12 0.07% 0.08% 0.02% 2 Virtual Exec

68 346736 507309 683 0.07% 0.05% 0.06% 0 IP Input

2 16840 28017 601 0.00% 0.02% 0.00% 0 Load Meter

3 1052 3733 281 0.00% 0.00% 0.00% 0 BGP Open

5 3061640 155746 19657 0.00% 0.42% 0.49% 0 Check heaps

13 232 138466 1 0.00% 0.00% 0.00% 0 IPC Deferred Por

16 18128 2483827 7 0.00% 0.01% 0.00% 0 EnvMon

10 56 2325 24 0.00% 0.00% 0.00% 0 IPC Dynamic Cach

18 0 1 0 0.00% 0.00% 0.00% 0 Crash writer

12 356 138466 2 0.00% 0.00% 0.00% 0 IPC Periodic Tim

20 9392 144200 65 0.00% 0.00% 0.00% 0 ARP Background

33 536 139099 3 0.00% 0.00% 0.00% 0 GraphIt

19 65528 121370 539 0.00% 0.00% 0.00% 0 ARP Input

40 49756 43371 1147 0.00% 0.01% 0.00% 0 Net Background

43 700 138460 5 0.00% 0.00% 0.00% 0 TTY Background

44 8536 139098 61 0.00% 0.00% 0.00% 0 Per-Second Jobs

63 2476 4187671 0 0.00% 0.02% 0.02% 0 ACCT Periodic Pr

64 11332 39157 289 0.00% 0.00% 0.00% 0 CDP Protocol

84 678104 2838 238937 0.00% 0.06% 0.05% 0 IP Background

85 25332 9372 2702 0.00% 0.00% 0.00% 0 IP RIB Update

86 12460 202602 61 0.00% 0.01% 0.00% 0 CEF process

163 400 138389 2 0.00% 0.00% 0.00% 0 trunk conditioni

179 120 980 122 0.00% 0.00% 0.00% 0 Net Input

180 460 28017 16 0.00% 0.00% 0.00% 0 Compute load avg

181 54392 2386 22796 0.00% 0.00% 0.00% 0 Per-minute Jobs

182 28 1169 23 0.00% 0.00% 0.00% 0 CC-API_VCM

183 2688 1365784 1 0.00% 0.01% 0.00% 0 CCPROXY_CT

187 63092 2394 26354 0.00% 0.00% 0.00% 0 Shelf Hello Proc

190 1044 140281 7 0.00% 0.00% 0.00% 0 NTP

191 40 2330 17 0.00% 0.00% 0.00% 0 DHCPD Database

192 112964 333488 338 0.00% 0.00% 0.00% 0 BGP Router

193 11548 36066 320 0.00% 0.00% 0.00% 0 BGP I/O

195 212 3 70666 0.00% 0.00% 0.00% 0 BGP Event

Can any one help on this

Joseph W. Doherty Sat, 05/02/2009 - 03:59

I mentioned the BGP scanner in my 3rd post.

There's not much you can do about its CPU consumption, but further explanation and how to mitigate some of its effects can be found here: http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a00809d16f0.shtml

PS:

The BGP scanner will commonly spike your CPU, but this doesn't tend to drive the long term CPU average high. In your case, you might have a long term high interrupt CPU. Again, if this is due to just traffic volume, you'll need a better performing device.

vinoth.kumar Sun, 05/03/2009 - 22:51

Thanks all for your suggestion

can anyone suggest us For traffic forwaring upto 1Gig which router will handle this much of traffic

Provided we will go for the upgraded platform

Joseph W. Doherty Mon, 05/04/2009 - 02:33

On the 7200, the discontinued NSE-1 might. Next up would be a 7304 with NSE-150, then the ASR series.

vinoth.kumar Wed, 05/06/2009 - 05:06

as per cisoc specfication the CPU processor concern its double from the earlier version

NPEG1 - Processor

700 MHz Broadcom BCM1250 processor.

NPEG2 - Processor

1.67-GHz Motorola Freescale 7448 processor

But still after upgrading to the NPEg2 also the cpu utlization is same

Suggest me the solution

The traffic handlig capacity per interface is

G0/1 - 153MB

G0/2 - 35MB

G0/3 - 225MB

Fa 3/1 - 2 MB

IP cef

router bgp xx04

no synchronization

bgp log-neighbor-changes

network xx.xx.0.0 mask 255.255.248.0

network xxx.xx.141.0

redistribute connected

neighbor xx.34.xx.45 remote-as xx847

neighbor xx.34.xx.45 description NEWER STEALTH 21032007

neighbor xx.34.xx.45 shutdown

neighbor xx.34.xx.45 next-hop-self

neighbor xx.34.xx.45 send-community

neighbor xx.34.xx.45 soft-reconfiguration inbound

neighbor xx.34.xx.45 distribute-list 56 in

neighbor xx.34.xx.45 prefix-list MY_ROUTES out

neighbor xx.34.xx.45 route-map STEALTH-IN in

neighbor xx.34.xx.45 route-map STEALTH-OUT out

neighbor xx.58.xx.41 remote-as xx57

neighbor xx.58.xx.41 description NEW STEALTH

neighbor xx.58.xx.41 shutdown

neighbor xx.58.xx.41 next-hop-self

neighbor xx.58.xx.41 send-community

neighbor xx.58.xx.41 soft-reconfiguration inbound

neighbor xx.58.xx.41 distribute-list 56 in

neighbor xx.58.xx.41 prefix-list MY_ROUTES out

neighbor xx.58.xx.41 route-map STEALTH-IN in

neighbor xx.58.xx.41 route-map STEALTH-OUT out

neighbor XX.20.XX.252 remote-as xx30

neighbor XX.20.XX.252 description NEW TELECITY

neighbor XX.20.XX.252 next-hop-self

neighbor XX.20.XX.252 send-community

neighbor XX.20.XX.252 soft-reconfiguration inbound

neighbor XX.20.XX.252 prefix-list MY_ROUTES out

neighbor XX.20.XX.252 route-map TELECITY-IN in

neighbor XX.20.XX.252 route-map TELECITY-OUT out

neighborXX.20.XX.251 remote-as xx30

neighborXX.20.XX.251 description BACKUP TELECITY 27-10-2006

neighborXX.20.XX.251 next-hop-self

neighborXX.20.XX.251 send-community

neighborXX.20.XX.251 soft-reconfiguration inbound

neighborXX.20.XX.251 prefix-list MY_ROUTES out

neighborXX.20.XX.251 route-map TELECITYBAK-IN in

neighborXX.20.XX.251 route-map TELECITYBAK-OUT out

no auto-summary

!

ip default-gateway xx.20.34.xx2

no ip forward-protocol nd

!

!

!

ip access-list extended CIRPACK

permit ip host xxx.x.97.132 any

permit ip host xx.x.47.228 any

deny ip any any log

ip access-list extended GigaBit0_1

permit ip host XX.XXX.0.203 any

permit ip any host XX.XXX.0.203

!

!

ip prefix-list MY_ROUTES seq 5 permit xx.xx.0.0/21

ip prefix-list MY_ROUTES seq 10 permit xxx.xx.141.0/24

the Cef is enabled for all interfaces

Paolo Bevilacqua Wed, 05/06/2009 - 18:57

I think you should consider run an IOS version with proven ISP use like S or SX trains.

Actions

This Discussion