How to change to spanish auto attendant on UC520

Unanswered Question
Apr 30th, 2009

Hi guys,

I'm having difficult times figuring out this issue, we have a branch down in Chile, they have an ASA5505 and behind it there is an UC520, the UC520 ATT is in English but they want to change the ATT to Spanish obviously most of their costumers are Latinos and the employees would like to have it in Spanish rather than English.

My question is, is this easy to do? what kind of scrip do I need? where can I download it? Is there a links with step by step instructions? Can I have english and Spanish at the same time? or is it better to have only one language setup on the UC520?

Advice please, I'll really appreciate it


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
leonardofernandez Thu, 04/30/2009 - 10:17

Thanks Skyler

I look at this document there are a lot of good info there, I appreciated it


gjpelaezg Sat, 06/27/2009 - 12:42


I had a problem while configuring auto attendant to spanish too. My problem is that when i want to save the new configuration, system prompts this error:

Language pack not available in the location
C:\Archivos de programa\Cisco Systems\CiscoSMB\Cisco Configuration Assistant\appdata\phoneloads\cue-vm-lang-pack.
C:\Archivos de programa\Cisco Systems\CiscoSMB\Cisco Configuration Assistant\appdata\phoneloads\cue-vm-es_MX-lang-pack.

The extrange thing is that I have the most actual files of the language in that directory, cue-vm-es_MX-langpack.ise.7.0.3.prt1 and cue-vm-langpack.ise.7.0.3.pkg

So... can anybody tell me what is wrong in this?

PD: I have Cisco IOS Software, UC500 Software (UC500-ADVIPSERVICESK9-M), Version 12.4(20)T2

Thanks a lot for your help


Marcos Hernandez Mon, 06/29/2009 - 06:43

Can you please include a CCA log while you do the upgrade?

C:\Program Files\Cisco Systems\CiscoSMB\Cisco Configuration Assistant\Application_Log_xx


Marcos Hernandez
Technical Marketing Engineer
Cisco Systems, Inc.

gjpelaezg Wed, 07/01/2009 - 12:00

Hi Marcos

Sorry for the delay... the attachment is the information in Application_Log_Wed_Jul_01_13_22_56_CDT_2009 ... this is the last configuration that I did to the UC500... i do not know where is exactly the information of last upgrade... if there is any... because the software never let me upgrade voicemail... I follow the instructions in cca-uc500-localization-v2 archive for "UC500 localization" and at "III. CUE Voicemail Localization" step 7 i get an error that says that cue-vm-k9.ise.7.0.3.pkg whas not supported... this is the image:

Thanks for your help


PD: The instructions that I follow were the ones in the link that you give to Leonardo.

gjpelaezg Tue, 07/07/2009 - 09:32

Hi Marcos.

There is another problem, I was looking for a way to personalize the record of voicemail message because of the problem that I have changing language and I tried to retry the configuration process with Telephony Setup Wizard and CCA 2.0 software promts an error message that tells me that I can not use it if UC500 is not in factory default configuration... can you tell me if there is a way to personalize voicemail message or if you found a way to solve my first problem with the process to change language?...

Thank you for your atention and help


Marcos Hernandez Thu, 07/09/2009 - 10:19

Hi Gustavo,

Sorry for the delay. I was out of the office these last few days. I will take a look at the applications log and get back to you ASAP.



leonardofernandez Thu, 04/30/2009 - 10:15

Thank you Eivind,

I'm going to try to download the scrip and follow the steps, I'll let you know



leonardofernandez Tue, 05/05/2009 - 12:04

Hi guys,

Sorry for taking so long to reply back, I download some of the prompts that i though are the correct ones then I used cca to upload them and install them on the uc520 but i did not change anything, everything is still in English do you think I missed a prompt or something? these are the one i downloaded

"CME-locale-es_ES-,  cue-vm-es_CO-lang-pack., cue-vm-lang-pack."

I have cca 1.9, i when under telephony, voice then region tab, not sure is that is the correct way to do the changes, I'm  familiarly with CLI so I can do some modification if its necesary, I really don't care if the ip phones are in English but the auto attendant is important to be in Spanish, please advise.



leonardofernandez Tue, 05/05/2009 - 13:03

I'm going to try it tomorrow, I'll let you know the outcome

Thank you for the info, it's seems what i needed it


Marcos Hernandez Sun, 07/12/2009 - 08:25


I reviewed the logs and nothing jumps out as being the evident root cause. I am going to kindly ask you to go ahead and open a TAC case. The procedure mentioned earlier in this thread should have been enough, but for some reason, it is not working in your case. TAC will help you determine this.


Marcos Hernandez
Technical Marketing Engineer
Cisco Systems, Inc.

gjpelaezg Mon, 07/13/2009 - 10:08

Hi Marcos

It is ok, I will do that, thank you for your help and attention.


Eivind Jonassen Thu, 04/30/2009 - 10:02

Hi Leo,

Not sure if you can do several voicemail languages from CCA, but the upgrade to spanish should be easy. Download the Spanish voicemail prompts from and then open CCA and choose spanish instead of english under telephony setup under configuration tab. I do belive you can have voicemail language setup per phone, but I guess you have to use CLI to configure it. Open a case with TAC is the easy way to go on this issue I think.




This Discussion