Terminal Server / Comm Server Async Port appending FF

Unanswered Question
Apr 30th, 2009

Hi there techies

I have a 2800 with NM-8AM and HWIC-2A/S

We are using the router as an async terminal server for a SCADA application to communicate to an RTU using serial DNP.

The Cisco router is appending an extra FF to DNP messages that contains an FF (ie FF becomes FF FF). This results in a CRC error.

The SCADA server uses reverse telnet to connect to the 2800 on port 60xx (raw telnet).

This problem occurs on the modems, async lines and aux port.

I'm sure there is a way around this, as I've configured similar systems before, but for the moment the line command I require escapes me. I don't have access to the exact config at the moment, but I'm hoping someone knows the answer.

From memory the line config is:

no flowcontrol

speed 9600

no exec

no escape

telnet transparent

transport input all

modem inout

TIA

Ian

I have this problem too.
1 vote
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (3 ratings)
Loading.
seungyoul-lee Tue, 06/04/2013 - 14:35

Hi Ian,

I am struggling to solve the same problem. I have exactly same configuration and environment such as SCADA and DNP3 traffic.

Did you solve the problem? If you did, could you share the solution?

Thomas,

renoufi Tue, 06/04/2013 - 16:11

I asked our DNP expert and he definately remembers the issue and has come across it several times but can't remember the exact fix.

It's to do with the Cisco device recognising the FF as an escape character and appending the additional FF.

You might try using port 2xxx or 4xxx to do the reverse telnet.

The other command of use might be:

autocommand telnet /stream

Look here:

http://www.cisco.com/en/US/products/sw/iosswrel/ps1835/products_configuration_guide_chapter09186a00801545a1.html

seungyoul-lee Wed, 06/05/2013 - 13:40

Hi Renoufi,

Thanks for good advice.

But I cannot solve this problem yet. I have two sites using Cisco router carrying serial DNP message. One site is using ISR2911 and another site is uing CGR2010. ISR2911 is working very well but CGR2010 has a problem described above. Both routers have exactly same configuration. If anyone has a clue or experience about this, please leave a reply.

renoufi Wed, 06/05/2013 - 17:34

Please confirm whether you tried ports 2xxx, 4xxx and 6xxx for your serial connections. They all behave differently.

Also confirm whether you tried the command:

autocommand telnet /stream

If that doesn't work, post your config for anlysis.

seungyoul-lee Thu, 06/06/2013 - 14:26

Hi Renoufi,

I have solved the problem due to the advise from you.

I changed the port number from 2XXX to 4XXX and then the CRC error has been removed.

I really appreciate for your help.

renoufi Wed, 06/12/2013 - 02:52

No worries. Please mark your question as answered and rate the reply.

Actions

This Discussion