Giuseppe Larosa Fri, 04/24/2009 - 13:51
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Sanjoy,

1522 bytes 802.1Q tagged frames are baby giants and the switch may be able to handle them without changing the system mtu.


For this reason you are still able to ping with 1500 byte IP packet size even if you use an 802.1Q trunk.


Hope to help

Giuseppe


sanjoy2006 Fri, 05/01/2009 - 09:55
User Badges:

2950 support 1522 frame size , I have very much doubt .


1518 it support frame header 14 plus 4 byte header



Giuseppe Larosa Fri, 05/01/2009 - 10:12
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Sanjoy,


see it as feature that allows you to send IPv4 packets with size 1500 bytes over a trunk without need to explicitly change the system MTU.


>> 2950 support 1522 frame size , I have very much doubt .


I used C2950 and we tested it.

We did MTU tests for MPLS VPN with the C2950 on the access link side.



by the way it is:

1500 byte IP

14 byte ethernet header

4 byte FCS

+

4 byte 802.1Q tag

1522


I agree this switch doesn't support system mtu command but trunking has to be transparent to end users so baby giants are supported


see


http://www.cisco.com/en/US/docs/switches/lan/catalyst2950/software/release/12.1_22_ea11x/command/reference/bootldr.html


about trunks


http://www.cisco.com/en/US/docs/switches/lan/catalyst2950/software/release/12.1_22_ea11x/configuration/guide/swvlan.html#wp1200245




you cannot use it on a MPLS network but as access switch it can do its job on any combination of access ports and 802.1Q trunks.


Hope to help

Giuseppe


Richard Burts Fri, 05/01/2009 - 18:00
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Sanjoy


I believe that the explanation is that when they build the switch interface logic to support dot1x trunking, that they build in support to recognize and process the tagging, including the extra 4 bytes, without considering it a violation of the system MTU. This is very similar to the way that they support the Ethernet header and the FCS which make a frame actually 1518 without violating the System MTU of 1500.


HTH


Rick

sanjoy2006 Sat, 05/02/2009 - 02:56
User Badges:

right this is the exact RCA I have also find same document .

Thanks rburt.

sanjoy2006 Sat, 05/02/2009 - 04:03
User Badges:

As a workaround, you can enable a port for trunking in order to support baby giants. When you enable a port for 802.1q trunking, the switch automatically assumes that an extra four bytes of data are appended on, and increment the frame size of the L2 packet. Note that ISL encapsulation is not supported on these platforms.Hence, for implementations that require exactly one tag to be carried (either 802.1q or MPLS, but not both), you can configure the port as a trunk port to force the switchport to accept an extra four bytes of data. If the port were to carry multiple VLANs for VLAN-ID tagging or 802.1p prioritization, configure the port as a 802.1q trunk. However, even if VLAN tagging is not necessary, but you want the increased four-byte support, you can configure the port as a 802.1q trunk. Change the Native VLAN to be the one desired to carry

the traffic. When you do so, you can accommodate an extra four bytes of data

Now take a look

2960-24TT-L

!

interface GigabitEthernet0/1

switchport trunk allowed vlan 1,13,20,23,69

switchport mode trunk not support baby giant support only 1518

load-interval 30

end

3560G

interface GigabitEthernet0/1

switchport trunk encapsulation dot1q So support baby giant 1522

switchport trunk allowed vlan 1,50

switchport mode trunk

load-interval 30

storm-control multicast level bps 500m

spanning-tree portfast

spanning-tree bpdufilter enable

spanning-tree guard root

end


3750G


interface GigabitEthernet1/0/28

switchport trunk encapsulation dot1q it will support 1522 baby giant

switchport trunk allowed vlan 10,51

switchport mode trunk

speed nonegotiate

spanning-tree portfast

end

Actions

This Discussion